summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2016-08-04 21:52:12 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2016-08-04 21:53:22 +0200
commit749ff44295a5c4a9124c60208ab060415173c4cc (patch)
treec83b49f68271e0b959cbde005ce5a32964eae4a8 /net-misc/plowshare
parentnet-misc/chrome-remote-desktop: version bump to 52.0.2743.74 (diff)
downloadgentoo-749ff44295a5c4a9124c60208ab060415173c4cc.tar.gz
gentoo-749ff44295a5c4a9124c60208ab060415173c4cc.tar.bz2
gentoo-749ff44295a5c4a9124c60208ab060415173c4cc.zip
net-misc/plowshare: version bump
Package-Manager: portage-2.3.0
Diffstat (limited to 'net-misc/plowshare')
-rw-r--r--net-misc/plowshare/Manifest1
-rw-r--r--net-misc/plowshare/plowshare-2.1.5.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/net-misc/plowshare/Manifest b/net-misc/plowshare/Manifest
index 98123eed93ee..268b4f922255 100644
--- a/net-misc/plowshare/Manifest
+++ b/net-misc/plowshare/Manifest
@@ -2,3 +2,4 @@ DIST plowshare-1.2.0.tar.gz 253572 SHA256 0f1ff5d2986334209389857d6c6f3f63162d66
DIST plowshare-2.1.1.tar.gz 90653 SHA256 96b3acd1dba1b14f3009334520969af4c00c8f4b7f5d924a26decc4b4a817e53 SHA512 4aae7c64ce8123301b241d31a0f25ffe414295d5d8b354423530f47cbe3dd91a4bbe57a686a6c56015dab37c6b463334b4f9165b570a2c0314c25ee94bc255fc WHIRLPOOL cde48f76136901c4c009611556beda92aa3b4e5ed9fc5d94487ed69d5f11745995dca7ba7bbd2dabe516161efe9e705a7bfbdd21423d96f506aae4079b847a34
DIST plowshare-2.1.2.tar.gz 90913 SHA256 d9b9f2aa464d7d2966f49704234c79139d1162705a0a553a3059c68fbf4be21a SHA512 ffe18bd1aa1e0523eee218c8f80ce906648a9a0457e0cb64f682d9f52d05fdec2f1ff236e74b323a9b051aaf87d597ef10c08d9fa539a169db780d3955f05885 WHIRLPOOL a752043fc9d37510d6c5ba24547b0c66d9316a9526d4abc580443757b069c8a1d9808815dde0ecbfafcfbabcbeb1a7ad3ef6bd73d62870da7e494bad8851c453
DIST plowshare-2.1.3.tar.gz 91534 SHA256 2f54325158203cf64f0041b20708d47cac1f5a936f90e99aaad299cefd14757d SHA512 759110b798de36b77737cebcf19a81872b4224df8c668ffe151415f3b15be2e50843ba865185e20d20fa17affa95228085edd86e1986aa4b1f22fa4ca921eaed WHIRLPOOL e33944c69caee6062ce7e1db9bddb3b53e7613d3131497b1596947a1362635a74b2448a85a9a3f6ee908ddd6cb94e238f4ab0b9b485ed3cf10fe360fb868559d
+DIST plowshare-2.1.5.tar.gz 94268 SHA256 31a1d379b738b007ff000107b03562bf73ed5f05d7fa1ebef50082f0799a59ce SHA512 1724580dd9fa818821e9686b758f904aad408c409e23e68444dbf6fc80cae81b03159fcfc816e7273777b02b1dbcc3ab93e13cc2b05f20145850a1c931da4342 WHIRLPOOL 853255b2a3abbe40349112e322e4e1bd9ca9261fe714e2d7f3802398b318a96e346238bc888eefeb78edd5050b19850b82c72050da59772ca1db0af41c14d3cb
diff --git a/net-misc/plowshare/plowshare-2.1.5.ebuild b/net-misc/plowshare/plowshare-2.1.5.ebuild
new file mode 100644
index 000000000000..eb0d7ec23a13
--- /dev/null
+++ b/net-misc/plowshare/plowshare-2.1.5.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit bash-completion-r1
+
+DESCRIPTION="Command-line downloader and uploader for file-sharing websites"
+HOMEPAGE="https://github.com/mcrapet/plowshare"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE="bash-completion +javascript view-captcha"
+
+SRC_URI="https://github.com/mcrapet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+RDEPEND="
+ >=app-shells/bash-4
+ || ( app-text/recode ( dev-lang/perl dev-perl/HTML-Parser ) )
+ dev-vcs/git
+ || ( media-gfx/imagemagick[tiff] media-gfx/graphicsmagick[imagemagick,tiff] )
+ net-misc/curl
+ sys-apps/util-linux
+ javascript? ( || ( dev-lang/spidermonkey:0 dev-java/rhino ) )
+ view-captcha? ( || ( media-gfx/aview media-libs/libcaca ) )"
+DEPEND=""
+
+# NOTES:
+# javascript dep should be any javascript interpreter using /usr/bin/js
+
+src_prepare() {
+ # Fix doc install path
+ sed -i -e "/^DOCDIR/s|plowshare|${PF}|" Makefile || die "sed failed"
+
+ if ! use bash-completion
+ then
+ sed -i -e \ "/^install:/s/install_bash_completion//" \
+ Makefile || die "sed failed"
+ fi
+
+ default
+}
+
+src_compile() {
+ # There is a Makefile but it's not compiling anything, let's not try.
+ :
+}
+
+src_test() {
+ # Disable tests because all of them need a working Internet connection.
+ :
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" \
+ PLOWSHARE_FORCE_VERSION="${PV}" install
+}
+
+pkg_postinst() {
+ elog "plowshare is not delivered with modules by default anymore"
+ elog "Per-user modules can be installed/updated with the plowmod command"
+ if ! use javascript; then
+ ewarn "Without javascript you will not be able to use modules"
+ ewarn "requering a Javascript shell (/usr/bin/js)"
+ fi
+}