summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/python-x2go
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/python-x2go')
-rw-r--r--net-misc/python-x2go/Manifest2
-rw-r--r--net-misc/python-x2go/metadata.xml9
-rw-r--r--net-misc/python-x2go/python-x2go-0.5.0.3.ebuild24
-rw-r--r--net-misc/python-x2go/python-x2go-0.5.0.4.ebuild24
4 files changed, 59 insertions, 0 deletions
diff --git a/net-misc/python-x2go/Manifest b/net-misc/python-x2go/Manifest
new file mode 100644
index 000000000000..8424be062ea1
--- /dev/null
+++ b/net-misc/python-x2go/Manifest
@@ -0,0 +1,2 @@
+DIST python-x2go-0.5.0.3.tar.gz 197897 SHA256 b6bd8fe2944b285b393accfd270c6c963a3fe21cead5f81c1983573d339c194e SHA512 cb826bfe064fa22d3dd3be2176e54ca6ff3e7e4c49271f4f33072c491222ce2e5164d5000da0cca02f1a612c1f61adc1d61e5702e11ef6d4e5a5454f61f48a86 WHIRLPOOL 0775ec1edcbeb514ed2cf0fd5fee687c9b8c1656d4ac52e7ae789edb1c3fbfd6981778410270ab3fbed75ef2f4ae907e63a271a660123bf88a1d3fd868828bb2
+DIST python-x2go-0.5.0.4.tar.gz 198280 SHA256 db971e96cc32d10782fdfbce04f1f8316c63510872d03cae99842bf96e2ab6c9 SHA512 d643f681da6c8c108ea2368a6f27c20d91f6175530182c057b660a54e4ea33b7fbf1a829777dd6d6984f61fc7dfe6a1b544b868a5d2f664e4621e22da7b981a9 WHIRLPOOL 0d183531aff77bdadba9c1072408af6c21ab727afcbbfefc63c030642b73eba205e7714ce8c14b67ff2d171ec71a92767d3d9afb8400034625b763174b8a7fe0
diff --git a/net-misc/python-x2go/metadata.xml b/net-misc/python-x2go/metadata.xml
new file mode 100644
index 000000000000..710937bd9d58
--- /dev/null
+++ b/net-misc/python-x2go/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>nx</herd>
+ <longdescription>
+The Python X2Go module integrates X2Go client support into your python programmes.
+Python X2Go is used in the headless X2Go client "pyhoca-cli" and by the tiny systray GUI applet "pyhoca-gui"
+ </longdescription>
+</pkgmetadata>
diff --git a/net-misc/python-x2go/python-x2go-0.5.0.3.ebuild b/net-misc/python-x2go/python-x2go-0.5.0.3.ebuild
new file mode 100644
index 000000000000..d6010aff42b5
--- /dev/null
+++ b/net-misc/python-x2go/python-x2go-0.5.0.3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+inherit distutils-r1
+
+DESCRIPTION="X2Go client-side Python API"
+HOMEPAGE="http://www.x2go.org"
+SRC_URI="http://code.x2go.org/releases/source/${PN}/${P}.tar.gz"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# TODO: minimal USE flag in net-misc/nx, we only need nxproxy/nxcomp
+DEPEND="dev-python/gevent[${PYTHON_USEDEP}]
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-python/python-xlib[${PYTHON_USEDEP}]
+ net-misc/nx"
+RDEPEND="${DEPEND}"
diff --git a/net-misc/python-x2go/python-x2go-0.5.0.4.ebuild b/net-misc/python-x2go/python-x2go-0.5.0.4.ebuild
new file mode 100644
index 000000000000..d6010aff42b5
--- /dev/null
+++ b/net-misc/python-x2go/python-x2go-0.5.0.4.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+inherit distutils-r1
+
+DESCRIPTION="X2Go client-side Python API"
+HOMEPAGE="http://www.x2go.org"
+SRC_URI="http://code.x2go.org/releases/source/${PN}/${P}.tar.gz"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# TODO: minimal USE flag in net-misc/nx, we only need nxproxy/nxcomp
+DEPEND="dev-python/gevent[${PYTHON_USEDEP}]
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-python/python-xlib[${PYTHON_USEDEP}]
+ net-misc/nx"
+RDEPEND="${DEPEND}"