summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/ris-linux
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/ris-linux')
-rw-r--r--net-misc/ris-linux/Manifest1
-rw-r--r--net-misc/ris-linux/files/binlsrv.confd2
-rw-r--r--net-misc/ris-linux/files/binlsrv.initd31
-rw-r--r--net-misc/ris-linux/files/setup.py9
-rw-r--r--net-misc/ris-linux/metadata.xml7
-rw-r--r--net-misc/ris-linux/ris-linux-0.4-r1.ebuild38
6 files changed, 88 insertions, 0 deletions
diff --git a/net-misc/ris-linux/Manifest b/net-misc/ris-linux/Manifest
new file mode 100644
index 000000000000..eb7b6e504ae0
--- /dev/null
+++ b/net-misc/ris-linux/Manifest
@@ -0,0 +1 @@
+DIST ris-linux-0.4.tar.gz 21634 SHA256 196c7441f498154d1ae41ef4f1e5107296b7de39f345c763ccce2e913432ae19 SHA512 e9eea14b45c060844e22dc3baa9cd15e7d202bcb3cb8b069b084115b05c0700bd563ed6322d675eee9baf72e8d530429d0c3137386377b6785ebc9007dbfd040 WHIRLPOOL 4607b013c46c4e657f3cac8c4a3bace495b3a7810059af2e5dda3cde04c984444cfe5074a1f86cfce48bd6546c6db79251c74f0bd97fe69744e041fbfea36989
diff --git a/net-misc/ris-linux/files/binlsrv.confd b/net-misc/ris-linux/files/binlsrv.confd
new file mode 100644
index 000000000000..2e6ed9f9090f
--- /dev/null
+++ b/net-misc/ris-linux/files/binlsrv.confd
@@ -0,0 +1,2 @@
+#Specify here path to directory with 'devlist.cache' file
+INFILE_PATH="/var/lib/ris/binl"
diff --git a/net-misc/ris-linux/files/binlsrv.initd b/net-misc/ris-linux/files/binlsrv.initd
new file mode 100644
index 000000000000..7e04b8bbe25d
--- /dev/null
+++ b/net-misc/ris-linux/files/binlsrv.initd
@@ -0,0 +1,31 @@
+#!/sbin/runscript
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting binlsrv"
+ if [ -z "$INFILE_PATH" ]; then
+ eerror "Path to devlist.cache not set, please set \$INFILE_PATH in /etc/conf.d/binlsrv"
+ return 1
+ fi
+ if [ ! -e "$INFILE_PATH/devlist.cache" ]; then
+ eerror "devlist.cache not generated, please make it with infparser.py"
+ fi
+
+ start-stop-daemon --start -i --exec /usr/bin/binlsrv.py --background \
+ --make-pidfile --pidfile /var/run/binlsrv.pid --chdir "$INFILE_PATH" \
+ --stdout /var/log/binlsrv.log
+
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping binlsrv"
+ start-stop-daemon --stop -i --exec /usr/bin/binlsrv.py --pidfile /var/run/binlsrv.pid
+ eend $?
+} \ No newline at end of file
diff --git a/net-misc/ris-linux/files/setup.py b/net-misc/ris-linux/files/setup.py
new file mode 100644
index 000000000000..0873f2512c99
--- /dev/null
+++ b/net-misc/ris-linux/files/setup.py
@@ -0,0 +1,9 @@
+#!/usr/bin/env python
+
+from distutils.core import setup
+
+setup(
+ name = 'ris-linux',
+ version = 'VERSION',
+ scripts = [ 'binlsrv.py', 'decode.py', 'infparser.py', 'fixloader.py', 'modldr.py' ]
+)
diff --git a/net-misc/ris-linux/metadata.xml b/net-misc/ris-linux/metadata.xml
new file mode 100644
index 000000000000..9e11bad60c03
--- /dev/null
+++ b/net-misc/ris-linux/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>maksbotan@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/net-misc/ris-linux/ris-linux-0.4-r1.ebuild b/net-misc/ris-linux/ris-linux-0.4-r1.ebuild
new file mode 100644
index 000000000000..063729ef424e
--- /dev/null
+++ b/net-misc/ris-linux/ris-linux-0.4-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1
+
+DESCRIPTION="BINL server to doing Windows(r) RIS"
+HOMEPAGE="http://oss.netfarm.it/guides/pxe.php"
+SRC_URI="http://oss.netfarm.it/guides/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ || ( net-ftp/atftp net-ftp/tftp-hpa )
+ net-misc/dhcp
+ net-fs/samba
+ sys-boot/syslinux"
+
+python_prepare_all(){
+ sed "s:VERSION:${PV}:" "${FILESDIR}"/setup.py > "${S}"/setup.py
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ newinitd "${FILESDIR}"/binlsrv.initd binlsrv
+ newconfd "${FILESDIR}"/binlsrv.confd binlsrv
+}