summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-05-03 19:37:37 -0500
committerAustin English <wizardedit@gentoo.org>2016-05-03 19:37:37 -0500
commite80645174260d52c03050b688f19c71cc9465b74 (patch)
tree1d2eeecdbe869821c6b593a6d079788b38376543 /net-misc/rwhoisd
parentnet-misc/rwbs: remove old version (diff)
downloadgentoo-e80645174260d52c03050b688f19c71cc9465b74.tar.gz
gentoo-e80645174260d52c03050b688f19c71cc9465b74.tar.bz2
gentoo-e80645174260d52c03050b688f19c71cc9465b74.zip
net-misc/rwhoisd: use #!/sbin/openrc-run instead of #!/sbin/runscript
Gentoo-Bug: https://bugs.gentoo.org/573846 Package-Manager: portage-2.2.26
Diffstat (limited to 'net-misc/rwhoisd')
-rw-r--r--net-misc/rwhoisd/files/rwhoisd2
-rw-r--r--net-misc/rwhoisd/rwhoisd-1.5.9.5-r3.ebuild47
2 files changed, 48 insertions, 1 deletions
diff --git a/net-misc/rwhoisd/files/rwhoisd b/net-misc/rwhoisd/files/rwhoisd
index 8e02214c8d07..f6978f662e27 100644
--- a/net-misc/rwhoisd/files/rwhoisd
+++ b/net-misc/rwhoisd/files/rwhoisd
@@ -1,4 +1,4 @@
-#!/sbin/runscript
+#!/sbin/openrc-run
depend() {
use logger
diff --git a/net-misc/rwhoisd/rwhoisd-1.5.9.5-r3.ebuild b/net-misc/rwhoisd/rwhoisd-1.5.9.5-r3.ebuild
new file mode 100644
index 000000000000..3acff499f3e7
--- /dev/null
+++ b/net-misc/rwhoisd/rwhoisd-1.5.9.5-r3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils flag-o-matic user
+
+DESCRIPTION="ARIN rwhois daemon"
+HOMEPAGE="http://projects.arin.net/rwhois/"
+SRC_URI="http://projects.arin.net/rwhois/ftp/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ sys-devel/flex
+ virtual/yacc
+"
+
+pkg_setup() {
+ enewgroup rwhoisd
+ enewuser rwhoisd -1 -1 /var/rwhoisd rwhoisd
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-destdir-${PV}.patch
+ append-cflags -DNEW_STYLE_BIN_SORT
+}
+
+src_compile() {
+ emake -C common
+ emake -C regexp
+ emake -C mkdb
+ default
+}
+
+src_install () {
+ default
+ doinitd "${FILESDIR}"/rwhoisd
+ newconfd "${FILESDIR}"/rwhoisd.conf rwhoisd
+}
+
+pkg_postinst () {
+ einfo "Please make sure to set the userid in rwhoisd.conf to rwhoisd."
+ einfo "It is highly inadvisable to run rwhoisd as root."
+}