summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/shigofumi
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/shigofumi')
-rw-r--r--net-misc/shigofumi/Manifest1
-rw-r--r--net-misc/shigofumi/metadata.xml11
-rw-r--r--net-misc/shigofumi/shigofumi-0.3.ebuild51
-rw-r--r--net-misc/shigofumi/shigofumi-9999.ebuild51
4 files changed, 114 insertions, 0 deletions
diff --git a/net-misc/shigofumi/Manifest b/net-misc/shigofumi/Manifest
new file mode 100644
index 000000000000..ecd24888cec4
--- /dev/null
+++ b/net-misc/shigofumi/Manifest
@@ -0,0 +1 @@
+DIST shigofumi-0.3.tar.bz2 312184 SHA256 e6d8e4bc68ef512a73238a49342d00e44ab72649b436d5658d4e1fa0237f70ec SHA512 ef7b2894cfa217b713865c4fe24cc985b4ff963df4a5005bda06f03b3c7f358b318e68a136328787fe2dfbb8b1623fe2b2ceb9fbbd20be7f243fa79ace1b0210 WHIRLPOOL 6a64c14035deba56fba30494ae22778ec4131db4c07ec8c206137bd1d25b0691a6b6aca325d875a1d22869e855fe2cbbc564a370d235c73d3c929061cfd908d3
diff --git a/net-misc/shigofumi/metadata.xml b/net-misc/shigofumi/metadata.xml
new file mode 100644
index 000000000000..b1eba2b98a8c
--- /dev/null
+++ b/net-misc/shigofumi/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<longdescription>
+ This is command line oriented client for ISDS (Informační systém datových
+ schránek / Data Box Information System) based on libisds library.
+</longdescription>
+<maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/net-misc/shigofumi/shigofumi-0.3.ebuild b/net-misc/shigofumi/shigofumi-0.3.ebuild
new file mode 100644
index 000000000000..3881cc7400e8
--- /dev/null
+++ b/net-misc/shigofumi/shigofumi-0.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+EGIT_REPO_URI='git://repo.or.cz/shigofumi.git'
+WANT_AUTOMAKE="1.11"
+inherit base
+[[ ${PV} = 9999* ]] && inherit git-2 autotools
+
+DESCRIPTION="Command line client for ISDS"
+HOMEPAGE="http://xpisar.wz.cz/shigofumi/"
+if [[ ${PV} = 9999* ]]; then
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="http://xpisar.wz.cz/${PN}/dist/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~mips ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="debug doc nls xattr"
+
+RDEPEND="dev-libs/confuse
+ dev-libs/libxml2
+ sys-libs/readline
+ >=net-libs/libisds-0.7"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? (
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ )
+ nls? ( sys-devel/gettext )"
+
+DOCS=( NEWS README AUTHORS ChangeLog )
+
+src_prepare() {
+ [[ ${PV} = 9999* ]] && eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-fatalwarnings \
+ $(use_enable debug) \
+ $(use_enable doc) \
+ $(use_enable nls) \
+ $(use_enable xattr)
+}
diff --git a/net-misc/shigofumi/shigofumi-9999.ebuild b/net-misc/shigofumi/shigofumi-9999.ebuild
new file mode 100644
index 000000000000..3881cc7400e8
--- /dev/null
+++ b/net-misc/shigofumi/shigofumi-9999.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+EGIT_REPO_URI='git://repo.or.cz/shigofumi.git'
+WANT_AUTOMAKE="1.11"
+inherit base
+[[ ${PV} = 9999* ]] && inherit git-2 autotools
+
+DESCRIPTION="Command line client for ISDS"
+HOMEPAGE="http://xpisar.wz.cz/shigofumi/"
+if [[ ${PV} = 9999* ]]; then
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="http://xpisar.wz.cz/${PN}/dist/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~mips ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="debug doc nls xattr"
+
+RDEPEND="dev-libs/confuse
+ dev-libs/libxml2
+ sys-libs/readline
+ >=net-libs/libisds-0.7"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? (
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ )
+ nls? ( sys-devel/gettext )"
+
+DOCS=( NEWS README AUTHORS ChangeLog )
+
+src_prepare() {
+ [[ ${PV} = 9999* ]] && eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-fatalwarnings \
+ $(use_enable debug) \
+ $(use_enable doc) \
+ $(use_enable nls) \
+ $(use_enable xattr)
+}