summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/shout
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/shout')
-rw-r--r--net-misc/shout/Manifest1
-rw-r--r--net-misc/shout/files/implicitdecls.patch12
-rw-r--r--net-misc/shout/files/ldflags.patch21
-rw-r--r--net-misc/shout/files/shout-0.8.0-overflow.patch26
-rw-r--r--net-misc/shout/files/variables.diff45
-rw-r--r--net-misc/shout/metadata.xml5
-rw-r--r--net-misc/shout/shout-0.8.0-r2.ebuild42
7 files changed, 152 insertions, 0 deletions
diff --git a/net-misc/shout/Manifest b/net-misc/shout/Manifest
new file mode 100644
index 000000000000..1c757b483abf
--- /dev/null
+++ b/net-misc/shout/Manifest
@@ -0,0 +1 @@
+DIST shout-0.8.0.tar.gz 66394 RMD160 3fd2173eff61954b183f0f80191808bdfdea7ae4 SHA1 6df3755e7292daa3133e6fff7ba74711ec06bf16 SHA256 7b36712730c370f7d25271ca93291f9055bb90ee3052e7aec33b5dae205d8227
diff --git a/net-misc/shout/files/implicitdecls.patch b/net-misc/shout/files/implicitdecls.patch
new file mode 100644
index 000000000000..b7a6999f121e
--- /dev/null
+++ b/net-misc/shout/files/implicitdecls.patch
@@ -0,0 +1,12 @@
+Index: shout-0.8.0/sock.c
+===================================================================
+--- shout-0.8.0.orig/sock.c
++++ shout-0.8.0/sock.c
+@@ -25,6 +25,7 @@
+ #include <arpa/inet.h>
+ #include <sys/time.h>
+ #include <unistd.h>
++#include <string.h>
+ #endif /* !win32 */
+
+ #include "sock.h"
diff --git a/net-misc/shout/files/ldflags.patch b/net-misc/shout/files/ldflags.patch
new file mode 100644
index 000000000000..3d049d98d318
--- /dev/null
+++ b/net-misc/shout/files/ldflags.patch
@@ -0,0 +1,21 @@
+Index: shout-0.8.0/Makefile.in
+===================================================================
+--- shout-0.8.0.orig/Makefile.in
++++ shout-0.8.0/Makefile.in
+@@ -2,7 +2,6 @@
+
+ CC = @CC@
+ CFLAGS = @CFLAGS@
+-LDFLAGS = @LIBS@
+
+ SHELL=/bin/sh
+
+@@ -26,7 +25,7 @@ COMPILE_CFLAGS=$(CFLAGS) $(DEFS)
+ all: shout
+
+ shout: shout.c rand.o mpeg.o configfile.o sock.o util.o
+- $(CC) $(COMPILE_CFLAGS) -o shout shout.c rand.o mpeg.o configfile.o sock.o util.o $(LDFLAGS)
++ $(CC) $(COMPILE_CFLAGS) $(LDFLAGS) -o shout shout.c rand.o mpeg.o configfile.o sock.o util.o @LIBS@
+
+ configfile.o: configfile.c
+ $(CC) $(COMPILE_CFLAGS) -c -o configfile.o configfile.c
diff --git a/net-misc/shout/files/shout-0.8.0-overflow.patch b/net-misc/shout/files/shout-0.8.0-overflow.patch
new file mode 100644
index 000000000000..a1292423ce4b
--- /dev/null
+++ b/net-misc/shout/files/shout-0.8.0-overflow.patch
@@ -0,0 +1,26 @@
+diff --git a/shout.c b/shout.c
+index 0a1bded..00bae8d 100644
+--- a/shout.c
++++ b/shout.c
+@@ -441,7 +441,7 @@ post_config ()
+ perror ("fopen");
+ px_shutdown (44);
+ }
+- my_snprintf (pid, BUFSIZE, "%d\n", (int) getpid ());
++ my_snprintf (pid, 30, "%d\n", (int) getpid ());
+ fputs (pid, fp);
+ fclose (fp);
+ }
+diff --git a/sock.c b/sock.c
+index 4a67c00..3b4e539 100644
+--- a/sock.c
++++ b/sock.c
+@@ -81,7 +81,7 @@ sock_connect (char *hostname, int port)
+ sock_close (sockfd);
+ return -1;
+ }
+- memcpy (&server.sin_addr, &sin.sin_addr, sizeof (sin));
++ memcpy (&server.sin_addr, &sin.sin_addr, sizeof (sin.sin_addr));
+ } else {
+ host = gethostbyname (hostname);
+ if (host == NULL) {
diff --git a/net-misc/shout/files/variables.diff b/net-misc/shout/files/variables.diff
new file mode 100644
index 000000000000..afaefbcb2cad
--- /dev/null
+++ b/net-misc/shout/files/variables.diff
@@ -0,0 +1,45 @@
+diff -urN shout-0.8.0/Makefile.in shout-0.8.0-modified/Makefile.in
+--- shout-0.8.0/Makefile.in Thu Apr 20 02:31:50 2000
++++ shout-0.8.0-modified/Makefile.in Tue Jul 23 19:14:36 2002
+@@ -9,11 +9,11 @@
+ srcdir = @srcdir@
+ VPATH = @srcdir@
+
+-prefix = @prefix@/icecast
+-exec_prefix = @prefix@
+-bindir = @BINDIR@
+-etcdir = @ETCDIR@
+-logdir = @LOGDIR@
++prefix = /usr
++exec_prefix = /usr
++bindir = /usr/bin
++etcdir = /etc/shout
++logdir = /var/log/shout
+
+ DEFS = -I. @DEFS@
+
+--- shout-0.8.0/configure 2000-04-20 09:41:45.000000000 +0200
++++ shout-0.8.0/configure 2004-07-17 17:17:40.000000000 +0200
+@@ -532,20 +532,10 @@
+ prefix=$prefix
+ fi
+
+-if test "x$enable_fsstd" = "xyes"; then
+ echo "FSSTD ENABLED"
+ BINDIR="/usr/bin"
+- ETCDIR="/etc/icecast"
+- LOGDIR="/var/log/icecast"
+-else
+- echo "FSSTD DISABLED"
+- BINDIR="${prefix}/icecast/bin"
+- ETCDIR="${prefix}/icecast/etc"
+- LOGDIR="${prefix}/icecast/log"
+-fi
+-
+-
+-
++ ETCDIR="/etc/shout"
++ LOGDIR="/var/log/shout"
+
+ # Extract the first word of "gcc", so it can be a program name with args.
+ set dummy gcc; ac_word=$2
diff --git a/net-misc/shout/metadata.xml b/net-misc/shout/metadata.xml
new file mode 100644
index 000000000000..e1774e3d9ad7
--- /dev/null
+++ b/net-misc/shout/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sound</herd>
+</pkgmetadata>
diff --git a/net-misc/shout/shout-0.8.0-r2.ebuild b/net-misc/shout/shout-0.8.0-r2.ebuild
new file mode 100644
index 000000000000..a08514e2105e
--- /dev/null
+++ b/net-misc/shout/shout-0.8.0-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Shout is a program for creating mp3 stream for use with icecast or shoutcast"
+HOMEPAGE="http://www.icecast.org"
+SRC_URI="http://icecast.org/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha ~ppc sparc x86"
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/variables.diff \
+ "${FILESDIR}"/ldflags.patch \
+ "${FILESDIR}"/implicitdecls.patch \
+ "${FILESDIR}"/${P}-overflow.patch
+ rm -f sock.o
+ sed -i -e "s/-ansi//" configure
+}
+
+src_compile() {
+ tc-export CC
+ econf --sysconfdir=/etc/shout \
+ --localstatedir=/var
+ emake || die "emake failed."
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ keepdir /var/log/shout
+ fowners root:audio /var/log/shout
+ fperms 775 /var/log/shout
+ fperms 755 /etc/shout
+ fperms 644 /etc/shout/shout.conf.dist
+ dodoc BUGS CREDITS README.shout TODO
+}