summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-03-05 09:26:40 +0100
committerJeroen Roovers <jer@gentoo.org>2016-03-05 09:26:57 +0100
commit1e993862a9035cdf54e32298f593a3d03b2f94fe (patch)
tree5c24a749baabbb07bc285d7e7156ac0e6c84ae13 /net-misc/socat
parentprofiles/profiles.desc: add missing Mac OS X profiles (diff)
downloadgentoo-1e993862a9035cdf54e32298f593a3d03b2f94fe.tar.gz
gentoo-1e993862a9035cdf54e32298f593a3d03b2f94fe.tar.bz2
gentoo-1e993862a9035cdf54e32298f593a3d03b2f94fe.zip
net-misc/socat: Fix building with USE=-ssl (bug #576270 by Jan Chren (rindeal)).
Package-Manager: portage-2.2.27
Diffstat (limited to 'net-misc/socat')
-rw-r--r--net-misc/socat/files/socat-1.7.3.1-stddef_h.patch38
-rw-r--r--net-misc/socat/socat-1.7.3.1.ebuild5
-rw-r--r--net-misc/socat/socat-2.0.0_beta9.ebuild6
-rw-r--r--net-misc/socat/socat-9999.ebuild3
4 files changed, 50 insertions, 2 deletions
diff --git a/net-misc/socat/files/socat-1.7.3.1-stddef_h.patch b/net-misc/socat/files/socat-1.7.3.1-stddef_h.patch
new file mode 100644
index 000000000000..c914a817ceca
--- /dev/null
+++ b/net-misc/socat/files/socat-1.7.3.1-stddef_h.patch
@@ -0,0 +1,38 @@
+When disabling OpenSSL support, nestlex.c still needs stddef.h which is
+magically included through the OpenSSL headers otherwise.
+
+--- a/configure.in
++++ b/configure.in
+@@ -61,7 +61,7 @@
+ AC_CHECK_HEADERS(inttypes.h)
+ AC_HEADER_SYS_WAIT
+ AC_CHECK_HEADERS(fcntl.h limits.h strings.h sys/param.h sys/ioctl.h sys/time.h syslog.h unistd.h)
+-AC_CHECK_HEADERS(pwd.h grp.h stdint.h sys/types.h poll.h sys/poll.h sys/socket.h sys/uio.h sys/stat.h netdb.h sys/un.h)
++AC_CHECK_HEADERS(pwd.h grp.h stddef.h stdint.h sys/types.h poll.h sys/poll.h sys/socket.h sys/uio.h sys/stat.h netdb.h sys/un.h)
+ AC_CHECK_HEADERS(pty.h)
+ AC_CHECK_HEADERS(netinet/in.h netinet/in_systm.h)
+ AC_CHECK_HEADERS(netinet/ip.h, [], [], [AC_INCLUDES_DEFAULT
+--- a/config.h.in
++++ b/config.h.in
+@@ -189,6 +189,9 @@
+ /* Define if you have the <grp.h> header file. */
+ #undef HAVE_GRP_H
+
++/* Define if you have the <stddef.h> header file. */
++#undef HAVE_STDDEF_H
++
+ /* Define if you have the <stdint.h> header file. */
+ #undef HAVE_STDINT_H
+
+--- a/sysincludes.h
++++ b/sysincludes.h
+@@ -51,6 +51,9 @@
+ #if HAVE_SYS_TIME_H
+ #include <sys/time.h> /* select(); OpenBSD: struct timespec */
+ #endif
++#if HAVE_STDDEF_H
++#include <stddef.h>
++#endif
+ #if HAVE_STDINT_H
+ #include <stdint.h> /* uint8_t */
+ #endif
diff --git a/net-misc/socat/socat-1.7.3.1.ebuild b/net-misc/socat/socat-1.7.3.1.ebuild
index 998dc35f1929..e46c58a43438 100644
--- a/net-misc/socat/socat-1.7.3.1.ebuild
+++ b/net-misc/socat/socat-1.7.3.1.ebuild
@@ -3,7 +3,7 @@
# $Id$
EAPI=5
-inherit eutils flag-o-matic toolchain-funcs
+inherit autotools eutils flag-o-matic toolchain-funcs
DESCRIPTION="Multipurpose relay (SOcket CAT)"
HOMEPAGE="http://www.dest-unreach.org/socat/"
@@ -31,6 +31,9 @@ DOCS=(
src_prepare() {
epatch "${FILESDIR}"/${PN}-1.7.3.0-filan-build.patch
+ epatch "${FILESDIR}"/${PN}-1.7.3.1-stddef_h.patch
+
+ eautoreconf
}
src_configure() {
diff --git a/net-misc/socat/socat-2.0.0_beta9.ebuild b/net-misc/socat/socat-2.0.0_beta9.ebuild
index 1a833198cc0c..07429defa383 100644
--- a/net-misc/socat/socat-2.0.0_beta9.ebuild
+++ b/net-misc/socat/socat-2.0.0_beta9.ebuild
@@ -4,7 +4,7 @@
EAPI=5
-inherit eutils flag-o-matic toolchain-funcs
+inherit autotools eutils flag-o-matic toolchain-funcs
DESCRIPTION="Multipurpose relay (SOcket CAT)"
HOMEPAGE="http://www.dest-unreach.org/socat/"
@@ -32,7 +32,11 @@ DOCS=(
src_prepare() {
epatch "${FILESDIR}"/${PN}-1.7.3.0-filan-build.patch
+ epatch "${FILESDIR}"/${PN}-1.7.3.1-stddef_h.patch
+
touch doc/${PN}.1 || die
+
+ eautoreconf
}
src_configure() {
diff --git a/net-misc/socat/socat-9999.ebuild b/net-misc/socat/socat-9999.ebuild
index 9ebf68b4de9d..076b3a140a36 100644
--- a/net-misc/socat/socat-9999.ebuild
+++ b/net-misc/socat/socat-9999.ebuild
@@ -33,6 +33,9 @@ DOCS=(
)
src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.7.3.0-filan-build.patch
+ epatch "${FILESDIR}"/${PN}-1.7.3.1-stddef_h.patch
+
eautoreconf
}