summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-04-18 17:19:17 +0200
committerJeroen Roovers <jer@gentoo.org>2019-04-18 17:19:41 +0200
commit6fac1518b00810d03d46ffddc5f030193b1deaf7 (patch)
tree6f10b59719ef6055e154f3e146069c9e3c2b15fe /net-misc/socat
parentdev-python/m2crypto: Fix crossdev (diff)
downloadgentoo-6fac1518b00810d03d46ffddc5f030193b1deaf7.tar.gz
gentoo-6fac1518b00810d03d46ffddc5f030193b1deaf7.tar.bz2
gentoo-6fac1518b00810d03d46ffddc5f030193b1deaf7.zip
net-misc/socat: Update live ebuild
Package-Manager: Portage-2.3.63, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-misc/socat')
-rw-r--r--net-misc/socat/files/socat-9999-stddef_h.patch38
-rw-r--r--net-misc/socat/socat-9999.ebuild3
2 files changed, 39 insertions, 2 deletions
diff --git a/net-misc/socat/files/socat-9999-stddef_h.patch b/net-misc/socat/files/socat-9999-stddef_h.patch
new file mode 100644
index 000000000000..802b578d4a29
--- /dev/null
+++ b/net-misc/socat/files/socat-9999-stddef_h.patch
@@ -0,0 +1,38 @@
+When disabling OpenSSL support, nestlex.c still needs stddef.h which is
+magically included through the OpenSSL headers otherwise.
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -61,7 +61,7 @@
+ AC_CHECK_HEADERS(inttypes.h)
+ AC_HEADER_SYS_WAIT
+ AC_CHECK_HEADERS(fcntl.h limits.h strings.h sys/param.h sys/ioctl.h sys/time.h syslog.h unistd.h)
+-AC_CHECK_HEADERS(pwd.h grp.h stdint.h sys/types.h poll.h sys/poll.h sys/socket.h sys/uio.h sys/stat.h netdb.h sys/un.h)
++AC_CHECK_HEADERS(pwd.h grp.h stddef.h stdint.h sys/types.h poll.h sys/poll.h sys/socket.h sys/uio.h sys/stat.h netdb.h sys/un.h)
+ AC_CHECK_HEADERS(pty.h)
+ AC_CHECK_HEADERS(netinet/in.h netinet/in_systm.h)
+ AC_CHECK_HEADERS(netinet/ip.h, [], [], [AC_INCLUDES_DEFAULT
+--- a/config.h.in
++++ b/config.h.in
+@@ -189,6 +189,9 @@
+ /* Define if you have the <grp.h> header file. */
+ #undef HAVE_GRP_H
+
++/* Define if you have the <stddef.h> header file. */
++#undef HAVE_STDDEF_H
++
+ /* Define if you have the <stdint.h> header file. */
+ #undef HAVE_STDINT_H
+
+--- a/sysincludes.h
++++ b/sysincludes.h
+@@ -51,6 +51,9 @@
+ #if HAVE_SYS_TIME_H
+ #include <sys/time.h> /* select(); OpenBSD: struct timespec */
+ #endif
++#if HAVE_STDDEF_H
++#include <stddef.h>
++#endif
+ #if HAVE_STDINT_H
+ #include <stdint.h> /* uint8_t */
+ #endif
diff --git a/net-misc/socat/socat-9999.ebuild b/net-misc/socat/socat-9999.ebuild
index dab9093e8760..dfc7752ca396 100644
--- a/net-misc/socat/socat-9999.ebuild
+++ b/net-misc/socat/socat-9999.ebuild
@@ -34,8 +34,7 @@ DOCS=(
)
PATCHES=(
- "${FILESDIR}"/${PN}-1.7.3.0-filan-build.patch
- "${FILESDIR}"/${PN}-1.7.3.1-stddef_h.patch
+ "${FILESDIR}"/${PN}-9999-stddef_h.patch
)
pkg_setup() {