summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2018-01-21 20:24:13 -0500
committerMike Frysinger <vapier@gentoo.org>2018-01-21 20:24:26 -0500
commit0b18aaa8782f3f5fdf89051e73be94b1b32c9487 (patch)
tree275ebfde22a58f71689b3841492ceb454ff4570e /net-misc/sslh
parentprofiles: Drop obsolete sci-libs/plplot p.use.stable.mask (diff)
downloadgentoo-0b18aaa8782f3f5fdf89051e73be94b1b32c9487.tar.gz
gentoo-0b18aaa8782f3f5fdf89051e73be94b1b32c9487.tar.bz2
gentoo-0b18aaa8782f3f5fdf89051e73be94b1b32c9487.zip
net-misc/sslh: version bump to 1.19
Diffstat (limited to 'net-misc/sslh')
-rw-r--r--net-misc/sslh/Manifest1
-rwxr-xr-xnet-misc/sslh/files/sslh.init.d-38
-rw-r--r--net-misc/sslh/sslh-1.19.ebuild76
-rw-r--r--net-misc/sslh/sslh-9999.ebuild17
4 files changed, 97 insertions, 5 deletions
diff --git a/net-misc/sslh/Manifest b/net-misc/sslh/Manifest
index 93816ec23f4f..fa1700a73f3f 100644
--- a/net-misc/sslh/Manifest
+++ b/net-misc/sslh/Manifest
@@ -1 +1,2 @@
DIST sslh-v1.18.tar.gz 53170 BLAKE2B 8d26bdc9950b9017279b36699821b756ea0507949edca90758cd4149aac56fd1a12e0192009ce2154af09818a6aa009fd2009f88d89dae8f76525d7aacc4a830 SHA512 3f0f61c340b689fb30015d5c73d6c29398b5c6a115ae9089d0b3c0230e99c90049df03133e4b0c3668fbfe995ed40cd3543c5764171c57e632e75bd5c3548fea
+DIST sslh-v1.19.tar.gz 57352 BLAKE2B 004084ac726c2b0a12add00da017934aa46420370bdf0e56c19443aff0a25f232324f0140cae7a09b15e885d73fae498b8c51b4c7a3f4da219bddf4abb99b412 SHA512 851a9e89098baeeb8279298b1a04527fde80e5efb4bb64006e165479ff2d7ba24b5621a99754ff906fca8c167fc1fd0bcd4b80860c999f5b9cafa408769aa18c
diff --git a/net-misc/sslh/files/sslh.init.d-3 b/net-misc/sslh/files/sslh.init.d-3
new file mode 100755
index 000000000000..7f9d61795b73
--- /dev/null
+++ b/net-misc/sslh/files/sslh.init.d-3
@@ -0,0 +1,8 @@
+#!/sbin/openrc-run
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+description="Port multiplexer for ssh/ssl/etc..."
+command="sslh"
+pidfile="/run/${SVCNAME}.pid"
+command_args="${DAEMON_OPTS} --pidfile ${pidfile}"
diff --git a/net-misc/sslh/sslh-1.19.ebuild b/net-misc/sslh/sslh-1.19.ebuild
new file mode 100644
index 000000000000..3c1ac5f9f7f7
--- /dev/null
+++ b/net-misc/sslh/sslh-1.19.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit flag-o-matic systemd toolchain-funcs
+
+DESCRIPTION="Port multiplexer - accept both HTTPS and SSH connections on the same port"
+HOMEPAGE="http://www.rutschle.net/tech/sslh.shtml"
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/yrutschle/sslh.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64 ~arm ~m68k ~mips ~s390 ~sh ~x86"
+ MY_P="${PN}-v${PV}"
+ SRC_URI="http://www.rutschle.net/tech/${PN}/${MY_P}.tar.gz"
+ S=${WORKDIR}/${MY_P}
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="caps pcre systemd tcpd"
+
+RDEPEND="caps? ( sys-libs/libcap )
+ systemd? ( sys-apps/systemd:= )
+ tcpd? ( sys-apps/tcp-wrappers )
+ >=dev-libs/libconfig-1.5"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ pcre? ( dev-libs/libpcre:= )"
+
+RESTRICT="test"
+
+src_prepare() {
+ default
+ sed -i \
+ -e '/MAN/s:| gzip -9 - >:>:' \
+ -e '/MAN=sslh.8.gz/s:.gz::' \
+ Makefile || die
+}
+
+src_compile() {
+ # On older versions of GCC, the default gnu89 variant
+ # will reject within-for-loop initializers, bug #595426
+ # Furthermore, we need to use the gnu variant (gnu99) instead
+ # of the ISO (c99) variant, as we want the __USE_XOPEN2K macro
+ # to be defined.
+ append-cflags -std=gnu99
+
+ emake \
+ CC="$(tc-getCC)" \
+ USELIBPCRE=$(usev pcre) \
+ USELIBCAP=$(usev caps) \
+ USELIBWRAP=$(usev tcpd) \
+ USESYSTEMD=$(usev systemd)
+}
+
+src_install() {
+ dosbin sslh-{fork,select}
+ dosym sslh-fork /usr/sbin/sslh
+
+ doman ${PN}.8
+
+ dodoc ChangeLog README.md
+
+ newinitd "${FILESDIR}"/sslh.init.d-3 sslh
+ newconfd "${FILESDIR}"/sslh.conf.d-2 sslh
+
+ if use systemd; then
+ # Gentoo puts the binaries in /usr/sbin, but upstream puts them in /usr/bin
+ sed -i -e 's~/usr/bin/~/usr/sbin/~g' scripts/systemd.sslh.service || die
+ systemd_newunit scripts/systemd.sslh.service sslh.service
+ exeinto /usr/lib/systemd/system-generators/
+ doexe systemd-sslh-generator
+ fi
+}
diff --git a/net-misc/sslh/sslh-9999.ebuild b/net-misc/sslh/sslh-9999.ebuild
index 8f3831fefa9b..3c1ac5f9f7f7 100644
--- a/net-misc/sslh/sslh-9999.ebuild
+++ b/net-misc/sslh/sslh-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI="6"
inherit flag-o-matic systemd toolchain-funcs
@@ -11,7 +11,7 @@ if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://github.com/yrutschle/sslh.git"
inherit git-r3
else
- KEYWORDS="amd64 ~arm ~m68k ~mips ~s390 ~sh x86"
+ KEYWORDS="~amd64 ~arm ~m68k ~mips ~s390 ~sh ~x86"
MY_P="${PN}-v${PV}"
SRC_URI="http://www.rutschle.net/tech/${PN}/${MY_P}.tar.gz"
S=${WORKDIR}/${MY_P}
@@ -31,6 +31,14 @@ DEPEND="${RDEPEND}
RESTRICT="test"
+src_prepare() {
+ default
+ sed -i \
+ -e '/MAN/s:| gzip -9 - >:>:' \
+ -e '/MAN=sslh.8.gz/s:.gz::' \
+ Makefile || die
+}
+
src_compile() {
# On older versions of GCC, the default gnu89 variant
# will reject within-for-loop initializers, bug #595426
@@ -51,12 +59,11 @@ src_install() {
dosbin sslh-{fork,select}
dosym sslh-fork /usr/sbin/sslh
- gunzip ${PN}.8.gz
doman ${PN}.8
dodoc ChangeLog README.md
- newinitd "${FILESDIR}"/sslh.init.d-2 sslh
+ newinitd "${FILESDIR}"/sslh.init.d-3 sslh
newconfd "${FILESDIR}"/sslh.conf.d-2 sslh
if use systemd; then