summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/vmpsd
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/vmpsd')
-rw-r--r--net-misc/vmpsd/Manifest1
-rw-r--r--net-misc/vmpsd/files/vmpsd-1.3-64bit.patch38
-rw-r--r--net-misc/vmpsd/files/vmpsd-1.4-snmp-support.patch56
-rw-r--r--net-misc/vmpsd/metadata.xml10
-rw-r--r--net-misc/vmpsd/vmpsd-1.4.ebuild42
5 files changed, 147 insertions, 0 deletions
diff --git a/net-misc/vmpsd/Manifest b/net-misc/vmpsd/Manifest
new file mode 100644
index 000000000000..54c70f2799e6
--- /dev/null
+++ b/net-misc/vmpsd/Manifest
@@ -0,0 +1 @@
+DIST vmpsd-1.4.tar.gz 92138 SHA256 f9f0bc2f7b5d81189794179b4706015ec01ce5a2f2c87d2d086538754559da7e SHA512 341a86f8db28f1f7a03b5581ec8f8319a175a2c5dc9c7ff5df880f4416cf048ef9e32afd6600220e48f8713d6c72c4ffae7d1e8d31c73ded466f084711580efd WHIRLPOOL 1ec27dfc0cd6ffc2c9f1fbbd6db716608af04ac8a972518e6a5ff12b01a05443b2665f3a27e7e0835d22df1ef40d0b4eb5490ea0bc2a5f60859df8c83e801837
diff --git a/net-misc/vmpsd/files/vmpsd-1.3-64bit.patch b/net-misc/vmpsd/files/vmpsd-1.3-64bit.patch
new file mode 100644
index 000000000000..c2825d4a6b76
--- /dev/null
+++ b/net-misc/vmpsd/files/vmpsd-1.3-64bit.patch
@@ -0,0 +1,38 @@
+*** vmpsd/vqp.c.orig Tue Aug 3 05:54:04 2004
+--- vmpsd/vqp.c Tue Mar 20 06:48:33 2007
+***************
+*** 127,134 ****
+ VQP_HEADER h;
+ u_char buf[MAX_PACKET_SIZE];
+ u_char *p;
+! unsigned long int data_type;
+! unsigned short int data_len;
+ unsigned int n = 0;
+
+ h.unkn1 = 0x01;
+--- 127,134 ----
+ VQP_HEADER h;
+ u_char buf[MAX_PACKET_SIZE];
+ u_char *p;
+! uint32_t data_type;
+! uint16_t data_len;
+ unsigned int n = 0;
+
+ h.unkn1 = 0x01;
+***************
+*** 310,316 ****
+ MAC_ENTRY *m;
+
+ m = find_mac(r->mac);
+! if ( (m->speed != 0) || (m->duplex != 0) )
+ set_port_speed( inet_ntoa(r->client_ip),
+ community,
+ r->port,
+--- 310,316 ----
+ MAC_ENTRY *m;
+
+ m = find_mac(r->mac);
+! if ( m != NULL && ((m->speed != 0) || (m->duplex != 0)) )
+ set_port_speed( inet_ntoa(r->client_ip),
+ community,
+ r->port,
diff --git a/net-misc/vmpsd/files/vmpsd-1.4-snmp-support.patch b/net-misc/vmpsd/files/vmpsd-1.4-snmp-support.patch
new file mode 100644
index 000000000000..66890af3a731
--- /dev/null
+++ b/net-misc/vmpsd/files/vmpsd-1.4-snmp-support.patch
@@ -0,0 +1,56 @@
+diff -Nuar vmpsd.orig/Makefile.am vmpsd/Makefile.am
+--- vmpsd.orig/Makefile.am 2004-10-31 00:59:51.000000000 +0000
++++ vmpsd/Makefile.am 2012-02-21 09:11:30.120856909 +0000
+@@ -1,5 +1,6 @@
+ bin_PROGRAMS = vmpsd
+-vmpsd_SOURCES = vmpsd.c daemon.c data.c log.c parser.c vqp.c data.h log.h vqp.h external.c external.h
++vmpsd_SOURCES = vmpsd.c daemon.c data.c log.c parser.c vqp.c snmp.c data.h log.h vqp.h external.c external.h
+ vmpsd_CFLAGS = -DSYSCONFDIR="\"${sysconfdir}\""
++vmpsd_LDADD = $(SNMP_LIB)
+ man_MANS = vmpsd.1
+ sysconf_DATA = vlan.db
+diff -Nuar vmpsd.orig/Makefile.in vmpsd/Makefile.in
+--- vmpsd.orig/Makefile.in 2006-05-15 13:33:57.000000000 +0000
++++ vmpsd/Makefile.in 2012-02-21 09:08:54.807227002 +0000
+@@ -59,7 +59,7 @@
+ am_vmpsd_OBJECTS = vmpsd-vmpsd.$(OBJEXT) vmpsd-daemon.$(OBJEXT) \
+ vmpsd-data.$(OBJEXT) vmpsd-log.$(OBJEXT) \
+ vmpsd-parser.$(OBJEXT) vmpsd-vqp.$(OBJEXT) \
+- vmpsd-external.$(OBJEXT)
++ vmpsd-external.$(OBJEXT) $(SNMP_OBJECTS)
+ vmpsd_OBJECTS = $(am_vmpsd_OBJECTS)
+ vmpsd_LDADD = $(LDADD)
+ DEFAULT_INCLUDES = -I. -I$(srcdir) -I.
+diff -Nuar vmpsd.orig/snmp.c vmpsd/snmp.c
+--- vmpsd.orig/snmp.c 2004-07-08 09:34:29.000000000 +0000
++++ vmpsd/snmp.c 2012-02-21 09:11:51.817566865 +0000
+@@ -8,6 +8,8 @@
+ #include <netinet/in.h>
+ #include <arpa/inet.h>
+
++#define UCD_COMPATIBLE 1
++#include <net-snmp/net-snmp-config.h>
+ #include <ucd-snmp/ucd-snmp-includes.h>
+
+ #include "log.h"
+diff -Nuar vmpsd.orig/vmpsd.c vmpsd/vmpsd.c
+--- vmpsd.orig/vmpsd.c 2006-05-15 13:33:57.000000000 +0000
++++ vmpsd/vmpsd.c 2012-02-21 09:12:28.987640940 +0000
+@@ -18,7 +18,7 @@
+
+ int parse_options(int argc, char **argv)
+ {
+- char opt;
++ signed char opt;
+ char *options = "a:cde:f:l:p:";
+
+ opterr = 0;
+@@ -80,7 +80,7 @@
+ printf("\t-d do not detach, log to stderr also\n");
+ printf("\t-e path use external program for mac to vlan assignment\n");
+ printf("\t when/if used with -f, -f is disregarded\n");
+- printf("\t-f file read VMPS database from file (/etc/vmps.db)\n");
++ printf("\t-f file read VMPS database from file ("SYSCONFDIR"/vmps.db)\n");
+ printf("\t-l level set logging level:\n");
+ printf("\t 0x0100 - fatal,\n");
+ printf("\t 0x0200 - info,\n");
diff --git a/net-misc/vmpsd/metadata.xml b/net-misc/vmpsd/metadata.xml
new file mode 100644
index 000000000000..f1d10859a0d6
--- /dev/null
+++ b/net-misc/vmpsd/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>robbat2@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">vmps</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-misc/vmpsd/vmpsd-1.4.ebuild b/net-misc/vmpsd/vmpsd-1.4.ebuild
new file mode 100644
index 000000000000..5086962dbbca
--- /dev/null
+++ b/net-misc/vmpsd/vmpsd-1.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils flag-o-matic autotools
+
+DESCRIPTION="An open-source VLAN management system"
+HOMEPAGE="http://vmps.sourceforge.net"
+SRC_URI="mirror://sourceforge/vmps/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+DEPEND="net-analyzer/net-snmp[ucd-compat(+)]
+ dev-libs/openssl"
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.4-snmp-support.patch
+ epatch "${FILESDIR}"/${PN}-1.3-64bit.patch
+ # Merged upstream
+ #EPATCH_OPTS="-d${S}" \
+ #epatch "${FILESDIR}"/${PN}-1.3-format-sec.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --sysconfdir=/etc/vmpsd \
+ --enable-snmp \
+ LIBS="-lssl" \
+ || die "econf failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc README INSTALL AUTHORS doc/*txt
+ newdoc external/README README.external
+ newdoc tools/README README.tools
+ dodoc external/simple tools/vqpcli.pl
+}