summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2016-03-07 14:48:00 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2016-03-07 14:54:33 +0100
commitf08b25af5ac679a57a52ca5a0213deb0800db8c5 (patch)
tree66f0b40e0fad356950e4cb54286f55a1f37167ef /net-misc/x2goserver
parentapp-arch/torrentzip: Fix invalid SRC_URI. (diff)
downloadgentoo-f08b25af5ac679a57a52ca5a0213deb0800db8c5.tar.gz
gentoo-f08b25af5ac679a57a52ca5a0213deb0800db8c5.tar.bz2
gentoo-f08b25af5ac679a57a52ca5a0213deb0800db8c5.zip
net-misc/x2goserver: remove hardcoded blowfish Cipher spec
Gentoo-Bug: 576356 Package-Manager: portage-2.2.27
Diffstat (limited to 'net-misc/x2goserver')
-rw-r--r--net-misc/x2goserver/files/x2goserver-4.0.1.19-remove_sshfs_cipher.patch21
-rw-r--r--net-misc/x2goserver/x2goserver-4.0.1.19-r3.ebuild93
2 files changed, 114 insertions, 0 deletions
diff --git a/net-misc/x2goserver/files/x2goserver-4.0.1.19-remove_sshfs_cipher.patch b/net-misc/x2goserver/files/x2goserver-4.0.1.19-remove_sshfs_cipher.patch
new file mode 100644
index 000000000000..b29336349f09
--- /dev/null
+++ b/net-misc/x2goserver/files/x2goserver-4.0.1.19-remove_sshfs_cipher.patch
@@ -0,0 +1,21 @@
+X-Git-Url: http://code.x2go.org/gitweb?p=x2goserver.git;a=blobdiff_plain;f=x2goserver%2Fbin%2Fx2gomountdirs;h=f39d19975c6806ea115921aa0e1949e3dfa44c7d;hp=f0b497edd252481792ebc6e5e73d79158bc4a14c;hb=86a0e421c3da850045459af855a33f646828dd68;hpb=7ae2669b596d3b84f0ba09552d5a8c0e653ce86d
+
+diff --git a/x2goserver/bin/x2gomountdirs b/x2goserver/bin/x2gomountdirs
+index f0b497e..f39d199 100755
+--- a/x2goserver/bin/x2gomountdirs
++++ b/x2goserver/bin/x2gomountdirs
+@@ -304,12 +304,12 @@ for (my $i=0;$i<@dirs;$i++)
+ {
+ syslog('debug', "SSH host key has arrived: $key.ident");
+ }
+- $msg = "timeout 30 sshfs $code_conv -o idmap=user,uid=`id -u`,gid=`id -g`,$umaskstr,ServerAliveInterval=300,Cipher=blowfish,IdentityFile=$key,UserKnownHostsFile=$key.ident \"$user\"\@$host:\"@dirs[$i]\" \"$mntpath\" -p $port";
++ $msg = "timeout 30 sshfs $code_conv -o idmap=user,uid=`id -u`,gid=`id -g`,$umaskstr,ServerAliveInterval=300,IdentityFile=$key,UserKnownHostsFile=$key.ident \"$user\"\@$host:\"@dirs[$i]\" \"$mntpath\" -p $port";
+ syslog('debug', "executing: $msg");
+ print "inserted, $msg\n";
+
+ # FIXME: this system call should be converted to a multi-argument system call while pertaining the redirect of stderr to the mounts.log file
+- if (system("timeout 30 sshfs $code_conv -o idmap=user,uid=`id -u`,gid=`id -g`,$umaskstr,ServerAliveInterval=300,Cipher=blowfish,IdentityFile=$key,UserKnownHostsFile=$key.ident \"$user\"\@$host:\"@dirs[$i]\" \"$mntpath\" -p $port 1>>$sessiondir/sshfs-mounts.log 2>&1")==0)
++ if (system("timeout 30 sshfs $code_conv -o idmap=user,uid=`id -u`,gid=`id -g`,$umaskstr,ServerAliveInterval=300,IdentityFile=$key,UserKnownHostsFile=$key.ident \"$user\"\@$host:\"@dirs[$i]\" \"$mntpath\" -p $port 1>>$sessiondir/sshfs-mounts.log 2>&1")==0)
+ {
+ print "mount @dirs[$i] ok\n";
+ syslog('notice', "successfully mounted $user\@$host:$port@dirs[$i] to $mntpath");
diff --git a/net-misc/x2goserver/x2goserver-4.0.1.19-r3.ebuild b/net-misc/x2goserver/x2goserver-4.0.1.19-r3.ebuild
new file mode 100644
index 000000000000..a977760aa233
--- /dev/null
+++ b/net-misc/x2goserver/x2goserver-4.0.1.19-r3.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit multilib systemd toolchain-funcs user
+
+DESCRIPTION="The X2Go server"
+HOMEPAGE="http://www.x2go.org"
+SRC_URI="http://code.x2go.org/releases/source/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+fuse postgres +sqlite"
+
+REQUIRED_USE="|| ( postgres sqlite )"
+
+DEPEND=""
+RDEPEND="dev-perl/Capture-Tiny
+ dev-perl/Config-Simple
+ dev-perl/File-BaseDir
+ dev-perl/File-ReadBackwards
+ dev-perl/File-Which
+ media-fonts/font-cursor-misc
+ media-fonts/font-misc-misc[nls]
+ >=net-misc/nx-3.5.0.25
+ net-misc/openssh
+ >=sys-apps/iproute2-4.3.0
+ x11-apps/xauth
+ x11-apps/xhost
+ x11-apps/xwininfo
+ fuse? ( sys-fs/sshfs-fuse )
+ postgres? ( dev-perl/DBD-Pg )
+ sqlite? ( dev-perl/DBD-SQLite )"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-use_bash_in_Xsession.patch
+ "${FILESDIR}"/${P}-remove_sshfs_cipher.patch
+ )
+
+pkg_setup() {
+ # Force the group creation, #479650
+ enewgroup x2gouser
+ enewgroup x2goprint
+ enewuser x2gouser -1 -1 /var/lib/x2go x2gouser
+ enewuser x2goprint -1 -1 /var/spool/x2goprint x2goprint
+}
+
+src_prepare() {
+ # Do not install Xresources symlink (#521126)
+ sed -e '\#$(INSTALL_SYMLINK) /etc/X11/Xresources# s/^/#/' -i x2goserver-xsession/Makefile || die "Xresources symlink sed failed"
+ # Multilib clean
+ sed -e "/^LIBDIR=/s/lib/$(get_libdir)/" -i Makefile */Makefile || die "multilib sed failed"
+ # Skip man2html build
+ sed -e "s/build-indep: build_man2html/build-indep:/" -i Makefile */Makefile || die "man2html sed failed"
+ # Use nxagent directly
+ sed -i -e "/NX_TEMP=/s/x2goagent/nxagent/" x2goserver/bin/x2gostartagent || die "sed failed"
+
+ default
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" PREFIX=/usr
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX=/usr install
+
+ fowners root:x2goprint /usr/bin/x2goprint
+ fperms 2755 /usr/bin/x2goprint
+ fperms 0750 /etc/sudoers.d
+ fperms 0440 /etc/sudoers.d/x2goserver
+ dosym /usr/share/applications /etc/x2go/applications
+
+ newinitd "${FILESDIR}"/${PN}.init x2gocleansessions
+ systemd_dounit "${FILESDIR}"/x2gocleansessions.service
+}
+
+pkg_postinst() {
+ if use sqlite ; then
+ elog "To use sqlite and create the initial database, run:"
+ elog " # x2godbadmin --createdb"
+ fi
+ if use postgres ; then
+ elog "To use a PostgreSQL databse, more information is availabe here:"
+ elog "http://www.x2go.org/doku.php/wiki:advanced:multi-node:x2goserver-pgsql"
+ fi
+
+ elog "For password authentication, you need to enable PasswordAuthentication"
+ elog "in /etc/ssh/sshd_config (disabled by default in Gentoo)"
+ elog "An init script was installed for x2gocleansessions"
+}