summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2018-02-06 11:43:34 -0600
committerWilliam Hubbs <williamh@gentoo.org>2018-02-06 11:44:02 -0600
commit80def5c8c1df26c4691376010f5d27a76aa74a79 (patch)
tree1a2bdde39e458aa07de864d3042fd0ae6cd96be0 /net-misc
parentsys-cluster/ceph: Fix init script (diff)
downloadgentoo-80def5c8c1df26c4691376010f5d27a76aa74a79.tar.gz
gentoo-80def5c8c1df26c4691376010f5d27a76aa74a79.tar.bz2
gentoo-80def5c8c1df26c4691376010f5d27a76aa74a79.zip
net-misc/dhcpcd: 7.0.1 version bump
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/dhcpcd/Manifest1
-rw-r--r--net-misc/dhcpcd/dhcpcd-7.0.1.ebuild148
2 files changed, 149 insertions, 0 deletions
diff --git a/net-misc/dhcpcd/Manifest b/net-misc/dhcpcd/Manifest
index ddc494265a41..801544a02353 100644
--- a/net-misc/dhcpcd/Manifest
+++ b/net-misc/dhcpcd/Manifest
@@ -8,3 +8,4 @@ DIST dhcpcd-7.0.0-rc2.tar.xz 206108 BLAKE2B e30acadab1e8084b0800b67f4609fa5c7fe4
DIST dhcpcd-7.0.0-rc3.tar.xz 207164 BLAKE2B 2e8cb676979606dba22c5f304650679e5325cc691d8a3c2dd62a1776373df4a7c21d5e85ee8106299b2f73def4bb2862bbe8d396b37dcab9c1dcff93634a0b78 SHA512 982c4c65ea45391e31170b592ce680c6cf5f4069b00decff3a299db23cede3e2521c66df7754a7a2379d5688f113553fe34e2fde825d6d9b83836a9e6d69fba9
DIST dhcpcd-7.0.0-rc4.tar.xz 207596 BLAKE2B 2ce28e6f171b0bcc0b5c9e2ba0e5c92c70e7e97a516ce170d24c77a9d9981662acc914cefa5cad1bda14d7129088c313069ebe956d3e79098f70c3a31e53499f SHA512 e4bbb7d52021b84510d2a4e634b6fb979c126a6828de55053df0d3c6aae67a5c9be3da008bd7c8606be3d6aa28b00bafed3188473adcf2f3bc1bbfe9b1f4adc3
DIST dhcpcd-7.0.0.tar.xz 207924 BLAKE2B bd24f22b4852596ef4a076d1ab15ac4411dd676ba8cbfdb4b1ba29ffe1bff2d18be40369c1f8804bc01988bb30b89ee1030ea95ddb48fbfc04ca06372b317d9d SHA512 f2ab1fcb2dad0c93da757c15d0b772b40cc15c8e59161d91684f06961cf7b515473d7c3fc5973b7755ac525e6851abdf8a5f27760bb5d28fe17e90ff0feaf904
+DIST dhcpcd-7.0.1.tar.xz 207908 BLAKE2B 1a9350a0c4a9eb1eb6f5a7be78beb4a5fecd802ee90a4649ab17db69eabc75a913b9f3db97ea6260bcad3516b9613c20f74d9d68a7ac98b508458e5cd30cf15f SHA512 d2a9b053aa663dd1ed38a10a73ee3377a3a076c9638bdda9331a4c161c2ba87f5f68f366ac8e1f1015404f617b74261a03a97ac7cdfd642b4a41b87b54984c34
diff --git a/net-misc/dhcpcd/dhcpcd-7.0.1.ebuild b/net-misc/dhcpcd/dhcpcd-7.0.1.ebuild
new file mode 100644
index 000000000000..2723156dac92
--- /dev/null
+++ b/net-misc/dhcpcd/dhcpcd-7.0.1.ebuild
@@ -0,0 +1,148 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} == "9999" ]]; then
+ EGIT_REPO_URI="git://roy.marples.name/dhcpcd"
+ inherit git-r3
+else
+ MY_P="${P/_alpha/-alpha}"
+ MY_P="${MY_P/_beta/-beta}"
+ MY_P="${MY_P/_rc/-rc}"
+ SRC_URI="http://roy.marples.name/downloads/${PN}/${MY_P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+inherit eutils systemd toolchain-funcs
+
+DESCRIPTION="A fully featured, yet light weight RFC2131 compliant DHCP client"
+HOMEPAGE="http://roy.marples.name/projects/dhcpcd/"
+LICENSE="BSD-2"
+SLOT="0"
+IUSE="elibc_glibc +embedded ipv6 kernel_linux +udev"
+
+COMMON_DEPEND="udev? ( virtual/udev )"
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}"
+
+src_configure()
+{
+ local dev hooks rundir
+ use udev || dev="--without-dev --without-udev"
+ hooks="--with-hook=ntp.conf"
+ use elibc_glibc && hooks="${hooks} --with-hook=yp.conf"
+ use kernel_linux && rundir="--rundir=${EPREFIX}/run"
+ econf \
+ --prefix="${EPREFIX}" \
+ --libexecdir="${EPREFIX}/lib/dhcpcd" \
+ --dbdir="${EPREFIX}/var/lib/dhcpcd" \
+ --localstatedir="${EPREFIX}/var" \
+ ${rundir} \
+ $(use_enable embedded) \
+ $(use_enable ipv6) \
+ ${dev} \
+ CC="$(tc-getCC)" \
+ ${hooks}
+}
+
+src_install()
+{
+ default
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ systemd_dounit "${FILESDIR}"/${PN}.service
+}
+
+pkg_postinst()
+{
+ local dbdir="${EROOT%/}"/var/lib/dhcpcd old_files=
+
+ local old_old_duid="${EROOT%/}"/var/lib/dhcpcd/dhcpcd.duid
+ local old_duid="${EROOT%/}"/etc/dhcpcd.duid
+ local new_duid="${dbdir}"/duid
+ if [ -e "${old_old_duid}" ]; then
+ # Upgrade the duid file to the new format if needed
+ if ! grep -q '..:..:..:..:..:..' "${old_old_duid}"; then
+ sed -i -e 's/\(..\)/\1:/g; s/:$//g' "${old_old_duid}"
+ fi
+
+ # Move the duid to /etc, a more sensible location
+ if [ ! -e "${old_duid}" ]; then
+ cp -p "${old_old_duid}" "${new_duid}"
+ fi
+ old_files="${old_files} ${old_old_duid}"
+ fi
+
+ # dhcpcd-7 moves the files out of /etc
+ if [ -e "${old_duid}" ]; then
+ if [ ! -e "${new_duid}" ]; then
+ cp -p "${old_duid}" "${new_duid}"
+ fi
+ old_files="${old_files} ${old_duid}"
+ fi
+ local old_secret="${EROOT%/}"/etc/dhcpcd.secret
+ local new_secret="${dbdir}"/secret
+ if [ -e "${old_secret}" ]; then
+ if [ ! -e "${new_secret}" ]; then
+ cp -p "${old_secret}" "${new_secret}"
+ fi
+ old_files="${old_files} ${old_secret}"
+ fi
+
+ # dhcpcd-7 renames some files in /var/lib/dhcpcd
+ local old_rdm="${dbdir}"/dhcpcd-rdm.monotonic
+ local new_rdm="${dbdir}"/rdm_monotonic
+ if [ -e "${old_rdm}" ]; then
+ if [ ! -e "${new_rdm}" ]; then
+ cp -p "${old_rdm}" "${new_rdm}"
+ fi
+ old_files="${old_files} ${old_rdm}"
+ fi
+ local lease=
+ for lease in "${dbdir}"/dhcpcd-*.lease*; do
+ [ -f "$lease" ] || continue
+ old_files="${old_files} ${lease}"
+ local new_lease=$(basename "$lease" | sed -e "s/dhcpcd-//")
+ [ -e "${dbdir}/${new_lease}" ] && continue
+ cp "${lease}" "${dbdir}/${new_lease}"
+ done
+
+ # Warn about removing stale files
+ if [ -n "${old_files}" ]; then
+ elog
+ elog "dhcpcd-7 has copied dhcpcd.duid and dhcpcd.secret from"
+ elog "${EROOT%/}/etc to ${dbdir}"
+ elog "and copied leases in ${dbdir} to new files with the dhcpcd-"
+ elog "prefix dropped."
+ elog
+ elog "You should remove these files if you don't plan on reverting"
+ elog "to an older version:"
+ local old_file=
+ for old_file in ${old_files}; do
+ elog " ${old_file}"
+ done
+ fi
+
+ if [ -z "$REPLACING_VERSIONS" ]; then
+ elog
+ elog "dhcpcd has zeroconf support active by default."
+ elog "This means it will always obtain an IP address even if no"
+ elog "DHCP server can be contacted, which will break any existing"
+ elog "failover support you may have configured in your net configuration."
+ elog "This behaviour can be controlled with the noipv4ll configuration"
+ elog "file option or the -L command line switch."
+ elog "See the dhcpcd and dhcpcd.conf man pages for more details."
+
+ elog
+ elog "Dhcpcd has duid enabled by default, and this may cause issues"
+ elog "with some dhcp servers. For more information, see"
+ elog "https://bugs.gentoo.org/show_bug.cgi?id=477356"
+ fi
+
+ if ! has_version net-dns/bind-tools; then
+ elog
+ elog "If you activate the lookup-hostname hook to look up your hostname"
+ elog "using the dns, you need to install net-dns/bind-tools."
+ fi
+}