summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorsoredake <fdsfgs@krutt.org>2017-12-19 11:26:47 +0200
committerDavid Seifert <soap@gentoo.org>2017-12-23 17:52:26 +0100
commit82b703ed7611bc30de37b3c5eba17493f01de665 (patch)
tree55e093ecf99273cb03975f606419618ef717987f /net-misc
parentnet-misc/streamlink: drop 0.8.1 version (diff)
downloadgentoo-82b703ed7611bc30de37b3c5eba17493f01de665.tar.gz
gentoo-82b703ed7611bc30de37b3c5eba17493f01de665.tar.bz2
gentoo-82b703ed7611bc30de37b3c5eba17493f01de665.zip
net-misc/streamlink: version bump to 0.9.0
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/streamlink/Manifest1
-rw-r--r--net-misc/streamlink/streamlink-0.9.0.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/net-misc/streamlink/Manifest b/net-misc/streamlink/Manifest
index 61e78f3b90bc..a78c3f03f989 100644
--- a/net-misc/streamlink/Manifest
+++ b/net-misc/streamlink/Manifest
@@ -2,3 +2,4 @@ DIST streamlink-0.1.0.tar.gz 960622 BLAKE2B 8d035784fc3585c738135a901b6da35b9ace
DIST streamlink-0.4.0.tar.gz 30674625 BLAKE2B 301ff7e2086425604c59d12063cd5b14f789dc39249bba96faedb0fece663f9e5d65f1f696d40f92f07a95a9edd5c915c71d22dcd1afb378cc000bac6eeebd5e SHA512 58a4110b1e6b20f0b05842ee8450a93d646d523a284cf60ad878b460b8e80081d78658f5abb67744609cfdd0a88ebbf97faf6453b2b53709f259e4f9cc093eed
DIST streamlink-0.6.0.tar.gz 30696706 BLAKE2B d735c9605b1d0bb9aa6c52c145b1ee3d9645d5a1be0ab0bbc4a84a3e9c5b527a8a35f3d61c2bc5e51d1549f6328802e13ca83231c08bebc90496144fb25c7dfe SHA512 b9f75bfd2cab577688ed84a6c690f776b2e3af38fa60edb7f2fd73f2c25246c81098652180c3adae61eec8798a7805988cad01c366989a961efdb1e12578af49
DIST streamlink-0.7.0.tar.gz 30709251 BLAKE2B 215a8aa8b273e9b46fb86020dd53cb15bd19cb3de77e0b6e4a124916b964077a012cec5358d81707782834031490921fcae8a3a8321b70a43a4b538321eac06e SHA512 6e908229295c4d129d2bb9bfc26c76b20d45c2c9dc8193528a259c572cddd4ea620f9f903fb639ddad206bcad05a416ccc50328d01489a7684ec724a8cf1c3c1
+DIST streamlink-0.9.0.tar.gz 30720281 BLAKE2B b0a19f78f26908ff7b35cbcc3a95539969cb00e6b54c1cdb4c4c72685e77f9291ced933238708cfd4cdb6225c7dade4fd49e9a98a7092a1aff2d91297aacd951 SHA512 3d8aea95cd71968dc8a77eb1ad243abad10db76d6f9729498826876465e10ad2ac6204f26ec528d05ddd352236789ba8f8a86347abd50ed2d558b7ffc41349cd
diff --git a/net-misc/streamlink/streamlink-0.9.0.ebuild b/net-misc/streamlink/streamlink-0.9.0.ebuild
new file mode 100644
index 000000000000..30393d7be3f5
--- /dev/null
+++ b/net-misc/streamlink/streamlink-0.9.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+PYTHON_REQ_USE='xml(+),threads(+)'
+
+inherit distutils-r1
+
+DESCRIPTION="CLI for extracting streams from websites to a video player of your choice"
+HOMEPAGE="https://streamlink.github.io/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="BSD-2 Apache-2.0"
+SLOT="0"
+IUSE="doc test"
+
+RDEPEND="dev-python/pycryptodome[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ virtual/python-futures[${PYTHON_USEDEP}]
+ virtual/python-singledispatch[${PYTHON_USEDEP}]
+ dev-python/backports-shutil_which[$(python_gen_usedep 'python2*')]
+ $(python_gen_cond_dep 'dev-python/backports-shutil_get_terminal_size[${PYTHON_USEDEP}]' 'python2*')
+ dev-python/pycountry[${PYTHON_USEDEP}]
+ dev-python/websocket-client[${PYTHON_USEDEP}]
+ media-video/rtmpdump
+ virtual/ffmpeg"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ )
+ test? (
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' 'python2*')
+ ${RDEPEND}
+ )"
+
+python_configure_all() {
+ # Avoid iso-639, iso3166 dependencies since we use pycountry.
+ export STREAMLINK_USE_PYCOUNTRY=1
+}
+
+python_compile_all() {
+ use doc && emake -C docs html man
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ if use doc; then
+ local HTML_DOCS=( docs/_build/html/. )
+ doman docs/_build/man/*
+ fi
+ distutils-r1_python_install_all
+}