summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-08-08 21:44:35 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-08-08 21:53:37 -0400
commit8383b328bbe7148feddc5c624f0505631f12d12a (patch)
treed5622c9e273925598d6674f7993271d711ac2d1c /net-misc
parentnet-wireless/kismet: minor bug fixes and cleanup (diff)
downloadgentoo-8383b328bbe7148feddc5c624f0505631f12d12a.tar.gz
gentoo-8383b328bbe7148feddc5c624f0505631f12d12a.tar.bz2
gentoo-8383b328bbe7148feddc5c624f0505631f12d12a.zip
net-misc/yt-dlp: add 2022.8.8
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/yt-dlp/Manifest1
-rw-r--r--net-misc/yt-dlp/yt-dlp-2022.8.8.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/net-misc/yt-dlp/Manifest b/net-misc/yt-dlp/Manifest
index 56d4c9f9e50b..51fc2f4e192f 100644
--- a/net-misc/yt-dlp/Manifest
+++ b/net-misc/yt-dlp/Manifest
@@ -1 +1,2 @@
DIST yt-dlp-2022.7.18.tar.gz 2348854 BLAKE2B 3ef23b1fbc379af2e2a291e96efe495a38d8a7a3db3a45d6131bcaa06cc03843e4c3eee7859c51a7868429ab64759e251a22c5fb320fcbf51d7e2c4ca9ac86d7 SHA512 07552c1b698326152c154ff83fc08b03637234ff448e6b5dd6776c0f37d2a4d892a5c89131c4c9ec8a8c479577018ffbdf7f53538e3dc41497c0fd131c90538a
+DIST yt-dlp-2022.8.8.tar.gz 2361172 BLAKE2B a210786df56faa39a725f2ab06c9cc7805128c2f4fde4c504bd26a09d6a38cf25bea8b52f1471261bb007c8645170a29fae364e3b4008d1ebc8d4f0caf645c35 SHA512 bef1f1110c97f0c8338e94fc2671849cbfe086eb7dba974c623dde2beec29a17dd0c9972603a5af530a07e0721a00e56c6437a2b5d82b39630e3f4f49b51b00b
diff --git a/net-misc/yt-dlp/yt-dlp-2022.8.8.ebuild b/net-misc/yt-dlp/yt-dlp-2022.8.8.ebuild
new file mode 100644
index 000000000000..775abf17078d
--- /dev/null
+++ b/net-misc/yt-dlp/yt-dlp-2022.8.8.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+inherit bash-completion-r1 distutils-r1 optfeature wrapper
+
+DESCRIPTION="youtube-dl fork with additional features and fixes"
+HOMEPAGE="https://github.com/yt-dlp/yt-dlp/"
+SRC_URI="mirror://pypi/${P::1}/${PN}/${P}.tar.gz"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~x86 ~x64-macos"
+
+RDEPEND="
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ !net-misc/youtube-dl[-yt-dlp(-)]"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # adjust requires for pycryptodome and optional dependencies (bug #828466)
+ sed -ri requirements.txt \
+ -e "s/^(pycryptodome)x/\1/" \
+ -e "/^(brotli.*|certifi|mutagen|websockets)/d" || die
+}
+
+python_test() {
+ epytest -m 'not download'
+}
+
+python_install_all() {
+ dodoc README.md Changelog.md supportedsites.md
+ doman yt-dlp.1
+
+ dobashcomp completions/bash/yt-dlp
+
+ insinto /usr/share/fish/vendor_completions.d
+ doins completions/fish/yt-dlp.fish
+
+ insinto /usr/share/zsh/site-functions
+ doins completions/zsh/_yt-dlp
+
+ rm -r "${ED}"/usr/share/doc/yt_dlp || die
+
+ make_wrapper youtube-dl "yt-dlp --compat-options youtube-dl"
+}
+
+pkg_postinst() {
+ optfeature "various features (merging tracks, streamed content)" media-video/ffmpeg
+ has_version media-video/atomicparsley || # allow fallback but don't advertise
+ optfeature "embedding metadata thumbnails in MP4/M4A files" media-libs/mutagen
+
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog 'A wrapper using "yt-dlp --compat-options youtube-dl" was installed'
+ elog 'as "youtube-dl". This is strictly for compatibility and it is'
+ elog 'recommended to use "yt-dlp" directly, it may be removed in the future.'
+ fi
+}