summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-nds/gosa-core
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-nds/gosa-core')
-rw-r--r--net-nds/gosa-core/Manifest3
-rw-r--r--net-nds/gosa-core/files/gosa.include36
-rw-r--r--net-nds/gosa-core/gosa-core-2.6.10.ebuild106
-rw-r--r--net-nds/gosa-core/gosa-core-2.6.11.ebuild108
-rw-r--r--net-nds/gosa-core/gosa-core-2.6.12.ebuild108
-rw-r--r--net-nds/gosa-core/metadata.xml15
6 files changed, 376 insertions, 0 deletions
diff --git a/net-nds/gosa-core/Manifest b/net-nds/gosa-core/Manifest
new file mode 100644
index 000000000000..0159e7330155
--- /dev/null
+++ b/net-nds/gosa-core/Manifest
@@ -0,0 +1,3 @@
+DIST gosa-core-2.6.10.tar.bz2 2651987 SHA256 f372b753a675745b8d177f4cd497b625fd36a49deb84b053d51fe1c133933e5d
+DIST gosa-core-2.6.11.tar.bz2 2711910 SHA256 79e484da20524ec17b8da12a146f35e6c5784e7e9f75962c89657680d00ebc30
+DIST gosa-core-2.6.12.tar.bz2 2541062 SHA256 dd6cf2bdb32196e6ad68efa4d2400bf6a95b4a7fddf7c11888c60ea8888b8dc0
diff --git a/net-nds/gosa-core/files/gosa.include b/net-nds/gosa-core/files/gosa.include
new file mode 100644
index 000000000000..dcd3434964a4
--- /dev/null
+++ b/net-nds/gosa-core/files/gosa.include
@@ -0,0 +1,36 @@
+Alias /gosa /usr/share/gosa/html
+
+<Directory /usr/share/gosa/html>
+ Options None
+ AllowOverride None
+ Order deny,allow
+ Allow from all
+</Directory>
+
+<IfModule mod_php5.c>
+<Location /gosa>
+ php_admin_flag engine on
+ php_admin_flag register_globals off
+ php_admin_flag allow_call_time_pass_reference off
+ php_admin_flag expose_php off
+ php_admin_flag zend.ze1_compatibility_mode off
+ php_admin_flag register_long_arrays off
+ php_admin_flag magic_quotes_gpc on
+ php_admin_value upload_tmp_dir /var/spool/gosa/
+ php_admin_value session.cookie_lifetime 0
+ include /etc/gosa/gosa.secrets
+</Location>
+</IfModule>
+
+<IfModule mod_fcgid.c>
+ PHP_Fix_Pathinfo_Enable 1
+ <Location /gosa>
+ Options +ExecCGI
+ AddHandler fcgid-script .php
+ FCGIWrapper /var/www/php-fcgi/php-fcgi-starter .php
+ include /etc/gosa/gosa.secrets
+ </Location>
+</IfModule>
+
+
+# vim: ts=4 filetype=apache
diff --git a/net-nds/gosa-core/gosa-core-2.6.10.ebuild b/net-nds/gosa-core/gosa-core-2.6.10.ebuild
new file mode 100644
index 000000000000..e8c8de9005b7
--- /dev/null
+++ b/net-nds/gosa-core/gosa-core-2.6.10.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+inherit eutils
+
+DESCRIPTION="LDAP administration frontend for user administration"
+HOMEPAGE="https://oss.gonicus.de/labs/gosa/wiki/WikiStart."
+SRC_URI="ftp://oss.gonicus.de/pub/gosa/${P}.tar.bz2
+ http://oss.gonicus.de/pub/gosa/${P}.tar.bz2
+ ftp://oss.gonicus.de/pub/gosa/archive/${P}.tar.bz2
+ http://oss.gonicus.de/pub/gosa/archive/${P}.tar.bz2 "
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="dev-lang/php[iconv,imap,ldap,mysql,session,zip]
+ sys-devel/gettext"
+RDEPEND="${DEPEND}
+ virtual/httpd-php
+ dev-perl/Crypt-SmbHash
+ media-gfx/imagemagick"
+
+src_prepare() {
+ epatch \
+ "${S}/redhat/02_fix_class_mapping.patch" \
+ "${S}/redhat/03_fix_locale_location.patch" \
+ "${S}/redhat/04_fix_online_help_location.patch"
+ sed -i \
+ -e 's|../contrib|/usr/share/gosa/template|' \
+ include/functions.inc || die "sed failed"
+}
+
+src_install() {
+ insinto /usr/share/gosa
+ doins -r doc html ihtml include locale plugins setup
+
+ insinto /usr/share/gosa/template
+ doins contrib/gosa.conf
+
+ dosbin \
+ update-gosa \
+ bin/gosa-encrypt-passwords
+
+ dobin \
+ update-locale \
+ update-online-help \
+ update-pdf-help \
+ dh-make-gosa \
+ contrib/gosa
+
+ insinto /etc/gosa
+ doins \
+ contrib/shells \
+ contrib/encodings \
+ contrib/desktoprc
+ touch "${D}/etc/gosa/gosa.secrets"
+
+ doicon debian/*.xpm
+ domenu debian/gosa-desktop.desktop
+
+ doman *.1 contrib/*.1 contrib/*.5
+
+ dodoc contrib/openldap/slapd.conf
+ insinto /etc/openldap/schema/gosa
+ doins contrib/openldap/*.schema
+
+ insinto /etc/apache2/vhosts.d
+ doins "${FILESDIR}/gosa.include"
+
+ dodoc AUTHORS Changelog FAQ README README.safemode
+
+ keepdir /etc/gosa
+ keepdir /var/spool/gosa
+ keepdir /var/cache/gosa
+}
+
+pkg_prerm() {
+ ebegin "Flushing the class and locale cache"
+ rm -r "${EROOT}"var/cache/gosa/*
+ eend $?
+ ebegin "Clearing the spool directory"
+ rm -r "${EROOT}"var/spool/gosa/*
+ eend $?
+}
+
+pkg_postinst() {
+ ebegin "Generating class cache and locales"
+ "${EROOT}"usr/sbin/update-gosa
+ eend $?
+
+ elog "Please make sure that the web server you are going to use has"
+ elog "read-write access to ${EROOT}var/spool/gosa"
+
+ elog "For Apache there is the gosa.include file in ${EROOT}etc/apache/vhosts.d."
+ elog "You can either use it as a template for your configuration or directly"
+ elog "include it in your apache configuration."
+
+ elog "GOsa requires some objectclasses and attributes to be present in the"
+ elog "directory. A sample configuration for slapd.conf can be found here:"
+ elog " ${EROOR}usr/share/doc/${PF}/slapd.conf[.gz]"
+}
diff --git a/net-nds/gosa-core/gosa-core-2.6.11.ebuild b/net-nds/gosa-core/gosa-core-2.6.11.ebuild
new file mode 100644
index 000000000000..92a75b3283bb
--- /dev/null
+++ b/net-nds/gosa-core/gosa-core-2.6.11.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+inherit eutils
+
+DESCRIPTION="LDAP administration frontend for user administration"
+HOMEPAGE="https://oss.gonicus.de/labs/gosa/wiki/WikiStart."
+SRC_URI="ftp://oss.gonicus.de/pub/gosa/${P}.tar.bz2
+ http://oss.gonicus.de/pub/gosa/${P}.tar.bz2
+ ftp://oss.gonicus.de/pub/gosa/archive/${P}.tar.bz2
+ http://oss.gonicus.de/pub/gosa/archive/${P}.tar.bz2 "
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="mail samba"
+
+DEPEND="dev-lang/php[iconv,imap,ldap,mysql,session,zip]
+ sys-devel/gettext"
+RDEPEND="${DEPEND}
+ virtual/httpd-php
+ dev-perl/Crypt-SmbHash
+ media-gfx/imagemagick"
+PDEPEND="mail? ( ~net-nds/gosa-plugin-mail-${PV} )
+ samba? ( ~net-nds/gosa-plugin-samba-${PV} )"
+
+src_prepare() {
+ epatch \
+ "${S}/redhat/02_fix_class_mapping.patch" \
+ "${S}/redhat/03_fix_locale_location.patch" \
+ "${S}/redhat/04_fix_online_help_location.patch"
+ sed -i \
+ -e 's|../contrib|/usr/share/gosa/template|' \
+ include/functions.inc || die "sed failed"
+}
+
+src_install() {
+ insinto /usr/share/gosa
+ doins -r doc html ihtml include locale plugins setup
+
+ insinto /usr/share/gosa/template
+ doins contrib/gosa.conf
+
+ dosbin \
+ update-gosa \
+ bin/gosa-encrypt-passwords
+
+ dobin \
+ update-locale \
+ update-online-help \
+ update-pdf-help \
+ dh-make-gosa \
+ contrib/gosa
+
+ insinto /etc/gosa
+ doins \
+ contrib/shells \
+ contrib/encodings \
+ contrib/desktoprc
+ touch "${D}/etc/gosa/gosa.secrets"
+
+ doicon debian/*.xpm
+ domenu debian/gosa-desktop.desktop
+
+ doman *.1 contrib/*.1 contrib/*.5
+
+ dodoc contrib/openldap/slapd.conf
+ insinto /etc/openldap/schema/gosa
+ doins contrib/openldap/*.schema
+
+ insinto /etc/apache2/vhosts.d
+ doins "${FILESDIR}/gosa.include"
+
+ dodoc AUTHORS Changelog FAQ README README.safemode
+
+ keepdir /etc/gosa
+ keepdir /var/spool/gosa
+ keepdir /var/cache/gosa
+}
+
+pkg_prerm() {
+ ebegin "Flushing the class and locale cache"
+ rm -r "${EROOT}"var/cache/gosa/*
+ eend $?
+ ebegin "Clearing the spool directory"
+ rm -r "${EROOT}"var/spool/gosa/*
+ eend $?
+}
+
+pkg_postinst() {
+ ebegin "Generating class cache and locales"
+ "${EROOT}"usr/sbin/update-gosa
+ eend $?
+
+ elog "Please make sure that the web server you are going to use has"
+ elog "read-write access to ${EROOT}var/spool/gosa"
+
+ elog "For Apache there is the gosa.include file in ${EROOT}etc/apache/vhosts.d."
+ elog "You can either use it as a template for your configuration or directly"
+ elog "include it in your apache configuration."
+
+ elog "GOsa requires some objectclasses and attributes to be present in the"
+ elog "directory. A sample configuration for slapd.conf can be found here:"
+ elog " ${EROOR}usr/share/doc/${PF}/slapd.conf[.gz]"
+}
diff --git a/net-nds/gosa-core/gosa-core-2.6.12.ebuild b/net-nds/gosa-core/gosa-core-2.6.12.ebuild
new file mode 100644
index 000000000000..b026517cd98b
--- /dev/null
+++ b/net-nds/gosa-core/gosa-core-2.6.12.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="LDAP administration frontend for user administration"
+HOMEPAGE="https://oss.gonicus.de/labs/gosa/wiki/WikiStart."
+SRC_URI="ftp://oss.gonicus.de/pub/gosa/${P}.tar.bz2
+ http://oss.gonicus.de/pub/gosa/${P}.tar.bz2
+ ftp://oss.gonicus.de/pub/gosa/archive/${P}.tar.bz2
+ http://oss.gonicus.de/pub/gosa/archive/${P}.tar.bz2 "
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="mail samba"
+
+DEPEND="dev-lang/php[iconv,imap,ldap,mysql,session,zip]
+ sys-devel/gettext"
+RDEPEND="${DEPEND}
+ virtual/httpd-php
+ dev-perl/Crypt-SmbHash
+ media-gfx/imagemagick"
+PDEPEND="mail? ( ~net-nds/gosa-plugin-mail-${PV} )
+ samba? ( ~net-nds/gosa-plugin-samba-${PV} )"
+
+src_prepare() {
+ epatch \
+ "${S}/redhat/02_fix_class_mapping.patch" \
+ "${S}/redhat/03_fix_locale_location.patch" \
+ "${S}/redhat/04_fix_online_help_location.patch"
+ sed -i \
+ -e 's|../contrib|/usr/share/gosa/template|' \
+ include/functions.inc || die "sed failed"
+}
+
+src_install() {
+ insinto /usr/share/gosa
+ doins -r doc html ihtml include locale plugins setup
+
+ insinto /usr/share/gosa/template
+ doins contrib/gosa.conf
+
+ dosbin \
+ update-gosa \
+ bin/gosa-encrypt-passwords
+
+ dobin \
+ update-locale \
+ update-online-help \
+ update-pdf-help \
+ dh-make-gosa \
+ contrib/gosa
+
+ insinto /etc/gosa
+ doins \
+ contrib/shells \
+ contrib/encodings \
+ contrib/desktoprc
+ touch "${D}/etc/gosa/gosa.secrets"
+
+ doicon debian/*.xpm
+ domenu debian/gosa-desktop.desktop
+
+ doman *.1 contrib/*.1 contrib/*.5
+
+ dodoc contrib/openldap/slapd.conf
+ insinto /etc/openldap/schema/gosa
+ doins contrib/openldap/*.schema
+
+ insinto /etc/apache2/vhosts.d
+ doins "${FILESDIR}/gosa.include"
+
+ dodoc AUTHORS Changelog FAQ README README.safemode
+
+ keepdir /etc/gosa
+ keepdir /var/spool/gosa
+ keepdir /var/cache/gosa
+}
+
+pkg_prerm() {
+ ebegin "Flushing the class and locale cache"
+ rm -r "${EROOT}"var/cache/gosa/*
+ eend $?
+ ebegin "Clearing the spool directory"
+ rm -r "${EROOT}"var/spool/gosa/*
+ eend $?
+}
+
+pkg_postinst() {
+ ebegin "Generating class cache and locales"
+ "${EROOT}"usr/sbin/update-gosa
+ eend $?
+
+ elog "Please make sure that the web server you are going to use has"
+ elog "read-write access to ${EROOT}var/spool/gosa"
+
+ elog "For Apache there is the gosa.include file in ${EROOT}etc/apache/vhosts.d."
+ elog "You can either use it as a template for your configuration or directly"
+ elog "include it in your apache configuration."
+
+ elog "GOsa requires some objectclasses and attributes to be present in the"
+ elog "directory. A sample configuration for slapd.conf can be found here:"
+ elog " ${EROOR}usr/share/doc/${PF}/slapd.conf[.gz]"
+}
diff --git a/net-nds/gosa-core/metadata.xml b/net-nds/gosa-core/metadata.xml
new file mode 100644
index 000000000000..11f7ed9ad722
--- /dev/null
+++ b/net-nds/gosa-core/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>dev-zero@gentoo.org</email>
+ <name>Tiziano Müller</name>
+ </maintainer>
+ <use>
+ <flag name='mail'>Manage mail accounts and servers with gosa.</flag>
+ <flag name='samba'>Manage samba accounts with gosa.</flag>
+ </use>
+ <upstream>
+ <changelog>http://oss.gonicus.de/pub/gosa/Changelog</changelog>
+ </upstream>
+</pkgmetadata>