summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Konotopov <ykonotopov@gnome.org>2019-01-01 14:36:03 +0400
committerAndreas Sturmlechner <asturm@gentoo.org>2019-02-03 23:56:59 +0100
commit725730f5ed6bdc575fc032d090a8b2da0b07c442 (patch)
tree29e583297b5ba6505c241e75751f0fd62de789b5 /net-news
parentdev-python/flask-api: verbump to 1.1 (diff)
downloadgentoo-725730f5ed6bdc575fc032d090a8b2da0b07c442.tar.gz
gentoo-725730f5ed6bdc575fc032d090a8b2da0b07c442.tar.bz2
gentoo-725730f5ed6bdc575fc032d090a8b2da0b07c442.zip
net-news/liferea: version bump to 1.12.6b
Signed-off-by: Yuri Konotopov <ykonotopov@gnome.org> Closes: https://github.com/gentoo/gentoo/pull/10717 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'net-news')
-rw-r--r--net-news/liferea/Manifest1
-rw-r--r--net-news/liferea/liferea-1.12.6b.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/net-news/liferea/Manifest b/net-news/liferea/Manifest
index 9f82f6ebe7ee..25e3adbfbd59 100644
--- a/net-news/liferea/Manifest
+++ b/net-news/liferea/Manifest
@@ -1,2 +1,3 @@
DIST liferea-1.12.3.tar.bz2 1467804 BLAKE2B 3ef8039b7af136568e041309a384547543908e193cd384af819e24cd7ae213e4020e0ea099128295603ecf36d5d817b7529a2356191320ba80f4624128a72a36 SHA512 574dd13502fee81e81e88a0fa3a57028af2d2bfcfed5a132468a2be9257a886c7cbf958883c230deb6dbf952912ecc92631396ef6b5c353315833e0541db1208
DIST liferea-1.12.5a.tar.bz2 1470744 BLAKE2B 83f86b1f08efe32c236f7a4bcf8f18e4c6d568cd0d94ebdf6fb700f4d5e3afd433f55628272e46984c81932d7a7004cf09bc9efe93c90e841afe1cd9953baec1 SHA512 6ada3750d40310cc56577baff29796bd26d1da6d74958dbfd46d9477ac24c2f33f5a88cd82a143073dd2e34dcfb4d82fdeec8029307f7c6a4e16e587d2148b5c
+DIST liferea-1.12.6b.tar.bz2 1495311 BLAKE2B 28af2ed3045aa63646df4dc45d3108984a4ad41c85536fe8143af2629d0df44622508722f91a4860ba94f751e4a581e182b3f12c80d7be6acce1a12976c5a2dc SHA512 247d4cea97f890bf20b2d01394182d3020c2ccd056c6f0ff94d4c9055ae1c3d73e2e94609c66344260eb4ddece1df86cee8be745247735bd9b48f936f0ad74a8
diff --git a/net-news/liferea/liferea-1.12.6b.ebuild b/net-news/liferea/liferea-1.12.6b.ebuild
new file mode 100644
index 000000000000..726e2e643217
--- /dev/null
+++ b/net-news/liferea/liferea-1.12.6b.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6,7} )
+
+inherit gnome2 python-single-r1
+
+DESCRIPTION="News Aggregator for RDF/RSS/CDF/Atom/Echo feeds"
+HOMEPAGE="https://lzone.de/liferea/"
+SRC_URI="https://github.com/lwindolf/${PN}/releases/download/v1.12.6/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE="gnome-keyring mediaplayer networkmanager notification tray"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+CDEPEND="${PYTHON_DEPS}
+ >=dev-db/sqlite-3.7.0:3
+ >=dev-libs/glib-2.28.0:2
+ dev-libs/gobject-introspection
+ dev-libs/json-glib
+ >=dev-libs/libpeas-1.0.0[gtk,python,${PYTHON_USEDEP}]
+ >=dev-libs/libxml2-2.6.27:2
+ >=dev-libs/libxslt-1.1.19
+ gnome-base/gsettings-desktop-schemas
+ >=net-libs/libsoup-2.42:2.4
+ net-libs/webkit-gtk:4
+ x11-libs/gtk+:3
+ >=x11-libs/pango-1.4.0"
+RDEPEND="${CDEPEND}
+ gnome-keyring? ( app-crypt/libsecret[introspection] )
+ mediaplayer? ( media-libs/gstreamer[introspection] )
+ networkmanager? ( net-misc/networkmanager )
+ notification? ( x11-libs/libnotify[introspection] )
+ tray? (
+ dev-python/pycairo
+ x11-libs/gdk-pixbuf[introspection]
+ )"
+DEPEND="${CDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig"