summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Konotopov <ykonotopov@gnome.org>2017-06-26 16:39:28 +0400
committerMichael Palimaka <kensington@gentoo.org>2017-06-27 22:56:20 +1000
commitf76071ffeadfaaaa771cc1bb830f283acb5854b0 (patch)
tree04ee4fd98581bdc58848783e65a2983128121c42 /net-news
parentapp-admin/filebeat: bump to 5.4.2, drop old (diff)
downloadgentoo-f76071ffeadfaaaa771cc1bb830f283acb5854b0.tar.gz
gentoo-f76071ffeadfaaaa771cc1bb830f283acb5854b0.tar.bz2
gentoo-f76071ffeadfaaaa771cc1bb830f283acb5854b0.zip
net-news/liferea: fixed external browser option.
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=622638
Diffstat (limited to 'net-news')
-rw-r--r--net-news/liferea/files/liferea-1.12_rc3-signal.patch66
-rw-r--r--net-news/liferea/liferea-1.12_rc3-r1.ebuild74
2 files changed, 140 insertions, 0 deletions
diff --git a/net-news/liferea/files/liferea-1.12_rc3-signal.patch b/net-news/liferea/files/liferea-1.12_rc3-signal.patch
new file mode 100644
index 000000000000..56fa5a8cce64
--- /dev/null
+++ b/net-news/liferea/files/liferea-1.12_rc3-signal.patch
@@ -0,0 +1,66 @@
+From b08641b21bdb590770e10bad873666aedf4ae306 Mon Sep 17 00:00:00 2001
+From: leiaz <leiaz@free.fr>
+Date: Sun, 14 May 2017 20:08:39 +0200
+Subject: [PATCH] Fixes #500 Connects browser entry to callback
+
+Glade copy/paste doesn't copy the signals/callbacks part. I missed that
+one when updating the ui file.
+---
+ glade/prefs.ui | 24 ++++++++++++++----------
+ 1 file changed, 14 insertions(+), 10 deletions(-)
+
+diff --git a/glade/prefs.ui b/glade/prefs.ui
+index b5b97bac0..65d055986 100644
+--- a/glade/prefs.ui
++++ b/glade/prefs.ui
+@@ -736,16 +736,6 @@
+ </packing>
+ </child>
+ <child>
+- <object class="GtkComboBox" id="browserpopup">
+- <property name="visible">True</property>
+- <property name="can_focus">False</property>
+- </object>
+- <packing>
+- <property name="left_attach">1</property>
+- <property name="top_attach">1</property>
+- </packing>
+- </child>
+- <child>
+ <object class="GtkLabel" id="manuallabel">
+ <property name="visible">True</property>
+ <property name="can_focus">False</property>
+@@ -765,6 +755,7 @@
+ <property name="visible">True</property>
+ <property name="can_focus">True</property>
+ <property name="activates_default">True</property>
++ <signal name="changed" handler="on_browsercmd_changed" swapped="no"/>
+ </object>
+ <packing>
+ <property name="left_attach">1</property>
+@@ -787,6 +778,16 @@
+ </packing>
+ </child>
+ <child>
++ <object class="GtkComboBox" id="browserpopup">
++ <property name="visible">True</property>
++ <property name="can_focus">False</property>
++ </object>
++ <packing>
++ <property name="left_attach">1</property>
++ <property name="top_attach">1</property>
++ </packing>
++ </child>
++ <child>
+ <placeholder/>
+ </child>
+ </object>
+@@ -1422,5 +1423,8 @@
+ <action-widgets>
+ <action-widget response="-7">prefclosebtn</action-widget>
+ </action-widgets>
++ <child>
++ <placeholder/>
++ </child>
+ </object>
+ </interface>
diff --git a/net-news/liferea/liferea-1.12_rc3-r1.ebuild b/net-news/liferea/liferea-1.12_rc3-r1.ebuild
new file mode 100644
index 000000000000..5e51ec580547
--- /dev/null
+++ b/net-news/liferea/liferea-1.12_rc3-r1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5} )
+
+inherit autotools gnome2 pax-utils python-single-r1
+
+MY_P=${P/_/-}
+MY_PV=${PV/_/-}
+
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="News Aggregator for RDF/RSS/CDF/Atom/Echo feeds"
+HOMEPAGE="https://lzone.de/liferea/"
+SRC_URI="https://github.com/lwindolf/${PN}/releases/download/v${MY_PV}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ >=dev-db/sqlite-3.7.0:3
+ >=dev-libs/glib-2.28.0:2
+ dev-libs/gobject-introspection
+ dev-libs/json-glib
+ >=dev-libs/libpeas-1.0.0[gtk,python,${PYTHON_USEDEP}]
+ >=dev-libs/libxml2-2.6.27:2
+ >=dev-libs/libxslt-1.1.19
+ gnome-base/gsettings-desktop-schemas
+ >=net-libs/libsoup-2.42:2.4
+ net-libs/webkit-gtk:4
+ x11-libs/gtk+:3
+ >=x11-libs/pango-1.4.0"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig"
+
+S="${WORKDIR}"/${MY_P}
+
+PATCHES=(
+ "${FILESDIR}/${P}-signal.patch"
+)
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # gnome2_src_prepare calls elibtoolize
+ if [ -f "${S}"/.elibtoolized ]; then
+ local AT_NOELIBTOOLIZE="yes"
+ fi
+ eautoreconf
+}
+
+src_configure() {
+ gnome2_src_configure --disable-schemas-compile
+}
+
+src_install() {
+ gnome2_src_install
+
+ # bug #338213
+ # Uses webkit's JIT. Needs mmap('rwx') to generate code in runtime.
+ # MPROTECT policy violation. Will sit here until webkit will
+ # get optional JIT.
+ pax-mark m "${D%/}"/usr/bin/liferea
+
+ einfo "If you want to enhance the functionality of this package,"
+ einfo "you should consider installing:"
+ einfo " net-misc/networkmanager"
+}