summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-nntp/sn/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-nntp/sn/files')
-rw-r--r--net-nntp/sn/files/sn-0.3.8-parallel-make.patch56
-rw-r--r--net-nntp/sn/files/sn-0.3.8-qa.patch21
2 files changed, 77 insertions, 0 deletions
diff --git a/net-nntp/sn/files/sn-0.3.8-parallel-make.patch b/net-nntp/sn/files/sn-0.3.8-parallel-make.patch
new file mode 100644
index 000000000000..d94e21897781
--- /dev/null
+++ b/net-nntp/sn/files/sn-0.3.8-parallel-make.patch
@@ -0,0 +1,56 @@
+--- sn-0.3.8/Makefile.orig
++++ sn-0.3.8/Makefile
+@@ -94,39 +94,39 @@
+ ar rc $@ $^
+ ranlib $@
+
+-snsplit: snsplit.o sn.a
++snsplit: snsplit.o sn.a lib/libstuff.a
+ $(LD) `cat cc-flags` $^ -o $@ $(LIBS)
+-snscan: snscan.o sn.a
++snscan: snscan.o sn.a lib/libstuff.a
+ $(LD) `cat cc-flags` $^ -o $@ $(LIBS) $(ZLIB)
+ sncat: snscan
+ ln -s snscan sncat
+ sncancel: snscan
+ ln -s snscan sncancel
+-snprimedb: snprimedb.o sn.a
++snprimedb: snprimedb.o sn.a lib/libstuff.a
+ $(LD) `cat cc-flags` $^ -o $@ $(LIBS)
+-sndumpdb: sndumpdb.o sn.a
++sndumpdb: sndumpdb.o sn.a lib/libstuff.a
+ $(LD) `cat cc-flags` $^ -o $@ $(LIBS)
+-snntpd: snntpd.o post.o commands.o list.o sn.a
++snntpd: snntpd.o post.o commands.o list.o sn.a lib/libstuff.a
+ $(LD) `cat cc-flags` $^ -o $@ $(LIBS) $(ZLIB)
+-snsend: snsend.o sn.a
++snsend: snsend.o sn.a lib/libstuff.a
+ $(LD) `cat cc-flags` $^ -o $@ $(LIBS) $(ZLIB)
+ snstore: snsend
+ ln -s snsend snstore
+-snfetch: snfetch.o sn.a
++snfetch: snfetch.o sn.a lib/libstuff.a
+ $(LD) `cat cc-flags` $^ -o $@ $(LIBS)
+-snexpire: snexpire.o sn.a
++snexpire: snexpire.o sn.a lib/libstuff.a
+ $(LD) `cat cc-flags` $^ -o $@ $(LIBS)
+-snmail: snmail.o sn.a
++snmail: snmail.o sn.a lib/libstuff.a
+ $(LD) `cat cc-flags` $^ -o $@ $(LIBS)
+-snget: snget.o get.o sn.a
++snget: snget.o get.o sn.a lib/libstuff.a
+ $(LD) `cat cc-flags` $^ -o $@ $(LIBS)
+-sngetd: sngetd.o get.o sn.a
++sngetd: sngetd.o get.o sn.a lib/libstuff.a
+ $(LD) `cat cc-flags` $^ -o $@ $(LIBS)
+-snnewgroup: snnewgroup.o sn.a
++snnewgroup: snnewgroup.o sn.a lib/libstuff.a
+ $(LD) `cat cc-flags` $^ -o $@ $(LIBS)
+-sndelgroup: sndelgroup.o sn.a
++sndelgroup: sndelgroup.o sn.a lib/libstuff.a
+ $(LD) `cat cc-flags` $^ -o $@ $(LIBS)
+-snlockf: snlockf.o
++snlockf: snlockf.o sn.a lib/libstuff.a
+ $(LD) `cat cc-flags` $^ -o $@ $(LIBS)
+
+ %: %.in sed-cmd
diff --git a/net-nntp/sn/files/sn-0.3.8-qa.patch b/net-nntp/sn/files/sn-0.3.8-qa.patch
new file mode 100644
index 000000000000..52a25ebcd83e
--- /dev/null
+++ b/net-nntp/sn/files/sn-0.3.8-qa.patch
@@ -0,0 +1,21 @@
+--- lib/readln.c
++++ lib/readln.c
+@@ -9,6 +9,7 @@
+ * Get a single line from an fd.
+ */
+
++#include <string.h>
+ #include <stdlib.h>
+ #include <unistd.h>
+ #include <sys/types.h>
+
+--- lib/cmdopen.c
++++ lib/cmdopen.c
+@@ -6,6 +6,7 @@
+ */
+
+ #include <unistd.h>
++#include <stdlib.h>
+ #include <fcntl.h>
+ #include <sys/wait.h>
+