summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHaelwenn (lanodan) Monnier <contact@hacktivis.me>2020-04-28 11:26:18 +0300
committerJoonas Niilola <juippis@gentoo.org>2020-04-28 11:29:03 +0300
commit80f987361a6b6e4258acf49bd0a702b471a95050 (patch)
tree5c4b291e22ed09098e91f3d2a0838a82b2b6029d /net-nntp/suck/suck-4.3.4.ebuild
parentdev-perl/Apache-SizeLimit: -r bump for EAPI7 (diff)
downloadgentoo-80f987361a6b6e4258acf49bd0a702b471a95050.tar.gz
gentoo-80f987361a6b6e4258acf49bd0a702b471a95050.tar.bz2
gentoo-80f987361a6b6e4258acf49bd0a702b471a95050.zip
net-nntp/suck: Version bump, 4.3.4
Closes: https://bugs.gentoo.org/696724 Signed-off-by: Haelwenn (lanodan) Monnier <contact@hacktivis.me> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-nntp/suck/suck-4.3.4.ebuild')
-rw-r--r--net-nntp/suck/suck-4.3.4.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/net-nntp/suck/suck-4.3.4.ebuild b/net-nntp/suck/suck-4.3.4.ebuild
new file mode 100644
index 000000000000..6e3a5533c5c3
--- /dev/null
+++ b/net-nntp/suck/suck-4.3.4.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+DESCRIPTION="Grab news from a remote NNTP server and feed them to another"
+HOMEPAGE="https://lazarus-pkgs.github.io/lazarus-pkgs/suck.html"
+SRC_URI="https://github.com/lazarus-pkgs/suck/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="perl ssl libressl"
+
+RDEPEND="
+ sys-libs/gdbm:=
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:= )
+ )
+"
+DEPEND="${RDEPEND}
+ sys-libs/db
+ perl? ( dev-lang/perl )
+"
+
+src_prepare() {
+ default
+
+ # Fix paths to the locations in Gentoo
+ sed -i \
+ -e 's:/usr/bin/rnews:/usr/$(get_libdir)/news/bin/rnews:' \
+ -e 's:/var/lib/news/history:/var/spool/news/db/history:' \
+ suck_config.h || die "path adaption sed failed"
+
+ eautoreconf
+}
+
+src_configure() {
+ use ssl || sed -i -e 's/^SSL_/#SSL_/' Makefile.in || die "ssl sed failed"
+ use perl || sed -i -e 's/^PERL_/#PERL_/' Makefile.in || die "perl sed failed"
+
+ econf --without-inn-lib --without-inn-include
+}
+
+src_compile() {
+ emake phrases.h
+ emake all lpost
+}
+
+src_install() {
+ dobin lmove lpost rpost suck testhost
+ doman man/*
+ dodoc CHANGELOG CONTENTS README*
+ docinto java
+ dodoc java/*
+ docinto perl
+ dodoc perl/*
+ docinto sample
+ dodoc sample/*
+}