summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-20 01:50:38 +0100
committerSam James <sam@gentoo.org>2021-04-20 02:20:39 +0100
commitec5cfb01429f7ecb7ccf037517695d619ae8850a (patch)
treeee4a16955d951281abfdab97baabc264be4b56e5 /net-nntp
parentnet-news/rsstool: port to EAPI 7 (diff)
downloadgentoo-ec5cfb01429f7ecb7ccf037517695d619ae8850a.tar.gz
gentoo-ec5cfb01429f7ecb7ccf037517695d619ae8850a.tar.bz2
gentoo-ec5cfb01429f7ecb7ccf037517695d619ae8850a.zip
net-nntp/newspost: port to EAPI 7
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-nntp')
-rw-r--r--net-nntp/newspost/files/CAN-2005-0101.patch4
-rw-r--r--net-nntp/newspost/files/newspost-2.1.1-glibc-2.10.patch20
-rw-r--r--net-nntp/newspost/files/newspost-2.1.1-nntp.patch8
-rw-r--r--net-nntp/newspost/newspost-2.1.1-r3.ebuild17
4 files changed, 24 insertions, 25 deletions
diff --git a/net-nntp/newspost/files/CAN-2005-0101.patch b/net-nntp/newspost/files/CAN-2005-0101.patch
index 2bfdfc2c190d..c81936be61ba 100644
--- a/net-nntp/newspost/files/CAN-2005-0101.patch
+++ b/net-nntp/newspost/files/CAN-2005-0101.patch
@@ -1,5 +1,5 @@
---- base/socket.c.orig Tue Jan 18 11:08:02 2005
-+++ base/socket.c Tue Jan 18 11:10:08 2005
+--- a/base/socket.c
++++ b/base/socket.c
@@ -126,7 +126,7 @@
i = 0;
diff --git a/net-nntp/newspost/files/newspost-2.1.1-glibc-2.10.patch b/net-nntp/newspost/files/newspost-2.1.1-glibc-2.10.patch
index fdaa78cbefb7..8778ab41c253 100644
--- a/net-nntp/newspost/files/newspost-2.1.1-glibc-2.10.patch
+++ b/net-nntp/newspost/files/newspost-2.1.1-glibc-2.10.patch
@@ -1,6 +1,5 @@
-diff -ur newspost-2.1.1.orig/base/newspost.c newspost-2.1.1/base/newspost.c
---- newspost-2.1.1.orig/base/newspost.c 2003-04-23 18:33:23.000000000 +0300
-+++ newspost-2.1.1/base/newspost.c 2009-08-06 14:46:41.000000000 +0300
+--- a/base/newspost.c
++++ b/base/newspost.c
@@ -342,7 +342,7 @@
file = fopen(filename, "r");
if (file != NULL) {
@@ -10,9 +9,8 @@ diff -ur newspost-2.1.1.orig/base/newspost.c newspost-2.1.1/base/newspost.c
if(line == NULL){
text_buffer = buff_add(text_buffer, "\r\n");
continue;
-diff -ur newspost-2.1.1.orig/base/utils.c newspost-2.1.1/base/utils.c
---- newspost-2.1.1.orig/base/utils.c 2009-08-06 14:44:35.000000000 +0300
-+++ newspost-2.1.1/base/utils.c 2009-08-06 14:45:20.000000000 +0300
+--- a/base/utils.c
++++ b/base/utils.c
@@ -43,7 +43,7 @@
return NULL;
}
@@ -22,9 +20,8 @@ diff -ur newspost-2.1.1.orig/base/utils.c newspost-2.1.1/base/utils.c
int c = fgetc(file);
buff = buff_free(buff);
while(TRUE){
-diff -ur newspost-2.1.1.orig/base/utils.h newspost-2.1.1/base/utils.h
---- newspost-2.1.1.orig/base/utils.h 2003-02-08 17:09:41.000000000 +0200
-+++ newspost-2.1.1/base/utils.h 2009-08-06 14:45:13.000000000 +0300
+--- a/base/utils.h
++++ b/base/utils.h
@@ -26,7 +26,7 @@
file_entry * file_entry_alloc();
file_entry * file_entry_free(file_entry *fe);
@@ -34,9 +31,8 @@ diff -ur newspost-2.1.1.orig/base/utils.h newspost-2.1.1/base/utils.h
Buff *buff_add(Buff *buff, char *data, ... );
Buff * buff_free(Buff *buff);
Buff *buff_create(Buff *buff, char *data, ... );
-diff -ur newspost-2.1.1.orig/ui/options.c newspost-2.1.1/ui/options.c
---- newspost-2.1.1.orig/ui/options.c 2003-04-23 18:33:33.000000000 +0300
-+++ newspost-2.1.1/ui/options.c 2009-08-06 14:46:31.000000000 +0300
+--- a/ui/options.c
++++ b/ui/options.c
@@ -332,7 +332,7 @@
file = fopen(filename->data, "r");
if (file != NULL) {
diff --git a/net-nntp/newspost/files/newspost-2.1.1-nntp.patch b/net-nntp/newspost/files/newspost-2.1.1-nntp.patch
index 8779e8f36b47..7482d6203e0e 100644
--- a/net-nntp/newspost/files/newspost-2.1.1-nntp.patch
+++ b/net-nntp/newspost/files/newspost-2.1.1-nntp.patch
@@ -1,5 +1,5 @@
---- newspost-2.1.1.orig/base/nntp.c
-+++ newspost-2.1.1/base/nntp.c
+--- a/base/nntp.c
++++ b/base/nntp.c
@@ -26,6 +26,10 @@
*** Public Routines
**/
@@ -56,8 +56,8 @@
}
buff = buff_add(buff, "From: %s\r\n", data->from->data);
---- newspost-2.1.1.orig/base/utils.c
-+++ newspost-2.1.1/base/utils.c
+--- a/base/utils.c
++++ b/base/utils.c
@@ -44,7 +44,7 @@
}
diff --git a/net-nntp/newspost/newspost-2.1.1-r3.ebuild b/net-nntp/newspost/newspost-2.1.1-r3.ebuild
index 0bcce1c68dc6..b0633bc47a2a 100644
--- a/net-nntp/newspost/newspost-2.1.1-r3.ebuild
+++ b/net-nntp/newspost/newspost-2.1.1-r3.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit epatch toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="A usenet binary autoposter for unix"
HOMEPAGE="http://newspost.unixcab.org/"
@@ -12,13 +12,16 @@ SRC_URI="http://newspost.unixcab.org/download/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE=""
-src_prepare() {
+PATCHES=(
# Should fix some problems with unexpected server replies, cf. bug 185468
- epatch "${FILESDIR}"/${P}-nntp.patch
- epatch "${FILESDIR}"/CAN-2005-0101.patch
- epatch "${FILESDIR}"/${P}-glibc-2.10.patch
+ "${FILESDIR}"/${P}-nntp.patch
+ "${FILESDIR}"/CAN-2005-0101.patch
+ "${FILESDIR}"/${P}-glibc-2.10.patch
+)
+
+src_prepare() {
+ default
sed -e "/-strip newspost/d" -i Makefile || die
}