summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNils Freydank <holgersson@posteo.de>2018-05-09 14:43:58 +0200
committerMichał Górny <mgorny@gentoo.org>2018-05-11 08:48:01 +0200
commit98684e0684d522bba35fc0aa22bb7f9b9b5e5f65 (patch)
tree0274f926a31d405fa64e804f36cced070bbcd509 /net-p2p/mktorrent
parentdev-lang/nasm: keyworded 2.13.03-r1 for ia64, bug #655428 (diff)
downloadgentoo-98684e0684d522bba35fc0aa22bb7f9b9b5e5f65.tar.gz
gentoo-98684e0684d522bba35fc0aa22bb7f9b9b5e5f65.tar.bz2
gentoo-98684e0684d522bba35fc0aa22bb7f9b9b5e5f65.zip
net-p2p/mktorrent: Bump to 1.1_p20180502.
Closes: https://bugs.gentoo.org/650340 Package-Manager: Portage-2.3.36, Repoman-2.3.9
Diffstat (limited to 'net-p2p/mktorrent')
-rw-r--r--net-p2p/mktorrent/Manifest1
-rw-r--r--net-p2p/mktorrent/mktorrent-1.1_p20180502.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/net-p2p/mktorrent/Manifest b/net-p2p/mktorrent/Manifest
index 6c0db134f6ca..1ca0c17ea76b 100644
--- a/net-p2p/mktorrent/Manifest
+++ b/net-p2p/mktorrent/Manifest
@@ -1,2 +1,3 @@
DIST mktorrent-1.0.tar.gz 23089 BLAKE2B debfdbf2691fd1baa9f1647ef1cd64a4e5d8cbcabd77fb7c8a4b7ec5c1abbf4fa56ae54ea51afc58b0807cde8d525c4ac7106d38576e52a71e2776ba0bfcacda SHA512 f103c8860c008796c2dc604fcabce7374264fd7814237fcad5f9dab0fe10e927b0e2d9b58e7462dd198265a7d83fe30fd68313c7dce4029d8c331a6f2d4622de
DIST mktorrent-1.1.tar.gz 23314 BLAKE2B 97893553c99f3a6f994876b4689db2536cdaef30f9a392cf3ef800d5d92323336f836a9a3f92aff807a449bcc8553582275c4b36d98e1a1e99835945a7f4b43d SHA512 2a7ce83950711cf5be098693ad79273b29bcd8a5ef345ea296c7b6b83c532dd3463b347c7137234f1890cb4ea663ee5a5b1878591bc8fb4386d94e4f65410859
+DIST mktorrent-96090fb175f3cef17ae2499e98c2868363106927.tar.gz 24575 BLAKE2B 85f4c1088a5db91ba9bfa9391c82d81c87436a5ee920441c4e05a0e22d535aa1f3c60a0f2c6918a313f911ce9a586ab0ce725212926ad703f7daeaa4ee8b3e14 SHA512 2016cf9c81c6d35f3e482bb5cf8d0083664cee7131bc57f94ba5d0482df7d9b53e49a622035e1e93b6cebb50da9a29d8d00e2a65d3b84a872d98ed51e75a3a8a
diff --git a/net-p2p/mktorrent/mktorrent-1.1_p20180502.ebuild b/net-p2p/mktorrent/mktorrent-1.1_p20180502.ebuild
new file mode 100644
index 000000000000..6e9c5fe03dae
--- /dev/null
+++ b/net-p2p/mktorrent/mktorrent-1.1_p20180502.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit toolchain-funcs
+
+DESCRIPTION="Simple command line utility to create BitTorrent metainfo files"
+HOMEPAGE="https://github.com/Rudde/mktorrent"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Rudde/mktorrent.git"
+else
+ COMMIT_ID="96090fb175f3cef17ae2499e98c2868363106927"
+ SRC_URI="https://github.com/Rudde/${PN}/archive/${COMMIT_ID}.tar.gz -> ${PN}-${COMMIT_ID}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~x86"
+ S="${WORKDIR}/${PN}-${COMMIT_ID}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="threads +ssl debug"
+
+RDEPEND="ssl? ( dev-libs/openssl:0= )"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ tc-export CC
+
+ local myemakeargs=(
+ USE_LONG_OPTIONS=1
+ USE_LARGE_FILES=1
+ DEBUG=$(usex debug)
+ USE_OPENSSL=$(usex ssl)
+ USE_PTHREADS=$(usex threads)
+ )
+ emake "${myemakeargs[@]}"
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc README
+}