summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony Ryan <anthonyryan1@gmail.com>2015-10-18 20:14:01 -0400
committerAnthony Ryan <anthonyryan1@gmail.com>2015-10-26 14:02:45 -0400
commit68094515e99d372640000f147c958f3e6470322c (patch)
treeb788d8fe72dfb2c89280a85d7272ecb004ca434e /net-p2p/rtorrent
parentgames-strategy/0ad: rm old (diff)
downloadgentoo-68094515e99d372640000f147c958f3e6470322c.tar.gz
gentoo-68094515e99d372640000f147c958f3e6470322c.tar.bz2
gentoo-68094515e99d372640000f147c958f3e6470322c.zip
net-p2p/rtorrent: version bump 0.9.6
* Bumped net-libs/libtorrent (required bump by dependency) * Updated the HOMEPAGE and SRC_URI due to changes upstream * [Repoman] Bumped EAPI, copyright and added slot operators * Added additional metadata and fixed indentation of metadata.xml * Added missing test dependency for libtorrent * Removed posix_falloc test override (resolved upstream) * Initial LibreSSL support Fixes https://bugs.gentoo.org/562830
Diffstat (limited to 'net-p2p/rtorrent')
-rw-r--r--net-p2p/rtorrent/Manifest1
-rw-r--r--net-p2p/rtorrent/metadata.xml11
-rw-r--r--net-p2p/rtorrent/rtorrent-0.9.6.ebuild63
3 files changed, 70 insertions, 5 deletions
diff --git a/net-p2p/rtorrent/Manifest b/net-p2p/rtorrent/Manifest
index eb354f0c1a72..abc99eba05d8 100644
--- a/net-p2p/rtorrent/Manifest
+++ b/net-p2p/rtorrent/Manifest
@@ -1,2 +1,3 @@
DIST rtorrent-0.9.3.tar.gz 583311 SHA256 9e93ca41beb1afe74ad7ad8013e0d53ae3586c9b0e97263d722f721535cc7310 SHA512 a6cc390795c0cf36bf70f4f141db3e176c81df0d6754fe2e6a95ef59385a70e7ce006fe81b83deff5b32e06cc771d03c5c7ba1140be64b2d252719e8aa2058f3 WHIRLPOOL 7cb2e51718596145ef8a07b1de0bb9ccd4dc923a4ec8091a3f775dffaafe5111873d43047e6e32720a202774454e53443e402010d956954f19cdfdb08983ec52
DIST rtorrent-0.9.4.tar.gz 601913 SHA256 bc0a2c1ee613b68f37021beaf4e64a9252f91ed06f998c1e897897c354ce7e84 SHA512 ae243d0336acff50e91e4ed9d306beb4705559775518e6dc122ec18a1530e59e2c531cf54f4b79899a1569ca18d343fce255071b45c41df1357bddfe926692aa WHIRLPOOL 03eb3cff0f7d490ada2199310fd2ba7576de8e20557e532df49be17f84aa2afb9cb8137b2eb317bc0fb4ce8ce035e900c65c32e81dc5d5d215923d91e8c0612a
+DIST rtorrent-0.9.6.tar.gz 610845 SHA256 1e69c24f1f26f8f07d58d673480dc392bfc4317818c1115265b08a7813ff5b0e SHA512 704f7b79d5bc78b817da21a6886662a5a97fde210a110c50f708bdc18e1dcf3ef5c5f4e2740261d41221cfc69c19926bf34e10057adf10601da9e6e06b2cef75 WHIRLPOOL df5878014087d894e9796508627ec508ff5d042c78cc09e8d9ae57a7f9556bb549f9900e3995a7296420438ca0edda245907f8ae0c71d5a0ae28c3af7a6f992e
diff --git a/net-p2p/rtorrent/metadata.xml b/net-p2p/rtorrent/metadata.xml
index 0547227d9821..9fa2e6deabbe 100644
--- a/net-p2p/rtorrent/metadata.xml
+++ b/net-p2p/rtorrent/metadata.xml
@@ -3,11 +3,12 @@
<pkgmetadata>
<herd>net-p2p</herd>
<longdescription lang="en">
- Console BitTorrent client using ncurses based on libtorrent written in C++.
-</longdescription>
+ Console BitTorrent client using ncurses based on libtorrent written in C++.
+ </longdescription>
<use>
- <flag name="daemon">Uses <pkg>app-misc/screen</pkg> to daemonize this
- application
- </flag>
+ <flag name="daemon">Uses <pkg>app-misc/screen</pkg> to daemonize this application</flag>
</use>
+ <upstream>
+ <remote-id type="github">rakshasa/rtorrent</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/net-p2p/rtorrent/rtorrent-0.9.6.ebuild b/net-p2p/rtorrent/rtorrent-0.9.6.ebuild
new file mode 100644
index 000000000000..efbf0261f74c
--- /dev/null
+++ b/net-p2p/rtorrent/rtorrent-0.9.6.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils systemd
+
+DESCRIPTION="BitTorrent Client using libtorrent"
+HOMEPAGE="https://rakshasa.github.io/rtorrent/"
+SRC_URI="http://rtorrent.net/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris"
+IUSE="daemon debug ipv6 selinux test xmlrpc"
+
+COMMON_DEPEND="~net-libs/libtorrent-0.13.${PV##*.}
+ >=dev-libs/libsigc++-2.2.2:2
+ >=net-misc/curl-7.19.1
+ sys-libs/ncurses:0=
+ xmlrpc? ( dev-libs/xmlrpc-c )"
+RDEPEND="${COMMON_DEPEND}
+ daemon? ( app-misc/screen )
+ selinux? ( sec-policy/selinux-rtorrent )
+"
+DEPEND="${COMMON_DEPEND}
+ dev-util/cppunit
+ virtual/pkgconfig"
+
+DOCS=( doc/rtorrent.rc )
+
+src_prepare() {
+ # bug #358271
+ epatch \
+ "${FILESDIR}"/${PN}-0.9.1-ncurses.patch \
+ "${FILESDIR}"/${PN}-0.9.4-tinfo.patch
+
+ # https://github.com/rakshasa/rtorrent/issues/332
+ cp "${FILESDIR}"/rtorrent.1 "${S}"/doc/ || die
+
+ eautoreconf
+}
+
+src_configure() {
+ # configure needs bash or script bombs out on some null shift, bug #291229
+ CONFIG_SHELL=${BASH} econf \
+ --disable-dependency-tracking \
+ $(use_enable debug) \
+ $(use_enable ipv6) \
+ $(use_with xmlrpc xmlrpc-c)
+}
+
+src_install() {
+ default
+ doman doc/rtorrent.1
+
+ if use daemon; then
+ newinitd "${FILESDIR}/rtorrentd.init" rtorrentd
+ newconfd "${FILESDIR}/rtorrentd.conf" rtorrentd
+ systemd_newunit "${FILESDIR}/rtorrentd_at.service" "rtorrentd@.service"
+ fi
+}