summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2017-03-26 22:18:52 -0400
committerMichael Orlitzky <mjo@gentoo.org>2017-03-26 22:18:52 -0400
commit3360cea4a297c59e3983f29ee2f370300cfcb2d0 (patch)
tree786e6e8fb94184f87ca1491b564700d42586d656 /net-p2p
parentnet-p2p/amule: remove unused version 2.3.1-r2. (diff)
downloadgentoo-3360cea4a297c59e3983f29ee2f370300cfcb2d0.tar.gz
gentoo-3360cea4a297c59e3983f29ee2f370300cfcb2d0.tar.bz2
gentoo-3360cea4a297c59e3983f29ee2f370300cfcb2d0.zip
net-p2p/amule: new revision to fix media-libs/gd USE dependency.
With USE=stats, amule needs gd to be built with PNG support. There was already a USE dependency for JPEG support, and this revision adds it for PNG, too. Gentoo-Bug: 612386 Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/amule/amule-2.3.2-r1.ebuild (renamed from net-p2p/amule/amule-2.3.2.ebuild)30
1 files changed, 14 insertions, 16 deletions
diff --git a/net-p2p/amule/amule-2.3.2.ebuild b/net-p2p/amule/amule-2.3.2-r1.ebuild
index d188432fea09..06bb5d1e7076 100644
--- a/net-p2p/amule/amule-2.3.2.ebuild
+++ b/net-p2p/amule/amule-2.3.2-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -6,8 +6,8 @@ WX_GTK_VER="3.0"
inherit wxwidgets user
-MY_P=${PN/m/M}-${PV}
-S="${WORKDIR}"/${MY_P}
+MY_P="${PN/m/M}-${PV}"
+S="${WORKDIR}/${MY_P}"
DESCRIPTION="aMule, the all-platform eMule p2p client"
HOMEPAGE="http://www.amule.org/"
@@ -18,23 +18,21 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
IUSE="daemon debug geoip nls remote stats unicode upnp +X"
-DEPEND="
- >=dev-libs/crypto++-5
+COMMON_DEPEND="
+ dev-libs/crypto++
sys-libs/binutils-libs:0=
- >=sys-libs/zlib-1.2.1
+ sys-libs/zlib
x11-libs/wxGTK:${WX_GTK_VER}[X?]
- stats? ( >=media-libs/gd-2.0.26:=[jpeg] )
+ stats? ( media-libs/gd:=[jpeg,png] )
geoip? ( dev-libs/geoip )
- upnp? ( >=net-libs/libupnp-1.6.6 )
- remote? ( >=media-libs/libpng-1.2.0:0=
- unicode? ( >=media-libs/gd-2.0.26:= ) )
- !net-p2p/imule
-"
-RDEPEND="${DEPEND}"
+ upnp? ( net-libs/libupnp:* )
+ remote? ( media-libs/libpng:0=
+ unicode? ( media-libs/gd:= ) )
+ !net-p2p/imule"
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}"
-PATCHES=(
- "${FILESDIR}"/${PN}-2.2.6-fallocate.diff
-)
+PATCHES=( "${FILESDIR}/${PN}-2.2.6-fallocate.diff" )
pkg_setup() {
if use stats && ! use X; then