summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-08-18 19:40:43 +0200
committerPacho Ramos <pacho@gentoo.org>2016-08-18 19:43:00 +0200
commit35c183ce3b6c41fbea8bdaafc01e5e12009b7724 (patch)
treea7c8c0e6d83013df9c48a77a1ce7c0ee33e6d7d5 /net-p2p
parentapp-emulation/containerd: Remove temporary 0.2.2 snapshot (diff)
downloadgentoo-35c183ce3b6c41fbea8bdaafc01e5e12009b7724.tar.gz
gentoo-35c183ce3b6c41fbea8bdaafc01e5e12009b7724.tar.bz2
gentoo-35c183ce3b6c41fbea8bdaafc01e5e12009b7724.zip
net-p2p/ed2k_hash: fltk support is completely broken (#359643)
Package-Manager: portage-2.3.0
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/ed2k_hash/ed2k_hash-0.4.0-r2.ebuild38
-rw-r--r--net-p2p/ed2k_hash/files/ed2k_64bit.patch4
2 files changed, 40 insertions, 2 deletions
diff --git a/net-p2p/ed2k_hash/ed2k_hash-0.4.0-r2.ebuild b/net-p2p/ed2k_hash/ed2k_hash-0.4.0-r2.ebuild
new file mode 100644
index 000000000000..0d946380a1e7
--- /dev/null
+++ b/net-p2p/ed2k_hash/ed2k_hash-0.4.0-r2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit flag-o-matic
+
+DESCRIPTION="Tool for generating eDonkey2000 links"
+HOMEPAGE="http://ed2k-tools.sourceforge.net/ed2k_hash.shtml"
+RESTRICT="mirror"
+SRC_URI="mirror://sourceforge/ed2k-tools/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="" # fltk support is broken, bug #359643
+
+DEPEND=""
+RDEPEND=""
+#DEPEND="fltk? ( x11-libs/fltk:1 )"
+
+PATCHES=( "${FILESDIR}/ed2k_64bit.patch" )
+
+src_configure() {
+# if use fltk; then
+# append-ldflags "$(fltk-config --ldflags)"
+# export CPPFLAGS="$(fltk-config --cxxflags)"
+# else
+ export ac_cv_lib_fltk_main='no'
+# fi
+
+ econf
+}
+
+src_install() {
+ emake install DESTDIR="${D}" mydocdir=/usr/share/doc/${PF}/html
+ einstalldocs
+}
diff --git a/net-p2p/ed2k_hash/files/ed2k_64bit.patch b/net-p2p/ed2k_hash/files/ed2k_64bit.patch
index 7425bb0c03fc..3523b1febecd 100644
--- a/net-p2p/ed2k_hash/files/ed2k_64bit.patch
+++ b/net-p2p/ed2k_hash/files/ed2k_64bit.patch
@@ -1,5 +1,5 @@
---- ed2k_hash-0.4.0/work/ed2k_hash-0.4.0/ed2k_hash/md4.h 2002-09-04 18:24:37.000000000 +0100
-+++ ed2k_hash-0.4.0_orig/work/ed2k_hash-0.4.0/ed2k_hash/md4.h 2004-09-02 21:13:49.900613616 +0100
+--- a/ed2k_hash/md4.h 2002-09-04 18:24:37.000000000 +0100
++++ b/ed2k_hash/md4.h 2004-09-02 21:13:49.900613616 +0100
@@ -66,7 +66,8 @@
typedef unsigned short int UINT2;