summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2017-03-08 00:59:12 +0100
committerDavid Seifert <soap@gentoo.org>2017-03-08 10:17:59 +0100
commit89934ddb2050964cc772bef4f58f09dbf74c5856 (patch)
treef4df6a2ab33d23feb30213533d49b91627f80a24 /net-p2p
parentdev-libs/qrosscore: remove Qt4-only 0.3.1, fixes bug #581540 (diff)
downloadgentoo-89934ddb2050964cc772bef4f58f09dbf74c5856.tar.gz
gentoo-89934ddb2050964cc772bef4f58f09dbf74c5856.tar.bz2
gentoo-89934ddb2050964cc772bef4f58f09dbf74c5856.zip
net-p2p/syncthing: bump to 0.14.24
Package-Manager: Portage-2.3.4, Repoman-2.3.2 Closes: https://github.com/gentoo/gentoo/pull/4153
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/syncthing/Manifest1
-rw-r--r--net-p2p/syncthing/syncthing-0.14.24.ebuild114
2 files changed, 115 insertions, 0 deletions
diff --git a/net-p2p/syncthing/Manifest b/net-p2p/syncthing/Manifest
index c63918331109..dab62ec18ebe 100644
--- a/net-p2p/syncthing/Manifest
+++ b/net-p2p/syncthing/Manifest
@@ -1,2 +1,3 @@
DIST syncthing-0.14.21.tar.gz 6771897 SHA256 b46e67e16f64631b956b6724afd229876a1fee95c12dae4ae211d2623e35fdf6 SHA512 f1fe3c3fd56e1832341e74213dfbbe82ae731bdad49053a9c8d36eac8fd74a77189f1dc524cd61978092a06d355930082307bbd0aab57705c8e69f5aaf34b598 WHIRLPOOL edb9f409fa9e11501b46d3da9f22390c2a6e86f8227d35a786b9e2ce036cb54040466e810c41ce95a3e6019c30d7fea75b65528fb58c1d588a665e3374b66597
DIST syncthing-0.14.23.tar.gz 6783975 SHA256 bf8a13f27329c85a3fddef87a3dc90d40b6de3a233738b1d05127bc378aacd60 SHA512 36a1d0f1ec6642056a6ff43b90af417eff09d6f9c7358fb1d80c3f0470d9c686d8644e4491c94f95a644ee26b6b4df4ecc27d519c7d4cc39539061f6dc5b181c WHIRLPOOL cae76bc2f41bb7c3a3df3fdf2af702a42e4f25f8dc2f03c0b90bd51f0205f29354a2b4744d7d54e8e11f15509c695ae9693b37d35b4e7d03087f71faf8d90ff8
+DIST syncthing-0.14.24.tar.gz 6781504 SHA256 6538536d4c1c17dc20e1f1253f7a393ea7cf2f993d27b41e74d98af5963c2fc3 SHA512 164bb2ec8a85b5d10c9b4a08dfc3a94ff1b479069f272471067dea82ac6bb1616ea21fd2576bf5464c144be1bff61a89c24f04fe18c20c4c982acd26c0cc5ca3 WHIRLPOOL 56233ac875be1f633eae73337a88175391cae7d25a2a46d1715dd3b4397054863cdc1fc4a92dbdf1253dfecedaa8bf5d370428b78699ca6ce9d160a53148440a
diff --git a/net-p2p/syncthing/syncthing-0.14.24.ebuild b/net-p2p/syncthing/syncthing-0.14.24.ebuild
new file mode 100644
index 000000000000..6a552aa9568f
--- /dev/null
+++ b/net-p2p/syncthing/syncthing-0.14.24.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGO_PN="github.com/${PN}/${PN}"
+
+inherit golang-vcs-snapshot systemd user versionator
+
+DESCRIPTION="Open Source Continuous File Synchronization"
+HOMEPAGE="https://syncthing.net"
+SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~arm"
+IUSE="tools"
+
+DOCS=( README.md AUTHORS CONTRIBUTING.md )
+
+pkg_setup() {
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 /var/lib/${PN} ${PN}
+
+ if use tools ; then
+ # separate user for the relay server
+ enewgroup strelaysrv
+ enewuser strelaysrv -1 -1 /var/lib/strelaysrv strelaysrv
+ # and his home folder
+ keepdir /var/lib/strelaysrv
+ fowners strelaysrv:strelaysrv /var/lib/strelaysrv
+ fi
+}
+
+src_prepare() {
+ default
+ sed -i \
+ 's|^ExecStart=.*|ExecStart=/usr/libexec/syncthing/strelaysrv|' \
+ src/${EGO_PN}/cmd/strelaysrv/etc/linux-systemd/strelaysrv.service \
+ || die
+}
+
+src_compile() {
+ export GOPATH="${S}:$(get_golibdir_gopath)"
+ cd src/${EGO_PN} || die
+ go run build.go -version "v${PV}" -no-upgrade install \
+ $(usex tools "all" "") || die "build failed"
+}
+
+src_test() {
+ cd src/${EGO_PN} || die
+ go run build.go test || die "test failed"
+}
+
+src_install() {
+ pushd src/${EGO_PN} >& /dev/null || die
+ doman man/*.[157]
+ einstalldocs
+
+ dobin bin/syncthing
+ if use tools ; then
+ exeinto /usr/libexec/syncthing
+ local exe
+ for exe in bin/* ; do
+ [[ "${exe}" == "bin/syncthing" ]] || doexe "${exe}"
+ done
+ fi
+ popd >& /dev/null || die
+
+ # openrc and systemd service files
+ systemd_dounit src/${EGO_PN}/etc/linux-systemd/system/${PN}{@,-resume}.service
+ systemd_douserunit src/${EGO_PN}/etc/linux-systemd/user/${PN}.service
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+
+ keepdir /var/{lib,log}/${PN}
+ fowners ${PN}:${PN} /var/{lib,log}/${PN}
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/${PN}.logrotate" ${PN}
+
+ if use tools ; then
+ # openrc and systemd service files
+ systemd_dounit src/${EGO_PN}/cmd/strelaysrv/etc/linux-systemd/strelaysrv.service
+ newconfd "${FILESDIR}/strelaysrv.confd" strelaysrv
+ newinitd "${FILESDIR}/strelaysrv.initd" strelaysrv
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/strelaysrv.logrotate" strelaysrv
+ fi
+}
+
+pkg_postinst() {
+ local v
+ for v in ${REPLACING_VERSIONS}; do
+ if [[ $(get_version_component_range 2) -gt \
+ $(get_version_component_range 2 ${v}) ]]; then
+ ewarn "Version ${PV} is not protocol-compatible with version" \
+ "0.$(($(get_version_component_range 2) - 1)).x or lower."
+ ewarn "Make sure all your devices are running at least version" \
+ "0.$(get_version_component_range 2).0."
+ fi
+ done
+
+ # check if user syncthing-relaysrv exists
+ # if yes, warn that it has been moved to strelaysrv
+ if [[ -n "$(egetent passwd syncthing-relaysrv 2>/dev/null)" ]]; then
+ ewarn
+ ewarn "The user and group for the relay server have been changed"
+ ewarn "from syncthing-relaysrv to strelaysrv"
+ ewarn "The old user and group are not deleted automatically. Delete them by running:"
+ ewarn " userdel -r syncthing-relaysrv"
+ ewarn " groupdel syncthing-relaysrv"
+ fi
+}