summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBertrand Jacquin <bertrand@jacquin.bzh>2016-09-10 19:46:40 +0100
committerChristian Ruppert <idl0r@gentoo.org>2016-09-28 21:53:50 +0200
commit35602ec5ee9c4f657ac616004ab0c35147bbfa4c (patch)
tree4c1bbdd3a3584e71fad8a92ef00ae0c0cb105b7a /net-proxy
parentprofile/hardened: add vtv support #547040 (diff)
downloadgentoo-35602ec5ee9c4f657ac616004ab0c35147bbfa4c.tar.gz
gentoo-35602ec5ee9c4f657ac616004ab0c35147bbfa4c.tar.bz2
gentoo-35602ec5ee9c4f657ac616004ab0c35147bbfa4c.zip
net-proxy/haproxy: Version bump
Move to EAPI 6 Replace dodoc with DOCS Use EROOT instead of ROOT Package-Manager: portage-2.2.28 Closes: https://github.com/gentoo/gentoo/pull/2293 Signed-off-by: Christian Ruppert <idl0r@gentoo.org>
Diffstat (limited to 'net-proxy')
-rw-r--r--net-proxy/haproxy/Manifest2
-rw-r--r--net-proxy/haproxy/haproxy-1.6.9.ebuild (renamed from net-proxy/haproxy/haproxy-1.6.8.ebuild)15
2 files changed, 11 insertions, 6 deletions
diff --git a/net-proxy/haproxy/Manifest b/net-proxy/haproxy/Manifest
index 00567bebb131..06b20d19bfc4 100644
--- a/net-proxy/haproxy/Manifest
+++ b/net-proxy/haproxy/Manifest
@@ -1,3 +1,3 @@
DIST haproxy-1.5.14.tar.gz 1345345 SHA256 9565dd38649064d0350a2883fa81ccfe92eb17dcda457ebdc01535e1ab0c8f99 SHA512 83d6101fd402f37845ab3febc914335e4c6d9bdebbb0ff81c8e048d5252ffa5a1b77c4250a434fed5dd541ef1f1f2c47d969b59f7a51d6ab9aea38a8646a9798 WHIRLPOOL 7d2c580589b9b31e1eba169e4bf930ac42d2564e21eb1c25adbdd39b701abd221fd671ebc227167ab956a48b2c30eeb740a6394355a8fa748c408ee42fdff6fc
DIST haproxy-1.5.18.tar.gz 1360582 SHA256 14a5684d85cf65c34a8d441afff2aaa4dd9b4234e81b3d4ddd242e6e7c97257e SHA512 b4f85986a6b1e0d152b643f576a0ff770fbc190457d3e0130fbb923ff9bf4d00b634e64edf0eadd5b47d0eb758fd9f6ecf33907fc4c21150a518064df954e7d0 WHIRLPOOL 5faf0aec42332564a3c392b0bbca25dc56c6a754672e1853ca765fc5d95d9ca963cd041dc705bbb38085a3da77219adf061966f2caa209e327ff02f3ee8fde3b
-DIST haproxy-1.6.8.tar.gz 1566594 SHA256 a51b7bf667245369683f8aafb288c4e33cb55d36c4b4b836f1dfc9aa56bb095c SHA512 692f93e0abf4ba457f74c25a17940ed855f39cbc50b4a4912e066cc8299cba5ba95d90dae98af95fbfa73b5b2fbb6ad21da7b6fa91cde7a91754f17f5bc332a3 WHIRLPOOL 1ecfced926da5c582bfe38fc20815bf57209c3c8afe5284a38c1e3e9446941993c8c3b2c9ba8b67256adf3c507d365fce02ab4ce175bbb411817b7753dee1a1c
+DIST haproxy-1.6.9.tar.gz 1566715 SHA256 cf7d2fa891d2ae4aa6489fc43a9cadf68c42f9cb0de4801afad45d32e7dda133 SHA512 0060a93c628689e1ca9e5845f9f93641f7647efc176cbf093bce59be19496492c317c8101fa50dd6181b130f861c74a20199f18e41ebd6995715364b1ea46a2e WHIRLPOOL a7311cb08507898cf19a422a6a55a6d429cbb99e0329b2de0defea472314c495d6c426a973ef436d532340f95d5abee2ad07fbf1d051d36fe4618ac28b743a35
diff --git a/net-proxy/haproxy/haproxy-1.6.8.ebuild b/net-proxy/haproxy/haproxy-1.6.9.ebuild
index 5b2d0aa04025..9ddbe6f57d9f 100644
--- a/net-proxy/haproxy/haproxy-1.6.8.ebuild
+++ b/net-proxy/haproxy/haproxy-1.6.9.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="5"
+EAPI="6"
inherit user versionator toolchain-funcs flag-o-matic systemd linux-info
@@ -32,6 +32,8 @@ RDEPEND="${DEPEND}"
S="${WORKDIR}/${MY_P}"
+DOCS=( CHANGELOG CONTRIBUTING MAINTAINERS )
+
pkg_setup() {
enewgroup haproxy
enewuser haproxy -1 -1 -1 haproxy
@@ -43,6 +45,8 @@ pkg_setup() {
}
src_prepare() {
+ default
+
sed -e 's:@SBINDIR@:'/usr/bin':' contrib/systemd/haproxy.service.in \
> contrib/systemd/haproxy.service || die
@@ -119,12 +123,13 @@ src_install() {
newconfd "${FILESDIR}/${PN}.confd" $PN
newinitd "${FILESDIR}/${PN}.initd-r3" $PN
- dodoc CHANGELOG CONTRIBUTING MAINTAINERS
doman doc/haproxy.1
dobin haproxy-systemd-wrapper
systemd_dounit contrib/systemd/haproxy.service
+ einstalldocs
+
if use doc; then
dodoc ROADMAP doc/{close-options,configuration,cookie-options,intro,linux-syn-cookies,management,proxy-protocol}.txt
fi
@@ -151,15 +156,15 @@ src_install() {
}
pkg_postinst() {
- if [[ ! -f "${ROOT}/etc/haproxy/haproxy.cfg" ]] ; then
+ if [[ ! -f "${EROOT}/etc/haproxy/haproxy.cfg" ]] ; then
ewarn "You need to create /etc/haproxy/haproxy.cfg before you start the haproxy service."
ewarn "It's best practice to not run haproxy as root, user and group haproxy was therefore created."
ewarn "Make use of them with the \"user\" and \"group\" directives."
- if [[ -d "${ROOT}/usr/share/doc/${PF}" ]]; then
+ if [[ -d "${EROOT}/usr/share/doc/${PF}" ]]; then
einfo "Please consult the installed documentation for learning the configuration file's syntax."
einfo "The documentation and sample configuration files are installed here:"
- einfo " ${ROOT}usr/share/doc/${PF}"
+ einfo " ${EROOT}usr/share/doc/${PF}"
fi
fi
}