summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Savchenko <bircoph@gentoo.org>2017-01-10 14:26:24 +0300
committerAndrew Savchenko <bircoph@gentoo.org>2017-01-10 14:26:54 +0300
commit63b8c050c2115100aa95e9c860d720607698bf63 (patch)
treeeccb605cce3002505cf520dc8e0f33ba0fb72a7b /net-proxy
parentgnome-extra/cinnamon-screensaver: setproctitle RDEP was added to wrong version (diff)
downloadgentoo-63b8c050c2115100aa95e9c860d720607698bf63.tar.gz
gentoo-63b8c050c2115100aa95e9c860d720607698bf63.tar.bz2
gentoo-63b8c050c2115100aa95e9c860d720607698bf63.zip
net-proxy/privoxy: 3.0.26 version bump
Package-Manager: Portage-2.3.3, Repoman-2.3.1 Signed-off-by: Andrew Savchenko <bircoph@gentoo.org>
Diffstat (limited to 'net-proxy')
-rw-r--r--net-proxy/privoxy/Manifest1
-rw-r--r--net-proxy/privoxy/metadata.xml6
-rw-r--r--net-proxy/privoxy/privoxy-3.0.26.ebuild128
3 files changed, 135 insertions, 0 deletions
diff --git a/net-proxy/privoxy/Manifest b/net-proxy/privoxy/Manifest
index 2ca75b89a032..98f326c90bca 100644
--- a/net-proxy/privoxy/Manifest
+++ b/net-proxy/privoxy/Manifest
@@ -1 +1,2 @@
DIST privoxy-3.0.24-stable-src.tar.gz 1728265 SHA256 a381f6dc78f08de0d4a2342d47a5949a6608073ada34b933137184f3ca9fb012 SHA512 4002df09613f06b337d3d56034443ac1481bc99dbd063857a3b02d6c2cec62b1d0cdf23a6396daba74e2be5b899d85e967dacb8e875f15e0824f00038b212705 WHIRLPOOL 4d23baad88bdc0c1cfad48440d464e5ec40208a317653b0c2e6a8bbd8a831d441576ddd41e82cddde73e7f9d3e954afdd654d1a163b1123379699d7b40159d96
+DIST privoxy-3.0.26-stable-src.tar.gz 1741772 SHA256 57e415b43ee5dfdca74685cc034053eaae962952fdabd086171551a86abf9cd8 SHA512 e448305287d0451c761b76b8d8974ea1ec837b621bbb498a7ff16a54cb4d8f1f734efe2eef03235c01163bb40e225785065aad6ee265a31d90970ab98af11044 WHIRLPOOL 56fc14cea34923186163a91747ba09bbe8c79464ed6668c6776d83f088f3742728ff0b0755e4ca0bfe7a8ed645627b1956876e59256cf76e25f1c13017957779
diff --git a/net-proxy/privoxy/metadata.xml b/net-proxy/privoxy/metadata.xml
index 0c46a859bf13..ff0981277efe 100644
--- a/net-proxy/privoxy/metadata.xml
+++ b/net-proxy/privoxy/metadata.xml
@@ -15,16 +15,22 @@
</longdescription>
<use>
<flag name="editor">Enable the web-based actions file editor</flag>
+ <flag name="client-tags">Enable support for client-specific tags</flag>
+ <flag name="compression">Allow privoxy to compress buffered content before sending to the client, if it supports it</flag>
+ <flag name="extended-host-patterns">Enable and require PCRE syntax in host patterns. You must convert action files to PCRE, see privoxy-url-pattern-translator.pl Use at your own risk!</flag>
<flag name="external-filters">Allow to filter content with scripts and programs. Experimental</flag>
<flag name="fast-redirects">Support fast redirects</flag>
<flag name="force">Allow single-page disable (force load)</flag>
<flag name="graceful-termination">Allow to shutdown Privoxy through the webinterface</flag>
+ <flag name="ie-images">Enable a quick but not always reliable auto-detect whether requests from MS Internet Explorer are for an image or not</flag>
<flag name="image-blocking">Allows the +handle-as-image action, to send "blocked" images instead of HTML</flag>
<flag name="lfs">Support large files (&gt;2GB) on 32-bit systems</flag>
<flag name="png-images">Use PNG format instead of GIF for built-in images</flag>
<flag name="stats">Keep statistics</flag>
<flag name="toggle">Support temporary disable toggle via web interface</flag>
+ <flag name="tools">Install log parser, regression tester and user agent generator tools</flag>
<flag name="whitelists">Support trust files (white lists)</flag>
+ <flag name="zlib">Use <pkg>sys-libs/zlib</pkg> to decompress data before filtering</flag>
</use>
<upstream>
<remote-id type="sourceforge">ijbswa</remote-id>
diff --git a/net-proxy/privoxy/privoxy-3.0.26.ebuild b/net-proxy/privoxy/privoxy-3.0.26.ebuild
new file mode 100644
index 000000000000..284e39ea669c
--- /dev/null
+++ b/net-proxy/privoxy/privoxy-3.0.26.ebuild
@@ -0,0 +1,128 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+inherit autotools systemd toolchain-funcs user
+
+[ "${PV##*_}" = "beta" ] &&
+ PRIVOXY_STATUS="beta" ||
+ PRIVOXY_STATUS="stable"
+
+HOMEPAGE="http://www.privoxy.org https://sourceforge.net/projects/ijbswa/"
+DESCRIPTION="A web proxy with advanced filtering capabilities for enhancing privacy"
+SRC_URI="mirror://sourceforge/ijbswa/${P%_*}-${PRIVOXY_STATUS}-src.tar.gz"
+
+IUSE="+acl client-tags compression editor extended-host-patterns
+external-filters +fast-redirects +force graceful-termination
+ie-images +image-blocking ipv6 lfs png-images selinux +stats
++threads toggle tools whitelists +zlib"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+LICENSE="GPL-2"
+
+DEPEND="
+ dev-libs/libpcre
+ zlib? ( sys-libs/zlib )
+"
+RDEPEND="${DEPEND}
+ extended-host-patterns? ( dev-lang/perl )
+ selinux? ( sec-policy/selinux-privoxy )
+ tools? (
+ net-misc/curl
+ dev-lang/perl
+ )
+"
+REQUIRED_USE="
+ compression? ( zlib )
+ toggle? ( editor )
+"
+
+S="${WORKDIR}/${P%_*}-${PRIVOXY_STATUS}"
+
+PATCHES=( "${FILESDIR}"/${PN}-3.0.19-gentoo.patch )
+
+pkg_pretend() {
+ if ! use threads; then
+ ewarn
+ ewarn "Privoxy may be very slow without threads support, consider to enable them."
+ ewarn "See also http://www.privoxy.org/faq/trouble.html#GENTOO-RICERS"
+ ewarn
+ fi
+}
+
+pkg_setup() {
+ enewgroup privoxy
+ enewuser privoxy -1 -1 /etc/privoxy privoxy
+}
+
+src_prepare() {
+ default
+ mv configure.in configure.ac || die
+ sed -i "s|/p\.p/|/config.privoxy.org/|g" tools/privoxy-regression-test.pl || die
+
+ # autoreconf needs to be called even if we don't modify any autotools source files
+ # See main makefile
+ eautoreconf
+}
+
+src_configure() {
+ # --with-debug only enables debug CFLAGS
+ # --with-docbook and --with-db2html and their deps are useless,
+ # since docs are already pregenerated in the source tarball
+ econf \
+ --docdir=/usr/share/doc/${PF} \
+ --sysconfdir=/etc/privoxy \
+ --enable-dynamic-pcre \
+ --with-user=privoxy \
+ --with-group=privoxy \
+ $(use_enable acl acl-support) \
+ $(use_enable compression) \
+ $(use_enable client-tags) \
+ $(use_enable editor) \
+ $(use_enable extended-host-patterns) \
+ $(use_enable fast-redirects) \
+ $(use_enable force) \
+ $(use_enable graceful-termination) \
+ $(use_enable ie-images) \
+ $(use_enable image-blocking) \
+ $(use_enable ipv6 ipv6-support) \
+ $(use_enable kernel_FreeBSD accept-filter) \
+ $(use_enable lfs large-file-support) \
+ $(use_enable png-images no-gifs) \
+ $(use_enable stats) \
+ $(use_enable threads pthread) \
+ $(use_enable toggle) \
+ $(use_enable whitelists trust-files) \
+ $(use_enable zlib)
+}
+
+src_install () {
+ default
+
+ newinitd "${FILESDIR}/privoxy.initd-3" privoxy
+ systemd_dounit "${FILESDIR}"/${PN}.service
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/privoxy.logrotate" privoxy
+
+ diropts -m 0750 -g privoxy -o privoxy
+ keepdir /var/log/privoxy
+
+ use extended-host-patterns && newbin tools/url-pattern-translator.pl privoxy-url-pattern-translator.pl
+ if use tools; then
+ dobin tools/{privoxy-log-parser.pl,privoxy-regression-test.pl}
+ newbin tools/uagen.pl privoxy-uagen.pl
+ fi
+}
+
+pkg_postinst() {
+ if use extended-host-patterns; then
+ ewarn
+ ewarn "You enabled extended-host-patterns, now you *must* convert all action files in"
+ ewarn "PCRE-compatible format, or privoxy will fail to start. Helper tool"
+ ewarn "privoxy-url-pattern-translator.pl is available."
+ ewarn
+ fi
+}