summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Laurantin <olivier.laurantin@laposte.net>2020-04-17 07:26:25 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-04-17 10:35:56 +0300
commitef8b23ec7f98e6f8e4921dca44914bf5ec33b40f (patch)
treee46a716ffb96f91e7f4442f4bb25a913b115a49a /net-wireless/blueberry
parentnet-ftp/uftpd: drop old version (diff)
downloadgentoo-ef8b23ec7f98e6f8e4921dca44914bf5ec33b40f.tar.gz
gentoo-ef8b23ec7f98e6f8e4921dca44914bf5ec33b40f.tar.bz2
gentoo-ef8b23ec7f98e6f8e4921dca44914bf5ec33b40f.zip
net-wireless/blueberry: version bump
Update to the latest upstream version Closes: https://bugs.gentoo.org/717554 Signed-off-by: Olivier Laurantin <olivier.laurantin@laposte.net> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-wireless/blueberry')
-rw-r--r--net-wireless/blueberry/Manifest1
-rw-r--r--net-wireless/blueberry/blueberry-1.3.6.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/net-wireless/blueberry/Manifest b/net-wireless/blueberry/Manifest
index 74c08291a2ba..98f421841a41 100644
--- a/net-wireless/blueberry/Manifest
+++ b/net-wireless/blueberry/Manifest
@@ -1 +1,2 @@
DIST blueberry-1.3.4.tar.gz 1410366 BLAKE2B a684c30b7457c4df8cc1f5449891cb43d0bc314692ad1d135377c861c669b0f4f8185396f39295268821ac6403dfd035201756dea4974f31066da766e36b559c SHA512 d5ca457ace0d46aab425b6821e690a94375de1222e90d0223afa97de5ce16f77089ba84b1b47a90e6494f34d3bd6824dbd6d2ff1e41e0b9be1d7bc9611abd6db
+DIST blueberry-1.3.6.tar.gz 1411444 BLAKE2B b86db1f470f44ad8c0b8efa173f0d161112a6ddd734b9cb9545ece78762299ed244855d9d89d7f9090f876ca6da8ac0b8cd8e2b4627ea94588bfe52b466b43d5 SHA512 6ff6a9b3dc5ff46fc383f55a1c6f519447ca707fac2a31436a1a8d0955de50dd5bfc9977879fcd3191ef1a4e508629ccb0d790a2dce3fd3ff54be098218bbd8d
diff --git a/net-wireless/blueberry/blueberry-1.3.6.ebuild b/net-wireless/blueberry/blueberry-1.3.6.ebuild
new file mode 100644
index 000000000000..b5c019bbd2ac
--- /dev/null
+++ b/net-wireless/blueberry/blueberry-1.3.6.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit eutils gnome2-utils python-single-r1 xdg-utils
+
+DESCRIPTION="A Bluetooth configuration tool"
+HOMEPAGE="https://github.com/linuxmint/blueberry"
+SRC_URI="https://github.com/linuxmint/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/dbus-python[${PYTHON_MULTI_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_MULTI_USEDEP}]
+ dev-python/setproctitle[${PYTHON_MULTI_USEDEP}]
+ dev-python/xapp[${PYTHON_MULTI_USEDEP}]
+ ')
+ >=net-wireless/gnome-bluetooth-3.14[introspection]
+ net-wireless/bluez[obex]
+ net-wireless/bluez-tools
+ || (
+ >=sys-apps/util-linux-2.31_rc1
+ net-wireless/rfkill
+ )
+ x11-libs/libnotify[introspection]
+ x11-misc/wmctrl"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ python_fix_shebang usr/lib
+}
+
+src_install() {
+ doins -r etc
+ exeinto /usr/bin
+ doexe usr/bin/*
+ exeinto /usr/lib/blueberry
+ doexe usr/lib/blueberry/*
+ insinto /usr
+ doins -r usr/share
+}
+
+pkg_preinst() {
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+ xdg_icon_cache_update
+}