summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2018-12-06 22:50:54 +0200
committerMart Raudsepp <leio@gentoo.org>2018-12-06 22:51:18 +0200
commit2c672c1a3e20bf4adfe741119ed43a4517ebe527 (patch)
tree73e03efc51612f8d00047f30f70d73831bd6f012 /net-wireless/gnome-bluetooth
parentnet-libs/glib-networking: bump to 2.54.1 (diff)
downloadgentoo-2c672c1a3e20bf4adfe741119ed43a4517ebe527.tar.gz
gentoo-2c672c1a3e20bf4adfe741119ed43a4517ebe527.tar.bz2
gentoo-2c672c1a3e20bf4adfe741119ed43a4517ebe527.zip
net-wireless/gnome-bluetooth: bump to 3.28.2
Signed-off-by: Mart Raudsepp <leio@gentoo.org> Package-Manager: Portage-2.3.52, Repoman-2.3.11
Diffstat (limited to 'net-wireless/gnome-bluetooth')
-rw-r--r--net-wireless/gnome-bluetooth/Manifest1
-rw-r--r--net-wireless/gnome-bluetooth/gnome-bluetooth-3.28.2.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/net-wireless/gnome-bluetooth/Manifest b/net-wireless/gnome-bluetooth/Manifest
index 08a042126285..fa6ba8bc1a50 100644
--- a/net-wireless/gnome-bluetooth/Manifest
+++ b/net-wireless/gnome-bluetooth/Manifest
@@ -1 +1,2 @@
DIST gnome-bluetooth-3.20.1.tar.xz 615880 BLAKE2B 4b578bc7d1bf1d700f57117202e5f6461e1ace972f6922425a012eb1bcf96c7e511222a1dbd344469e0db96142d4da99face54e07d7359e28e20234d7766a70c SHA512 945dde99c6531e369702dea22e60f5b05759d751b16b091fc67c256e949cee8153f60ac7ad616c086366a0141b263b068fad28bab4b50b84356d59b4e464d88a
+DIST gnome-bluetooth-3.28.2.tar.xz 349456 BLAKE2B 24a8adbbd37a6a7338a10bb84fd113c3a65bb9c5ef277c9df082f10f52b9d9dc2bc3ff6182993fd85fb5f5f8269a965f0aba864f73ed8595a700a51e59242fc1 SHA512 03f66f8c5c195b10cf2c13dc93191b9f2f79adae099ddb8037ef1277731f37b8f0a42b603e8aacbe2fb108be6abf7a77a823d86d5fac62a42a53e3498d53d87e
diff --git a/net-wireless/gnome-bluetooth/gnome-bluetooth-3.28.2.ebuild b/net-wireless/gnome-bluetooth/gnome-bluetooth-3.28.2.ebuild
new file mode 100644
index 000000000000..3d98bbae7f45
--- /dev/null
+++ b/net-wireless/gnome-bluetooth/gnome-bluetooth-3.28.2.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome.org gnome2-utils meson udev user xdg
+
+DESCRIPTION="Bluetooth graphical utilities integrated with GNOME"
+HOMEPAGE="https://wiki.gnome.org/Projects/GnomeBluetooth"
+
+LICENSE="GPL-2+ LGPL-2.1+ FDL-1.1+"
+SLOT="2/13" # subslot = libgnome-bluetooth soname version
+IUSE="gtk-doc +introspection"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+
+COMMON_DEPEND="
+ >=x11-libs/gtk+-3.12:3[introspection?]
+ media-libs/libcanberra[gtk3]
+ >=x11-libs/libnotify-0.7.0
+ virtual/libudev
+ >=dev-libs/glib-2.38:2
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5:= )
+"
+RDEPEND="${COMMON_DEPEND}
+ virtual/udev
+ >=net-wireless/bluez-5
+"
+DEPEND="${COMMON_DEPEND}
+ !net-wireless/bluez-gnome
+ dev-libs/libxml2:2
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ gtk-doc? ( >=dev-util/gtk-doc-1.9 )
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ enewgroup plugdev
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dicon_update=false
+ $(meson_use gtk-doc gtk_doc)
+ $(meson_use introspection)
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ udev_dorules "${FILESDIR}"/61-${PN}.rules
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_icon_cache_update
+ if ! has_version sys-auth/consolekit[acl] && ! has_version sys-apps/systemd[acl] ; then
+ elog "Don't forget to add yourself to the plugdev group "
+ elog "if you want to be able to control bluetooth transmitter."
+ fi
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_icon_cache_update
+}