summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZero_Chaos <zerochaos@gentoo.org>2015-10-12 18:27:28 -0400
committerZero_Chaos <zerochaos@gentoo.org>2015-10-12 18:28:01 -0400
commit4ee823569a6e626c666eda1e74ec967a28c4ca3a (patch)
treef46a613bd6957b18d774f98fd61ce4c0da5bbc21 /net-wireless/ubertooth
parentwww-apps/postfixadmin: bup, has sec fixes too (diff)
downloadgentoo-4ee823569a6e626c666eda1e74ec967a28c4ca3a.tar.gz
gentoo-4ee823569a6e626c666eda1e74ec967a28c4ca3a.tar.bz2
gentoo-4ee823569a6e626c666eda1e74ec967a28c4ca3a.zip
net-wireless/ubertooth net-wireless/kismet-ubertooth net-libs/libbtbb: version bump
Diffstat (limited to 'net-wireless/ubertooth')
-rw-r--r--net-wireless/ubertooth/Manifest1
-rw-r--r--net-wireless/ubertooth/ubertooth-2015.10.1.ebuild103
-rw-r--r--net-wireless/ubertooth/ubertooth-9999.ebuild3
3 files changed, 106 insertions, 1 deletions
diff --git a/net-wireless/ubertooth/Manifest b/net-wireless/ubertooth/Manifest
index 0c78e62c2b3c..40da1f62471c 100644
--- a/net-wireless/ubertooth/Manifest
+++ b/net-wireless/ubertooth/Manifest
@@ -1,2 +1,3 @@
DIST ubertooth-2015-09-R2.tar.xz 1706712 SHA256 f2088c8c0e754df47dd8dbf604d5822bf5894b91e4505276c6f9e26b6a23b56d SHA512 240f6d682fe0addc05bb8ccf7eec931534449adfa9c1369b484aeac73d9bcaf75c211aeede21c6c219e363773ce3d63e4aa0ee6b662acc83409587bd7ac7e4da WHIRLPOOL 9fba78d1740efd342f3892ffc3cf914d1919ef1c7d282786a64afb72d6ed306dec3600363e3f85f2f70d9ccfba6b62f826a72942cb7c9316d151dd2718f79b09
+DIST ubertooth-2015-10-R1.tar.xz 1716840 SHA256 bc37e7978d137a64d918d7c8f1e7ca9cff093f9921d805e9809b12e5ab12ae35 SHA512 ad7229c9509db4b4230ec28d1c16200f0780dd7ce55224528ced6d8969f342a79b7317b69e7b9e49d03e93f973203801f4f703dd80dc115400366b0984c965b1 WHIRLPOOL 5f46bdc8746481d68fd5c8e3ce04aadbcc1bc704c95b1b5a3d389376704a2a3e702faf819c749f98cb737578e9ccfa3ac01887081bceeceed2e4804493b2c2a8
DIST ubertooth_one_rx_only.dfu 32060 SHA256 fefc034ff19fa8b4b307d77c875bfeaa639e2aa0ecf8b8337e6424618480b1b5 SHA512 daeaeae90cb2aa591db2787466cbdc7365ce4e74ce5f7af4f61c9c1a22af93e846ea9230acca64f88a85a959d0db447b19da4dc4d213601db8dd1ad3d9978fa7 WHIRLPOOL 3069bf540c87d317e4f612b25ef4af10c3a9197ec9ead69082021442e0cc70d4b381488ba4bd509f75535a43f8f7b5fcebae313b96623513de846edb51cf63a0
diff --git a/net-wireless/ubertooth/ubertooth-2015.10.1.ebuild b/net-wireless/ubertooth/ubertooth-2015.10.1.ebuild
new file mode 100644
index 000000000000..c35791d555cb
--- /dev/null
+++ b/net-wireless/ubertooth/ubertooth-2015.10.1.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_OPTIONAL=1
+
+inherit multilib distutils-r1 cmake-utils udev
+
+HOMEPAGE="http://ubertooth.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+bluez +specan +pcap +ubertooth1-firmware +udev"
+REQUIRED_USE=" specan? ( ${PYTHON_REQUIRED_USE} )"
+DEPEND="bluez? ( net-wireless/bluez:= )
+ >=net-libs/libbtbb-${PV}:=
+ pcap? ( net-libs/libbtbb[pcap] )
+ specan? ( ${PYTHON_DEPS} )
+ virtual/libusb:1="
+RDEPEND="${DEPEND}
+ specan? ( >=dev-qt/qtgui-4.7.2:4
+ >=dev-python/pyside-1.0.2[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.3[${PYTHON_USEDEP}] )
+ udev? ( virtual/udev )"
+
+MY_PV=${PV/\./-}
+MY_PV=${MY_PV/./-R}
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/greatscottgadgets/ubertooth.git"
+ inherit git-r3
+ KEYWORDS=""
+ S="${WORKDIR}/${P}/host"
+else
+ S="${WORKDIR}/${PN}-${MY_PV}/host"
+ SRC_URI="https://github.com/greatscottgadgets/${PN}/releases/download/${MY_PV}/${PN}-${MY_PV}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+DESCRIPTION="An open source wireless development platform suitable for Bluetooth experimentation"
+
+#readd firmware building, but do it right
+#USE="-fortran -mudflap -nls -openmp -multilib" crossdev --without-headers --genv 'EXTRA_ECONF="--with-mode=thumb --with-cpu=cortex-m3 --with-float=soft"' -s4 -t arm-cortexm3-eabi
+
+src_prepare() {
+ cmake-utils_src_prepare
+ if use specan; then
+ pushd python/specan_ui || die
+ distutils-r1_src_prepare
+ popd
+ fi
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_enable bluez USE_BLUEZ)
+ $(cmake-utils_use pcap USE_PCAP)
+ $(cmake-utils_use_enable udev INSTALL_UDEV_RULES)
+ -DDISABLE_PYTHON=true
+ )
+ if use udev; then
+ mycmakeargs+=(
+ -DUDEV_RULES_GROUP=usb
+ -DUDEV_RULES_PATH="$(get_udevdir)/rules.d"
+ )
+ fi
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+
+ if use specan; then
+ pushd python/specan_ui || die
+ distutils-r1_src_compile
+ popd
+ fi
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ insinto /usr/share/${PN}
+ pushd "${WORKDIR}/${PN}-${MY_PV}" || die
+ if [[ ${PV} == "9999" ]] ; then
+ ewarn "Firmware isn't available for git releases, we assume you are already"
+ ewarn "on the latest and/or can build your own."
+ else
+ use ubertooth1-firmware && newins ubertooth-one-firmware-bin/bluetooth_rxtx.dfu ${PN}-one-${PV}-bluetooth_rxtx.dfu
+ use ubertooth1-firmware && newins ubertooth-one-firmware-bin/bluetooth_rx_only.dfu ${PN}-one-${PV}-bluetooth_rx_only.dfu
+ fi
+ popd
+
+ if use specan; then
+ pushd python/specan_ui || die
+ distutils-r1_src_install
+ popd
+ fi
+
+ elog "Everyone can read from the ubertooth, but to talk to it"
+ elog "your user needs to be in the usb group."
+}
diff --git a/net-wireless/ubertooth/ubertooth-9999.ebuild b/net-wireless/ubertooth/ubertooth-9999.ebuild
index ae358ea08dad..c35791d555cb 100644
--- a/net-wireless/ubertooth/ubertooth-9999.ebuild
+++ b/net-wireless/ubertooth/ubertooth-9999.ebuild
@@ -87,7 +87,8 @@ src_install() {
ewarn "Firmware isn't available for git releases, we assume you are already"
ewarn "on the latest and/or can build your own."
else
- use ubertooth1-firmware && newins ubertooth-one-firmware-bin/bluetooth_rxtx.dfu ${PN}-one-${PV}-bluetooth_rxtx.dfu
+ use ubertooth1-firmware && newins ubertooth-one-firmware-bin/bluetooth_rxtx.dfu ${PN}-one-${PV}-bluetooth_rxtx.dfu
+ use ubertooth1-firmware && newins ubertooth-one-firmware-bin/bluetooth_rx_only.dfu ${PN}-one-${PV}-bluetooth_rx_only.dfu
fi
popd