summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-astronomy/sofa_c
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-astronomy/sofa_c')
-rw-r--r--sci-astronomy/sofa_c/Manifest1
-rw-r--r--sci-astronomy/sofa_c/files/sofa_c-makefile.patch113
-rw-r--r--sci-astronomy/sofa_c/metadata.xml23
-rw-r--r--sci-astronomy/sofa_c/sofa_c-20120301a.ebuild38
4 files changed, 175 insertions, 0 deletions
diff --git a/sci-astronomy/sofa_c/Manifest b/sci-astronomy/sofa_c/Manifest
new file mode 100644
index 000000000000..cead38fc4fe0
--- /dev/null
+++ b/sci-astronomy/sofa_c/Manifest
@@ -0,0 +1 @@
+DIST sofa_c-20120301_a.tar.gz 1267551 SHA256 3534538b4abda067ef07f1aaef869f3b72ddc7f246447558b708d2968e63e66f SHA512 00da8e834e790922200c25b55cba3b48e49770cbada2271e4b7720f5170a422c9a47e6ebd1c51787256e88aaa656c347f21add14fbc353a9346d395ea3eda2c2 WHIRLPOOL d4f13d08b6ff1f67c808ba09858cd0f77664031ea466b71fc65f48f09bd216cd384db7660b574385d1c65ddcbdd5f894a2631335be557ffb29f1b8703d517a46
diff --git a/sci-astronomy/sofa_c/files/sofa_c-makefile.patch b/sci-astronomy/sofa_c/files/sofa_c-makefile.patch
new file mode 100644
index 000000000000..b992d401d3fa
--- /dev/null
+++ b/sci-astronomy/sofa_c/files/sofa_c-makefile.patch
@@ -0,0 +1,113 @@
+--- makefile.orig 2013-05-22 20:51:58.398491342 +0000
++++ makefile 2013-05-22 21:05:52.055466710 +0000
+@@ -49,7 +49,7 @@
+
+ # Specify the installation home directory.
+
+-INSTALL_DIR = $(HOME)
++INSTALL_DIR = $(DESTDIR)/usr
+
+ # Specify the installation directory for the library.
+
+@@ -63,9 +63,10 @@
+ # of your preferred C compiler (CCOMPC) and compilation flags (CFLAGF
+ # for functions, CFLAGX for executables) here.
+
+-CCOMPC = gcc
+-CFLAGF = -c -pedantic -Wall -W -O
+-CFLAGX = -pedantic -Wall -W -O
++CCOMPC = $(CC)
++CFLAGF = -c -pedantic -Wall -W -fPIC $(CFLAGS)
++CFLAGX = -pedantic -Wall -W $(CFLAGS)
++
+
+ #----YOU SHOULDN'T HAVE TO MODIFY ANYTHING BELOW THIS LINE---------
+
+@@ -80,6 +81,12 @@
+ SOFA_LIB_NAME = libsofa_c.a
+ SOFA_LIB = $(SOFA_LIB_DIR)$(SOFA_LIB_NAME)
+
++
++# Name the SOFA/C library in its source and target locations.
++
++SOFA_SHLIB_NAME = libsofa_c.so
++SOFA_SHLIB = $(SOFA_LIB_DIR)$(SOFA_SHLIB_NAME)
++
+ # Name the SOFA/C testbed in its source and target locations.
+
+ SOFA_TEST_NAME = t_sofa_c.c
+@@ -88,7 +95,7 @@
+ # Name the SOFA/C includes in their source and target locations.
+
+ SOFA_INC_NAMES = sofa.h sofam.h
+-SOFA_INC = $(SOFA_INC_DIR)sofa.h $(SOFA_INC_DIR)sofam.h
++SOFA_INC = $(SOFA_INC_NAMES:%=$(SOFA_INC_DIR)%)
+
+ # The list of SOFA/C library object files.
+ SOFA_OBS = iauA2af.o \
+@@ -285,29 +292,32 @@
+ #-----------------------------------------------------------------------
+
+ # Build (but do not install) the library.
+-all : $(SOFA_LIB_NAME)
++all : $(SOFA_SHLIB_NAME)
+ -@ echo ""
+ -@ echo "*** Now type 'make test'" \
+ " to install the library and run tests ***"
+ -@ echo ""
+
+ # Install the library and header files.
+-install $(SOFA_LIB) : $(INSTALL_DIRS) $(SOFA_LIB_NAME) $(SOFA_INC)
+- cp $(SOFA_LIB_NAME) $(SOFA_LIB_DIR)
++install: $(INSTALL_DIRS) $(SOFA_SHLIB_NAME) $(SOFA_INC)
++ cp $(SOFA_SHLIB_NAME).0.0 $(SOFA_LIB_DIR)
++ ln -s $(SOFA_SHLIB_NAME).0.0 $(SOFA_SHLIB).0
++ ln -s $(SOFA_SHLIB_NAME).0 $(SOFA_SHLIB)
+
+ # Deinstall the library and header files.
+ deinstall:
+- rm -f $(SOFA_LIB) $(SOFA_INC)
++ rm -f $(SOFA_LIB) $(SOFA_SHLIB)* $(SOFA_INC)
+
+ # Test the build.
+ check: $(SOFA_TEST_NAME) $(SOFA_INC_NAMES) $(SOFA_LIB_NAME)
+- $(CCOMPC) $(CFLAGX) $(SOFA_TEST_NAME) $(SOFA_LIB_NAME) \
++ $(CCOMPC) $(CFLAGX) $(SOFA_TEST_NAME) $(SOFA_SHLIB_NAME).0.0 \
+ -lm -o $(SOFA_TEST)
+- ./$(SOFA_TEST)
+- rm -f $(SOFA_TEST)
++ ln -s $(SOFA_SHLIB_NAME).0.0 $(SOFA_SHLIB_NAME).0
++ LD_LIBRARY_PATH="$(LD_LIBRARY_PATH):." ./$(SOFA_TEST)
++ rm -f $(SOFA_TEST) $(SOFA_SHLIB_NAME).0
+
+ # Test the installed library.
+-installcheck test: $(SOFA_TEST_NAME) $(SOFA_INC) $(SOFA_LIB)
++installcheck: $(SOFA_TEST_NAME) $(SOFA_INC) $(SOFA_LIB)
+ $(CCOMPC) $(CFLAGX) $(SOFA_TEST_NAME) -I$(SOFA_INC_DIR) \
+ -L$(SOFA_LIB_DIR) -lsofa_c -lm -o $(SOFA_TEST)
+ ./$(SOFA_TEST)
+@@ -315,11 +325,11 @@
+
+ # Local clean up.
+ clean realclean:
+- rm -f $(SOFA_OBS) $(SOFA_LIB_NAME)
++ rm -f $(SOFA_OBS) $(SOFA_LIB_NAME) $(SOFA_SHLIB_NAME)
+
+ # Clean up and deinstall.
+ distclean:
+- rm -f $(SOFA_OBS) $(SOFA_LIB_NAME) $(SOFA_INC) $(SOFA_LIB)
++ rm -f $(SOFA_OBS) $(SOFA_LIB_NAME) $(SOFA_INC) $(SOFA_LIB) $(SOFA_SHLIB_NAME)
+
+ # Create the installation directories if not already present.
+ $(INSTALL_DIRS):
+@@ -329,6 +339,10 @@
+ $(SOFA_LIB_NAME): $(SOFA_OBS)
+ ar ru $(SOFA_LIB_NAME) $?
+
++$(SOFA_SHLIB_NAME): $(SOFA_OBS)
++ $(CC) $(LDFLAGS) -shared -Wl,-soname,$(SOFA_SHLIB_NAME).0 -lm -o $(SOFA_SHLIB_NAME).0.0 $?
++
++
+ # Install the header files.
+ $(SOFA_INC) : $(INSTALL_DIRS) $(SOFA_INC_NAMES)
+ cp $(SOFA_INC_NAMES) $(SOFA_INC_DIR)
diff --git a/sci-astronomy/sofa_c/metadata.xml b/sci-astronomy/sofa_c/metadata.xml
new file mode 100644
index 000000000000..17260472bb98
--- /dev/null
+++ b/sci-astronomy/sofa_c/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-astronomy</herd>
+<longdescription lang="en">
+ This is a suite of vector/matrix routines and various utilities that
+ underpin the astronomy algorithms, which include routines for the
+ following:
+ * Calendars
+ * Time Scales
+ * Earth rotation and sidereal time
+ * Ephemerides (medium precision)
+ * Geocentric/geodetic transformations
+ * Precession, nutation, polar motion
+ * Star space motion
+ * Star catalogue conversion
+ This is the ANSI C version of the library.
+ The International Astronomical Union's SOFA service has the task of
+ establishing and maintaining an accessible and authoritative set of
+ algorithms and procedures that implement standard models used in
+ fundamental astronomy.
+</longdescription>
+</pkgmetadata>
diff --git a/sci-astronomy/sofa_c/sofa_c-20120301a.ebuild b/sci-astronomy/sofa_c/sofa_c-20120301a.ebuild
new file mode 100644
index 000000000000..55d0acfd5227
--- /dev/null
+++ b/sci-astronomy/sofa_c/sofa_c-20120301a.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils flag-o-matic multilib
+
+YYYY=${PV:0:4}
+MMDD=${PV:4:4}
+MYPV=${YYYY}${MMDD}_${PV:8:1}
+
+DESCRIPTION="Library for algorithms for models in fundamental astronomy"
+HOMEPAGE=" http://www.iausofa.org/current_C.html"
+SRC_URI="http://www.iausofa.org/${YYYY}_${MMDD}_C/${PN}-${MYPV}.tar.gz"
+
+LICENSE="SOFA"
+SLOT=0
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+RDEPEND=""
+DEPEND=""
+
+S="${WORKDIR}/sofa/${MYPV}/c/src"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-makefile.patch
+ sed -i -e "s:/lib:/$(get_libdir):" makefile || die
+ replace-flags -O? -O1
+}
+
+src_install() {
+ emake DESTDIR="${ED}" -j1 install
+ cd ..
+ dodoc 00READ.ME
+ use doc && dodoc doc/*.lis doc/*.pdf
+}