summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-biology/gatk
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-biology/gatk')
-rw-r--r--sci-biology/gatk/Manifest1
-rw-r--r--sci-biology/gatk/gatk-2.4.ebuild39
-rw-r--r--sci-biology/gatk/gatk-9999.ebuild41
-rw-r--r--sci-biology/gatk/metadata.xml5
4 files changed, 86 insertions, 0 deletions
diff --git a/sci-biology/gatk/Manifest b/sci-biology/gatk/Manifest
new file mode 100644
index 000000000000..6cd4e325d33f
--- /dev/null
+++ b/sci-biology/gatk/Manifest
@@ -0,0 +1 @@
+DIST gatk-2.4.tar.gz 9106774 SHA256 db0be90ef5182866a1f936742fba20b317ce582556e19acb69de2a8894f7383a SHA512 9050fc2024d0b3c9a6b5617787831c0496276bcd7318a872f6c1128c31fc31c6f59429a1b189e5c2cc740909b42d846b5e041f8626b03af3a80442294db34ace WHIRLPOOL 1fa7a73f317db82c313ea112ffaa6466c2b17384f1ad8d06c74a3f4764dfd822f036cc2dc99890c157fc2c32ce299a4a7d0c73cafc72dd7ad955d75053745b2c
diff --git a/sci-biology/gatk/gatk-2.4.ebuild b/sci-biology/gatk/gatk-2.4.ebuild
new file mode 100644
index 000000000000..53bc0dc1b50b
--- /dev/null
+++ b/sci-biology/gatk/gatk-2.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+EANT_BUILD_TARGET="dist"
+EANT_NEEDS_TOOLS="true"
+JAVA_ANT_REWRITE_CLASSPATH="true"
+
+inherit java-pkg-2 java-ant-2 vcs-snapshot
+
+DESCRIPTION="The Genome Analysis Toolkit"
+HOMEPAGE="http://www.broadinstitute.org/gsa/wiki/index.php/The_Genome_Analysis_Toolkit"
+SRC_URI="https://github.com/broadgsa/gatk/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64"
+
+COMMON_DEPS=""
+DEPEND="
+ >=virtual/jdk-1.6
+ ${COMMON_DEPS}"
+RDEPEND="
+ >=virtual/jre-1.6
+ ${COMMON_DEPS}"
+
+src_prepare() {
+ sed -i '/property name="ivy.home"/ s|${user.home}|'${WORKDIR}'|' build.xml || die
+ java-pkg-2_src_prepare
+}
+
+src_install() {
+ java-pkg_dojar dist/*.jar
+ java-pkg_dolauncher GenomeAnalysisTK --jar GenomeAnalysisTK.jar
+ java-pkg_dolauncher AnalyzeCovariates --jar AnalyzeCovariates.jar
+}
diff --git a/sci-biology/gatk/gatk-9999.ebuild b/sci-biology/gatk/gatk-9999.ebuild
new file mode 100644
index 000000000000..9a705487d658
--- /dev/null
+++ b/sci-biology/gatk/gatk-9999.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+EANT_BUILD_TARGET="dist"
+EANT_NEEDS_TOOLS="true"
+JAVA_ANT_REWRITE_CLASSPATH="true"
+
+inherit git-2 java-pkg-2 java-ant-2
+
+DESCRIPTION="The Genome Analysis Toolkit"
+HOMEPAGE="http://www.broadinstitute.org/gsa/wiki/index.php/The_Genome_Analysis_Toolkit"
+SRC_URI=""
+EGIT_REPO_URI="https://github.com/broadgsa/gatk.git"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+KEYWORDS=""
+
+COMMON_DEPS=""
+DEPEND="
+ >=virtual/jdk-1.6
+ dev-vcs/git
+ ${COMMON_DEPS}"
+RDEPEND="
+ >=virtual/jre-1.6
+ ${COMMON_DEPS}"
+
+src_prepare() {
+ sed -i '/property name="ivy.home"/ s|${user.home}|'${WORKDIR}'|' build.xml || die
+ java-pkg-2_src_prepare
+}
+
+src_install() {
+ java-pkg_dojar dist/*.jar
+ java-pkg_dolauncher GenomeAnalysisTK --jar GenomeAnalysisTK.jar
+ java-pkg_dolauncher AnalyzeCovariates --jar AnalyzeCovariates.jar
+}
diff --git a/sci-biology/gatk/metadata.xml b/sci-biology/gatk/metadata.xml
new file mode 100644
index 000000000000..f17a827e3101
--- /dev/null
+++ b/sci-biology/gatk/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-biology</herd>
+</pkgmetadata>