summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-biology/prosite
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-biology/prosite')
-rw-r--r--sci-biology/prosite/Manifest4
-rw-r--r--sci-biology/prosite/metadata.xml15
-rw-r--r--sci-biology/prosite/prosite-19.36.ebuild42
-rw-r--r--sci-biology/prosite/prosite-20.36.ebuild41
-rw-r--r--sci-biology/prosite/prosite-20.52.ebuild41
-rw-r--r--sci-biology/prosite/prosite-20.72.ebuild41
6 files changed, 184 insertions, 0 deletions
diff --git a/sci-biology/prosite/Manifest b/sci-biology/prosite/Manifest
new file mode 100644
index 000000000000..abbafda0a493
--- /dev/null
+++ b/sci-biology/prosite/Manifest
@@ -0,0 +1,4 @@
+DIST prosite-19.36.tar.bz2 4462981 RMD160 4d80651193b4c34bfdf42b770d4ec07927666057 SHA1 52acc49f0452b344a20b52983cbd896b6dd3b79b SHA256 6f923d4794f50c8e68d030d01cb6675579007cc04c197d811886dfb4ae853607
+DIST prosite-20.36.tar.bz2 5953220 RMD160 51f2da1efc886616e78ebced1a32c3a916bdef8f SHA1 328518c8e936d8960846bdefa8164a6f78a73503 SHA256 05593ff424d4145e19a7f394dab5a64fe0c5c6a640091fe03451f52bd31bfd25
+DIST prosite-20.52.tar.bz2 7038156 RMD160 506a64a15ea1145eadb8138b192718436282a2c1 SHA1 39abf5053c21f3d03ce0bb0bfc1fb3fb82284fb6 SHA256 89e5fc11e2ed18b1f16cc78e5271cccf6a5ea28a64fdcd7e99a770dfebb1968d
+DIST prosite-20.72.tar.bz2 7521700 RMD160 5f48b403a05caeebf4136c2a626fa7a31e413b27 SHA1 164bc5ffc41aa2eb7e0a8588af577b84eca82040 SHA256 93b8664adecce63b14a96b6b9fbd970bcc2852a83413fd9b873df84dcfe07d12
diff --git a/sci-biology/prosite/metadata.xml b/sci-biology/prosite/metadata.xml
new file mode 100644
index 000000000000..075d4b7bcf10
--- /dev/null
+++ b/sci-biology/prosite/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-biology</herd>
+ <longdescription>
+ A protein families and domains database maintained at the Swiss
+ Institude for Bioinformatics. It consists of biologically significant
+ sites, patterns and profiles that help to reliably identify to which
+ known protein family (if any) a new sequence belongs. PROSITE currently
+ contains patterns and profiles specific for more than a thousand
+ protein families or domains. Each of these signatures comes with
+ documentation providing background information on the structure and
+ function of these proteins.
+ </longdescription>
+</pkgmetadata>
diff --git a/sci-biology/prosite/prosite-19.36.ebuild b/sci-biology/prosite/prosite-19.36.ebuild
new file mode 100644
index 000000000000..552c9193733f
--- /dev/null
+++ b/sci-biology/prosite/prosite-19.36.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="A protein families and domains database"
+LICENSE="swiss-prot"
+HOMEPAGE="http://ca.expasy.org/prosite"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+SLOT="0"
+# Minimal build keeps only the indexed files (if applicable) and the
+# documentation. The non-indexed database is not installed.
+IUSE="emboss minimal"
+KEYWORDS="amd64 ppc x86"
+
+DEPEND="emboss? ( sci-biology/emboss )"
+
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ if use emboss; then
+ mkdir PROSITE
+ echo
+ einfo "Indexing PROSITE for usage with EMBOSS."
+ EMBOSS_DATA="." prosextract -auto -prositedir "${S}" || die \
+ "Indexing PROSITE failed."
+ echo
+ fi
+}
+
+src_install() {
+ if ! use minimal; then
+ insinto /usr/share/${PN}
+ doins ${PN}.{doc,dat,lis} || die "Installing raw database failed."
+ fi
+ dodoc *.txt || die "Documentation installation failed."
+ dohtml *.htm || die "HTML documentation installation failed."
+ if use emboss; then
+ insinto /usr/share/EMBOSS/data/PROSITE
+ doins PROSITE/* || die "Installing EMBOSS data files failed."
+ fi
+}
diff --git a/sci-biology/prosite/prosite-20.36.ebuild b/sci-biology/prosite/prosite-20.36.ebuild
new file mode 100644
index 000000000000..9bb65805bd27
--- /dev/null
+++ b/sci-biology/prosite/prosite-20.36.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="A protein families and domains database"
+HOMEPAGE="http://ca.expasy.org/prosite"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="swiss-prot"
+# Minimal build keeps only the indexed files (if applicable) and the
+# documentation. The non-indexed database is not installed.
+IUSE="emboss minimal"
+KEYWORDS="amd64 ~ppc x86"
+
+DEPEND="emboss? ( sci-biology/emboss )"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ if use emboss; then
+ mkdir PROSITE
+ echo
+ einfo "Indexing PROSITE for usage with EMBOSS."
+ EMBOSS_DATA="." prosextract -auto -prositedir "${S}" || die \
+ "Indexing PROSITE failed."
+ echo
+ fi
+}
+
+src_install() {
+ if ! use minimal; then
+ insinto /usr/share/${PN}
+ doins *.{doc,dat} || die "Installing raw database failed."
+ fi
+ insinto /usr/share/doc/${PF}
+ doins *.pdf || die "PDF documentation installation failed."
+ if use emboss; then
+ insinto /usr/share/EMBOSS/data/PROSITE
+ doins PROSITE/* || die "Installing EMBOSS data files failed."
+ fi
+}
diff --git a/sci-biology/prosite/prosite-20.52.ebuild b/sci-biology/prosite/prosite-20.52.ebuild
new file mode 100644
index 000000000000..69a997ed0987
--- /dev/null
+++ b/sci-biology/prosite/prosite-20.52.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="A protein families and domains database"
+HOMEPAGE="http://ca.expasy.org/prosite"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="swiss-prot"
+# Minimal build keeps only the indexed files (if applicable) and the
+# documentation. The non-indexed database is not installed.
+IUSE="emboss minimal"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
+
+DEPEND="emboss? ( sci-biology/emboss )"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ if use emboss; then
+ mkdir PROSITE
+ echo
+ einfo "Indexing PROSITE for usage with EMBOSS."
+ EMBOSS_DATA="." prosextract -auto -prositedir "${S}" || die \
+ "Indexing PROSITE failed."
+ echo
+ fi
+}
+
+src_install() {
+ if ! use minimal; then
+ insinto /usr/share/${PN}
+ doins *.{doc,dat} || die "Installing raw database failed."
+ fi
+ insinto /usr/share/doc/${PF}
+ doins *.pdf || die "PDF documentation installation failed."
+ if use emboss; then
+ insinto /usr/share/EMBOSS/data/PROSITE
+ doins PROSITE/* || die "Installing EMBOSS data files failed."
+ fi
+}
diff --git a/sci-biology/prosite/prosite-20.72.ebuild b/sci-biology/prosite/prosite-20.72.ebuild
new file mode 100644
index 000000000000..799a5a432c14
--- /dev/null
+++ b/sci-biology/prosite/prosite-20.72.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="A protein families and domains database"
+HOMEPAGE="http://ca.expasy.org/prosite"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="swiss-prot"
+# Minimal build keeps only the indexed files (if applicable) and the
+# documentation. The non-indexed database is not installed.
+IUSE="emboss minimal"
+KEYWORDS="amd64 ~ppc x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
+
+DEPEND="emboss? ( sci-biology/emboss )"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ if use emboss; then
+ mkdir PROSITE
+ echo
+ einfo "Indexing PROSITE for usage with EMBOSS."
+ EMBOSS_DATA="." prosextract -auto -prositedir "${S}" || die \
+ "Indexing PROSITE failed."
+ echo
+ fi
+}
+
+src_install() {
+ if ! use minimal; then
+ insinto /usr/share/${PN}
+ doins *.{doc,dat} || die "Installing raw database failed."
+ fi
+ insinto /usr/share/doc/${PF}
+ doins *.pdf || die "PDF documentation installation failed."
+ if use emboss; then
+ insinto /usr/share/EMBOSS/data/PROSITE
+ doins PROSITE/* || die "Installing EMBOSS data files failed."
+ fi
+}