summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-biology/transfac
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-biology/transfac')
-rw-r--r--sci-biology/transfac/Manifest1
-rw-r--r--sci-biology/transfac/metadata.xml13
-rw-r--r--sci-biology/transfac/transfac-3.2.ebuild41
3 files changed, 55 insertions, 0 deletions
diff --git a/sci-biology/transfac/Manifest b/sci-biology/transfac/Manifest
new file mode 100644
index 000000000000..d9522e5cccb5
--- /dev/null
+++ b/sci-biology/transfac/Manifest
@@ -0,0 +1 @@
+DIST transfac32.tar.Z 3346266 RMD160 892164634a80f388ba3c588823576ff0b5582338 SHA1 1f950c981364b03819463536c8d0195fe7351f02 SHA256 cf5c64e6f23037d73562d66f9dde56a767a8f31974a1c0906ec68edea3731a7f
diff --git a/sci-biology/transfac/metadata.xml b/sci-biology/transfac/metadata.xml
new file mode 100644
index 000000000000..d07df4fd4dbf
--- /dev/null
+++ b/sci-biology/transfac/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-biology</herd>
+ <longdescription>
+ TRANSFAC® is a database of eukaryotic transcription factors, of their
+ genomic binding sites and DNA-binding profiles. TRANSFAC 3.2 is an old
+ public version available at the European Bioinformatics Institute.
+ TRANSFAC® is currently maintained by the BIOBASE company. Altough they
+ offer public access to a more recent version of the database, they
+ offer no free downloadable version.
+ </longdescription>
+</pkgmetadata>
diff --git a/sci-biology/transfac/transfac-3.2.ebuild b/sci-biology/transfac/transfac-3.2.ebuild
new file mode 100644
index 000000000000..e2cdd68565f2
--- /dev/null
+++ b/sci-biology/transfac/transfac-3.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="A database of eucaryotic transcription factors"
+HOMEPAGE="http://www.gene-regulation.com/pub/databases.html"
+SRC_URI="ftp://ftp.ebi.ac.uk/pub/databases/${PN}/${PN}32.tar.Z"
+LICENSE="public-domain"
+
+SLOT="3"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris"
+IUSE="emboss minimal"
+# Minimal build keeps only the indexed files (if applicable) and the documentation.
+# The non-indexed database is not installed.
+
+DEPEND="emboss? ( sci-biology/emboss )"
+
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"
+
+src_compile() {
+ if use emboss; then
+ echo
+ einfo "Indexing TRANSFAC for usage with EMBOSS."
+ EMBOSS_DATA=. tfextract -auto -infile class.dat || die \
+ "Indexing TRANSFAC failed."
+ echo
+ fi
+}
+
+src_install() {
+ if ! use minimal; then
+ insinto /usr/share/${PN}-${SLOT}
+ doins *.dat || die
+ fi
+ if use emboss; then
+ insinto /usr/share/EMBOSS/data
+ doins tf* || die
+ fi
+}