summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-04-05 16:14:41 +0200
committerDavid Seifert <soap@gentoo.org>2021-04-05 16:14:41 +0200
commit17ca0e1b3b8cda81f6028b21303d8c64021c2947 (patch)
tree4503b8d05aa5725e20ed425c99193947a5884130 /sci-biology
parentsci-biology/raxml: Port to EAPI 7 (diff)
downloadgentoo-17ca0e1b3b8cda81f6028b21303d8c64021c2947.tar.gz
gentoo-17ca0e1b3b8cda81f6028b21303d8c64021c2947.tar.bz2
gentoo-17ca0e1b3b8cda81f6028b21303d8c64021c2947.zip
sci-biology/mothur: Port to EAPI 7
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/mothur/mothur-1.27.0-r1.ebuild35
1 files changed, 17 insertions, 18 deletions
diff --git a/sci-biology/mothur/mothur-1.27.0-r1.ebuild b/sci-biology/mothur/mothur-1.27.0-r1.ebuild
index 9e9bf2160310..12b628475aac 100644
--- a/sci-biology/mothur/mothur-1.27.0-r1.ebuild
+++ b/sci-biology/mothur/mothur-1.27.0-r1.ebuild
@@ -1,43 +1,42 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit eutils flag-o-matic fortran-2 toolchain-funcs
+inherit flag-o-matic fortran-2 toolchain-funcs
DESCRIPTION="A suite of algorithms for ecological bioinformatics"
HOMEPAGE="https://www.mothur.org/"
SRC_URI="https://www.mothur.org/w/images/c/cb/Mothur.${PV}.zip -> ${P}.zip"
+S="${WORKDIR}/${PN^}.source"
LICENSE="GPL-3"
SLOT="0"
-IUSE="mpi +readline"
KEYWORDS="amd64 x86"
+IUSE="mpi +readline"
RDEPEND="
sci-biology/uchime
mpi? ( virtual/mpi )"
-DEPEND="${RDEPEND}
- app-arch/unzip"
+DEPEND="${RDEPEND}"
+BDEPEND="app-arch/unzip"
-S=${WORKDIR}/Mothur.source
+PATCHES=(
+ "${FILESDIR}"/${P}-makefile.patch
+ "${FILESDIR}"/${P}-overflows.patch
+)
-pkg_setup() {
- fortran-2_pkg_setup
- use mpi && export CXX=mpicxx || export CXX=$(tc-getCXX)
+src_configure() {
+ use mpi && export CXX=mpicxx || tc-export CXX
use amd64 && append-cppflags -DBIT_VERSION
}
-src_prepare() {
- epatch \
- "${FILESDIR}"/${P}-makefile.patch \
- "${FILESDIR}"/${P}-overflows.patch
-}
-
src_compile() {
- emake USEMPI=$(usex mpi) USEREADLINE=$(usex readline)
+ emake \
+ USEMPI=$(usex mpi) \
+ USEREADLINE=$(usex readline)
}
src_install() {
- dobin ${PN}
+ dobin mothur
}