summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-12-31 21:26:22 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-12-31 22:13:46 +0100
commit23df63ca4ab84f0deee052ac6365c07e4eeff234 (patch)
tree1aa1063c6f44f75bd1dd3712deb0e87dbe928846 /sci-chemistry
parentdev-libs/handystats: Drop old (diff)
downloadgentoo-23df63ca4ab84f0deee052ac6365c07e4eeff234.tar.gz
gentoo-23df63ca4ab84f0deee052ac6365c07e4eeff234.tar.bz2
gentoo-23df63ca4ab84f0deee052ac6365c07e4eeff234.zip
sci-chemistry/apbs: EAPI-6 bump
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/apbs/apbs-1.4.1-r2.ebuild32
-rw-r--r--sci-chemistry/apbs/files/apbs-1.4.1-manip.patch18
-rw-r--r--sci-chemistry/apbs/files/apbs-1.4.1-python.patch38
3 files changed, 43 insertions, 45 deletions
diff --git a/sci-chemistry/apbs/apbs-1.4.1-r2.ebuild b/sci-chemistry/apbs/apbs-1.4.1-r2.ebuild
index 108e43bf904b..b3c4f192894b 100644
--- a/sci-chemistry/apbs/apbs-1.4.1-r2.ebuild
+++ b/sci-chemistry/apbs/apbs-1.4.1-r2.ebuild
@@ -1,19 +1,17 @@
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
PYTHON_COMPAT=( python2_7 )
DISTUTILS_SINGLE_IMPL=true
-
-inherit cmake-utils distutils-r1 flag-o-matic multilib toolchain-funcs
-
-GITHUB_REV="74fcb8676de69ed04ddab8976a8b05a6caaf4d65"
+COMMIT="74fcb8676de69ed04ddab8976a8b05a6caaf4d65"
+inherit cmake-utils distutils-r1 flag-o-matic toolchain-funcs
DESCRIPTION="Evaluation of electrostatic properties of nanoscale biomolecular systems"
HOMEPAGE="https://www.poissonboltzmann.org/apbs/"
#SRC_URI="mirror://sourceforge/${PN}/${P}-source.tar.gz"
-SRC_URI="https://github.com/Electrostatics/apbs-pdb2pqr/archive/${GITHUB_REV}.zip -> ${P}.zip"
+SRC_URI="https://github.com/Electrostatics/apbs-pdb2pqr/archive/${COMMIT}.zip -> ${P}.zip"
SLOT="0"
LICENSE="BSD"
@@ -44,7 +42,7 @@ DEPEND="${RDEPEND}
doc? ( app-doc/doxygen )
"
-S="${WORKDIR}"/${PN}-pdb2pqr-${GITHUB_REV}/${PN}
+S="${WORKDIR}"/${PN}-pdb2pqr-${COMMIT}/${PN}
PATCHES=(
"${FILESDIR}"/${P}-multilib.patch
@@ -71,24 +69,24 @@ src_prepare() {
src_configure() {
local mycmakeargs=(
-DCMAKE_SKIP_RPATH=ON
- -DTOOLS_PATH="${ED}"/usr
+ -DTOOLS_PATH="${ED%/}"/usr
-DSYS_LIBPATHS="${EPREFIX}"/usr/$(get_libdir)
-DLIBRARY_INSTALL_PATH=$(get_libdir)
-DFETK_PATH="${EPREFIX}"/usr/
-DBUILD_SHARED_LIBS=ON
-DENABLE_QUIT=OFF
- $(cmake-utils_use_build doc DOC)
- $(cmake-utils_use_build tools TOOLS)
+ -DBUILD_DOC=$(usex doc)
+ -DBUILD_TOOLS=$(usex tools)
-DENABLE_BEM=OFF
# ENABLE_BEM: Boundary element method using TABIPB
- $(cmake-utils_use_enable debug DEBUG)
- $(cmake-utils_use_enable debug VERBOSE_DEBUG)
- $(cmake-utils_use_enable fast FAST)
- $(cmake-utils_use_enable fetk FETK)
- $(cmake-utils_use_enable mpi MPI)
- $(cmake-utils_use_enable python PYTHON)
+ -DENABLE_DEBUG=$(usex debug)
+ -DENABLE_VERBOSE_DEBUG=$(usex debug)
+ -DENABLE_FAST=$(usex fast)
+ -DENABLE_FETK=$(usex fetk)
+ -DENABLE_MPI=$(usex mpi)
+ -DENABLE_PYTHON=$(usex python)
# ENABLE_TINKER: Enable TINKER support
- $(cmake-utils_use_enable iapbs iAPBS)
+ -DENABLE_iAPBS=$(usex iapbs)
# MAX_MEMORY: Set the maximum memory (in MB) to be used for a job
)
cmake-utils_src_configure
diff --git a/sci-chemistry/apbs/files/apbs-1.4.1-manip.patch b/sci-chemistry/apbs/files/apbs-1.4.1-manip.patch
index 378223397594..090a27d8a5a6 100644
--- a/sci-chemistry/apbs/files/apbs-1.4.1-manip.patch
+++ b/sci-chemistry/apbs/files/apbs-1.4.1-manip.patch
@@ -3,10 +3,10 @@
apbs/tools/mesh/CMakeLists.txt | 4 ++--
4 files changed, 5 insertions(+), 9 deletions(-)
-diff --git a/apbs/CMakeLists.txt b/apbs/CMakeLists.txt
+diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8917fc4..5152008 100644
---- a/apbs/CMakeLists.txt
-+++ b/apbs/CMakeLists.txt
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
@@ -293,7 +293,7 @@ option(ENABLE_FETK "Enable the finite element solver" OFF)
if(ENABLE_FETK)
@@ -16,10 +16,10 @@ index 8917fc4..5152008 100644
list(APPEND APBS_LIBS "-lstdc++")
list(APPEND APBS_LIBS "-L${FETK_PATH}/lib")
-diff --git a/apbs/tools/manip/CMakeLists.txt b/apbs/tools/manip/CMakeLists.txt
+diff --git a/tools/manip/CMakeLists.txt b/tools/manip/CMakeLists.txt
index 937dac7..5768cc5 100644
---- a/apbs/tools/manip/CMakeLists.txt
-+++ b/apbs/tools/manip/CMakeLists.txt
+--- a/tools/manip/CMakeLists.txt
++++ b/tools/manip/CMakeLists.txt
@@ -4,9 +4,9 @@ set(LIBS "")
list(APPEND LIBS "apbs_generic")
list(APPEND LIBS "apbs_mg")
@@ -32,10 +32,10 @@ index 937dac7..5768cc5 100644
message(STATUS "libraries: ${LIBS}")
-diff --git a/apbs/tools/mesh/CMakeLists.txt b/apbs/tools/mesh/CMakeLists.txt
+diff --git a/tools/mesh/CMakeLists.txt b/tools/mesh/CMakeLists.txt
index 1406377..6e6dfb9 100644
---- a/apbs/tools/mesh/CMakeLists.txt
-+++ b/apbs/tools/mesh/CMakeLists.txt
+--- a/tools/mesh/CMakeLists.txt
++++ b/tools/mesh/CMakeLists.txt
@@ -4,9 +4,9 @@ set(LIBS "")
list(APPEND LIBS "apbs_generic")
list(APPEND LIBS "apbs_mg")
diff --git a/sci-chemistry/apbs/files/apbs-1.4.1-python.patch b/sci-chemistry/apbs/files/apbs-1.4.1-python.patch
index db9f86ba120a..5ad6613615f2 100644
--- a/sci-chemistry/apbs/files/apbs-1.4.1-python.patch
+++ b/sci-chemistry/apbs/files/apbs-1.4.1-python.patch
@@ -7,10 +7,10 @@
apbs/tools/python/setup.py | 16 ++++++++++++++++
7 files changed, 26 insertions(+), 8 deletions(-)
-diff --git a/apbs/contrib/iapbs/src/apbs_driver.c b/apbs/contrib/iapbs/src/apbs_driver.c
+diff --git a/contrib/iapbs/src/apbs_driver.c b/contrib/iapbs/src/apbs_driver.c
index c9e443b..e1ad67f 100644
---- a/apbs/contrib/iapbs/src/apbs_driver.c
-+++ b/apbs/contrib/iapbs/src/apbs_driver.c
+--- a/contrib/iapbs/src/apbs_driver.c
++++ b/contrib/iapbs/src/apbs_driver.c
@@ -595,7 +595,7 @@ int apbsdrv_(
printPBEPARM(pbeparm);
@@ -38,10 +38,10 @@ index c9e443b..e1ad67f 100644
}
bytesTotal = Vmem_bytesTotal();
highWater = Vmem_highWaterTotal();
-diff --git a/apbs/src/CMakeLists.txt b/apbs/src/CMakeLists.txt
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 44d20fa..2577343 100644
---- a/apbs/src/CMakeLists.txt
-+++ b/apbs/src/CMakeLists.txt
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
@@ -68,6 +68,7 @@ configure_file(
if(ENABLE_iAPBS)
@@ -50,10 +50,10 @@ index 44d20fa..2577343 100644
INSTALL(TARGETS apbs_routines DESTINATION ${LIBRARY_INSTALL_PATH})
INSTALL(FILES apbscfg.h DESTINATION ${HEADER_INSTALL_PATH})
endif()
-diff --git a/apbs/tools/CMakeLists.txt b/apbs/tools/CMakeLists.txt
+diff --git a/tools/CMakeLists.txt b/tools/CMakeLists.txt
index 1982a3c..4acbe68 100644
---- a/apbs/tools/CMakeLists.txt
-+++ b/apbs/tools/CMakeLists.txt
+--- a/tools/CMakeLists.txt
++++ b/tools/CMakeLists.txt
@@ -4,5 +4,5 @@ add_subdirectory(mesh)
add_subdirectory(manip)
@@ -61,17 +61,17 @@ index 1982a3c..4acbe68 100644
- add_subdirectory(manip)
+ add_subdirectory(python)
endif(ENABLE_PYTHON)
-diff --git a/apbs/tools/python/CMakeLists.txt b/apbs/tools/python/CMakeLists.txt
+diff --git a/tools/python/CMakeLists.txt b/tools/python/CMakeLists.txt
new file mode 100644
index 0000000..8b13789
--- /dev/null
-+++ b/apbs/tools/python/CMakeLists.txt
++++ b/tools/python/CMakeLists.txt
@@ -0,0 +1 @@
+
-diff --git a/apbs/tools/python/apbslib.c b/apbs/tools/python/apbslib.c
+diff --git a/tools/python/apbslib.c b/tools/python/apbslib.c
index fef5cc8..feaaa2c 100644
---- a/apbs/tools/python/apbslib.c
-+++ b/apbs/tools/python/apbslib.c
+--- a/tools/python/apbslib.c
++++ b/tools/python/apbslib.c
@@ -2504,8 +2504,8 @@ static swig_module_info swig_module = {swig_types, 24, 0, 0, 0, 0};
#include "maloc/maloc.h"
#include "apbscfg.h"
@@ -83,10 +83,10 @@ index fef5cc8..feaaa2c 100644
#include <limits.h>
-diff --git a/apbs/tools/python/apbslib.i b/apbs/tools/python/apbslib.i
+diff --git a/tools/python/apbslib.i b/tools/python/apbslib.i
index 17fe521..44d05ea 100644
---- a/apbs/tools/python/apbslib.i
-+++ b/apbs/tools/python/apbslib.i
+--- a/tools/python/apbslib.i
++++ b/tools/python/apbslib.i
@@ -15,8 +15,8 @@ Header files:
#include "maloc/maloc.h"
#include "apbscfg.h"
@@ -98,11 +98,11 @@ index 17fe521..44d05ea 100644
%}
/*
-diff --git a/apbs/tools/python/setup.py b/apbs/tools/python/setup.py
+diff --git a/tools/python/setup.py b/tools/python/setup.py
new file mode 100644
index 0000000..4a20198
--- /dev/null
-+++ b/apbs/tools/python/setup.py
++++ b/tools/python/setup.py
@@ -0,0 +1,16 @@
+from distutils.core import setup, Extension
+setup(name='apbs',