summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-07-18 10:27:04 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-07-18 14:13:03 +0200
commit29c4f43687a258c733921ee58e3d625351fbfca4 (patch)
treecaf36046c8c087810e9092d660ba0f181178e7d4 /sci-electronics/gazebo
parentdev-libs/urdfdom_headers: bump to 0.4.2 (diff)
downloadgentoo-29c4f43687a258c733921ee58e3d625351fbfca4.tar.gz
gentoo-29c4f43687a258c733921ee58e3d625351fbfca4.tar.bz2
gentoo-29c4f43687a258c733921ee58e3d625351fbfca4.zip
sci-electronics/gazebo: bump to 7.3.1
Package-Manager: portage-2.3.0
Diffstat (limited to 'sci-electronics/gazebo')
-rw-r--r--sci-electronics/gazebo/Manifest1
-rw-r--r--sci-electronics/gazebo/gazebo-7.3.1.ebuild73
2 files changed, 74 insertions, 0 deletions
diff --git a/sci-electronics/gazebo/Manifest b/sci-electronics/gazebo/Manifest
index a53315e8d9a4..1cfa60bb8272 100644
--- a/sci-electronics/gazebo/Manifest
+++ b/sci-electronics/gazebo/Manifest
@@ -1 +1,2 @@
DIST gazebo-7.2.0.tar.bz2 51084680 SHA256 3e10501379236146f5393fcf02be419ce343bfa76b0f6670d43cc5bc13cd6fb1 SHA512 b484ef589fbcbe3262b257a6741f253ba23837c3585f42a857e7b03acf6dcbf7209a65f1fce9e4ee6df3b8a45a5124015c99e8708644f259e6d1275bbadab503 WHIRLPOOL 595146621ed9f6bbeecb325fddcacf048fadaff69338c2c8cefccb6e82669494d92000ae194e0a1941094491be3ec759165e8f8220fb7649cdb209ee66e5b60a
+DIST gazebo-7.3.1.tar.bz2 50992794 SHA256 aeff031d9b1b72c94b06b2a87790e6b561f4cba0e1dce155269108b3237e5c62 SHA512 2ecf89efd5312efe2d7c2b27c898467b49f94e2dbe75c69c2e403262e11361bea0a701a61134bbbfe01f1723621e5ccfc44c6d40698c7c2e8608292e275b5ea5 WHIRLPOOL 50886561eb6d8fffaabeb90466ddee1ed57aefc9b9d8ef4d65cc9a311355a8abea62034289dcd15bbf185c697bda1575d2365f80b52f8922af734dbd5586f37f
diff --git a/sci-electronics/gazebo/gazebo-7.3.1.ebuild b/sci-electronics/gazebo/gazebo-7.3.1.ebuild
new file mode 100644
index 000000000000..c3b8b54a0534
--- /dev/null
+++ b/sci-electronics/gazebo/gazebo-7.3.1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils versionator vcs-snapshot flag-o-matic
+
+DESCRIPTION="A 3D multiple robot simulator with dynamics"
+HOMEPAGE="http://gazebosim.org/"
+SRC_URI="http://osrf-distributions.s3.amazonaws.com/gazebo/releases/${P}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="cpu_flags_x86_sse2 libav test"
+
+RDEPEND="
+ =dev-libs/protobuf-2*:=
+ virtual/opengl
+ media-libs/openal
+ net-misc/curl
+ dev-libs/tinyxml
+ dev-libs/tinyxml2
+ dev-libs/libtar
+ dev-cpp/tbb
+ >=dev-games/ogre-1.7.4
+ sci-libs/libccd
+ libav? ( >=media-video/libav-9:0= )
+ !libav? ( >=media-video/ffmpeg-2.6:0= )
+ sci-libs/gts
+ >=sci-physics/bullet-2.82
+ >=dev-libs/sdformat-4.1:=
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ dev-qt/qtwebkit:4
+ dev-qt/qtxmlpatterns:4
+ dev-libs/boost:=[threads]
+ sci-libs/gdal
+ virtual/libusb:1
+ dev-libs/libspnav
+ media-libs/freeimage
+ sci-libs/hdf5:=
+ sys-apps/util-linux
+ media-gfx/graphviz
+ >=sci-libs/ignition-math-2.3:2=
+ net-libs/ignition-transport:=
+"
+DEPEND="${RDEPEND}
+ dev-qt/qttest:4
+ app-text/ronn
+ virtual/pkgconfig
+ x11-apps/mesa-progs
+ test? ( dev-libs/libxslt )
+"
+CMAKE_BUILD_TYPE=RelWithDebInfo
+
+src_configure() {
+ # doesnt build without it
+ append-cxxflags "-std=c++11"
+ # doesnt build with as-needed either
+ append-ldflags "-Wl,--no-as-needed"
+
+ local mycmakeargs=(
+ "-DUSE_UPSTREAM_CFLAGS=OFF"
+ "-DSSE2_FOUND=$(usex cpu_flags_x86_sse2 TRUE FALSE)"
+ "-DUSE_HOST_CFLAGS=FALSE"
+ "-DENABLE_TESTS_COMPILATION=$(usex test TRUE FALSE)"
+ "-DENABLE_SCREEN_TESTS=FALSE"
+ "-DUSE_EXTERNAL_TINYXML2=TRUE"
+ )
+ cmake-utils_src_configure
+}