summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-electronics/plcedit
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-electronics/plcedit')
-rw-r--r--sci-electronics/plcedit/Manifest1
-rw-r--r--sci-electronics/plcedit/files/plcedit-2.2.1-gcc47.patch15
-rw-r--r--sci-electronics/plcedit/metadata.xml12
-rw-r--r--sci-electronics/plcedit/plcedit-2.2.1.ebuild43
4 files changed, 71 insertions, 0 deletions
diff --git a/sci-electronics/plcedit/Manifest b/sci-electronics/plcedit/Manifest
new file mode 100644
index 000000000000..80bdc0c21bee
--- /dev/null
+++ b/sci-electronics/plcedit/Manifest
@@ -0,0 +1 @@
+DIST plcedit-2.2.1.tar.gz 2855243 SHA256 c38be06f538d253052418308ae739e3230a3fb96c57126a1d52b0ea80dbaddfa SHA512 dee6dedd6b7fcd979311fa25e694b53eb9588bf713b9638a3e1355a155c467974c5cc41c4375d4f9f104e9c850024ba51a643011a107e21abbfbfc38c2dae7c2 WHIRLPOOL b6f2ec9e78754067ef1e8b7336f65d1617224b822b4f3cafad4d23e2504233bc68de4fa5d30413577e5a848a519ddf1746d5512757481c4f7383c8296d439e94
diff --git a/sci-electronics/plcedit/files/plcedit-2.2.1-gcc47.patch b/sci-electronics/plcedit/files/plcedit-2.2.1-gcc47.patch
new file mode 100644
index 000000000000..046a27cbac8c
--- /dev/null
+++ b/sci-electronics/plcedit/files/plcedit-2.2.1-gcc47.patch
@@ -0,0 +1,15 @@
+ https://bugs.gentoo.org/450856
+
+ src/singleapp/qtlocalpeer.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+--- a/src/singleapp/qtlocalpeer.cpp
++++ b/src/singleapp/qtlocalpeer.cpp
+@@ -57,6 +57,7 @@ static PProcessIdToSessionId pProcessIdToSessionId = 0;
+ #endif
+ #if defined(Q_OS_UNIX)
+ #include <time.h>
++#include <unistd.h>
+ #endif
+
+ namespace QtLP_Private {
diff --git a/sci-electronics/plcedit/metadata.xml b/sci-electronics/plcedit/metadata.xml
new file mode 100644
index 000000000000..d5f9562e2df2
--- /dev/null
+++ b/sci-electronics/plcedit/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>qt</herd>
+<maintainer>
+<email>hwoarang@gentoo.org</email>
+<name>Markos Chandras</name>
+</maintainer>
+<longdescription lang="en">
+</longdescription>
+</pkgmetadata>
+
diff --git a/sci-electronics/plcedit/plcedit-2.2.1.ebuild b/sci-electronics/plcedit/plcedit-2.2.1.ebuild
new file mode 100644
index 000000000000..47a22e7be235
--- /dev/null
+++ b/sci-electronics/plcedit/plcedit-2.2.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit eutils versionator qt4-r2
+MY_PN="PLCEdit"
+
+DESCRIPTION="Qt4 notepad for PLC programming"
+HOMEPAGE="http://www.qt-apps.org/content/show.php/PLCEdit?content=78380"
+#upstreams default tarball is quite messy. Better repack it myself :/
+SRC_URI="http://dev.gentoo.org/~hwoarang/distfiles/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="debug doc"
+
+RDEPEND="dev-qt/qtgui:4"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc47.patch
+
+ if use doc; then
+ sed -i -e "/helpDir =/s:Help:html:" \
+ -e "s:(QApplication\:\:applicationDirPath():\"/usr/share/doc/${PF}\":g" \
+ -e "/ + helpDir/s:helpDir):helpDir:" \
+ src/helpwidget.cpp
+ fi
+ qt4-r2_src_prepare
+}
+
+src_install() {
+ newbin release/${MY_PN} ${PN} || die "dobin failed"
+ newicon src/ressources/images/icon.png ${PN}.png
+ make_desktop_entry ${PN} ${MY_PN} ${PN} 'Qt;Electronics'
+ dodoc readme.txt || die "dodoc failed"
+ if use doc; then
+ dohtml -r Docs/html/* || die "dohtml failed"
+ fi
+}