summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc Schiffbauer <mschiff@gentoo.org>2016-12-30 22:37:32 +0100
committerMarc Schiffbauer <mschiff@gentoo.org>2016-12-31 00:03:18 +0100
commit4fcba282c4c48ea4083c95f711889ccee249312f (patch)
treee60e9a5c8c3da9c0126b76b6a93a9f1a55977127 /sci-geosciences
parentapp-emulation/wine: update to use multilib_foreach_abi in src_install (diff)
downloadgentoo-4fcba282c4c48ea4083c95f711889ccee249312f.tar.gz
gentoo-4fcba282c4c48ea4083c95f711889ccee249312f.tar.bz2
gentoo-4fcba282c4c48ea4083c95f711889ccee249312f.zip
sci-geosciences/opencpn-plugin-gxradar: added new plugin
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/opencpn-plugin-gxradar/Manifest1
-rw-r--r--sci-geosciences/opencpn-plugin-gxradar/metadata.xml15
-rw-r--r--sci-geosciences/opencpn-plugin-gxradar/opencpn-plugin-gxradar-1.1.ebuild38
-rw-r--r--sci-geosciences/opencpn-plugin-gxradar/opencpn-plugin-gxradar-9999.ebuild38
4 files changed, 92 insertions, 0 deletions
diff --git a/sci-geosciences/opencpn-plugin-gxradar/Manifest b/sci-geosciences/opencpn-plugin-gxradar/Manifest
new file mode 100644
index 000000000000..cffcf8cb9f15
--- /dev/null
+++ b/sci-geosciences/opencpn-plugin-gxradar/Manifest
@@ -0,0 +1 @@
+DIST opencpn-plugin-gxradar-1.1.tar.gz 297126 SHA256 7f4dca4feb4e705b880cd8779b9689725173ce5e5a08a8b3fb57cc1cf04fb9e5 SHA512 16b361e664323d125872628291bf97c6ac29caee4bae09ec256180aa66591bf9c66b7bdc38cd6d3c0988ed295148c0691bb8e511b5a9b9b6b34046dd419c9d7e WHIRLPOOL 59ce158b72298eae37a5c46f9d902689c3072646fe33af29331af2976dde712a9234fd7d5df7868fc8f1db0b6c310f4d27441a8a35dae34adde4547df7b5db62
diff --git a/sci-geosciences/opencpn-plugin-gxradar/metadata.xml b/sci-geosciences/opencpn-plugin-gxradar/metadata.xml
new file mode 100644
index 000000000000..d8606ec694c7
--- /dev/null
+++ b/sci-geosciences/opencpn-plugin-gxradar/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mschiff@gentoo.org</email>
+ <name>Marc Schiffbauer</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci-geosciences@gentoo.org</email>
+ <name>Gentoo Geosciences Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">trudK45/gxradar_pi</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-geosciences/opencpn-plugin-gxradar/opencpn-plugin-gxradar-1.1.ebuild b/sci-geosciences/opencpn-plugin-gxradar/opencpn-plugin-gxradar-1.1.ebuild
new file mode 100644
index 000000000000..fa31d46c8630
--- /dev/null
+++ b/sci-geosciences/opencpn-plugin-gxradar/opencpn-plugin-gxradar-1.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+WX_GTK_VER="3.0"
+MY_PN="gxradar_pi"
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/trudK45/${MY_PN}.git"
+ inherit git-r3 cmake-utils wxwidgets
+ KEYWORDS=""
+else
+ SRC_URI="
+ https://github.com/trudK45/${MY_PN}/archive/v.${PV}.tar.gz -> ${P}.tar.gz
+ "
+ inherit cmake-utils wxwidgets
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${MY_PN}-v.${PV}"
+fi
+
+DESCRIPTION="Garmin xHD Radar Plugin for OpenCPN"
+HOMEPAGE="https://github.com/trudK45/gxradar_pi"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ x11-libs/wxGTK:${WX_GTK_VER}
+ >=sci-geosciences/opencpn-4.2.0
+ sys-devel/gettext
+"
+DEPEND="${RDEPEND}"
+src_prepare() {
+ need-wxwidgets unicode
+ cmake-utils_src_prepare
+}
diff --git a/sci-geosciences/opencpn-plugin-gxradar/opencpn-plugin-gxradar-9999.ebuild b/sci-geosciences/opencpn-plugin-gxradar/opencpn-plugin-gxradar-9999.ebuild
new file mode 100644
index 000000000000..01ad84dc49d6
--- /dev/null
+++ b/sci-geosciences/opencpn-plugin-gxradar/opencpn-plugin-gxradar-9999.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+WX_GTK_VER="3.0"
+MY_PN="gxradar_pi"
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/trudK45/${MY_PN}.git"
+ inherit git-r3 cmake-utils wxwidgets
+ KEYWORDS=""
+else
+ SRC_URI="
+ https://github.com/trudK45/${MY_PN}/archive/v.${PV}.tar.gz -> ${P}.tar.gz
+ "
+ inherit cmake-utils wxwidgets
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${MY_PN}-${PV}"
+fi
+
+DESCRIPTION="Garmin xHD Radar Plugin for OpenCPN"
+HOMEPAGE="https://github.com/trudK45/gxradar_pi"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ x11-libs/wxGTK:${WX_GTK_VER}
+ >=sci-geosciences/opencpn-4.2.0
+ sys-devel/gettext
+"
+DEPEND="${RDEPEND}"
+src_prepare() {
+ need-wxwidgets unicode
+ cmake-utils_src_prepare
+}