summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2017-05-13 16:47:22 +0100
committerJustin Lecher <jlec@gentoo.org>2017-05-13 17:02:08 +0100
commitbaf4cd355603557dca40cb50bbc6dcde328c053b (patch)
treeee44c2713938bc282c8dd8a4f6ccff929c9cb451 /sci-libs/chemkit
parentcdrom.eclass: Fix matching of entries with trailing /, bug #618344 (diff)
downloadgentoo-baf4cd355603557dca40cb50bbc6dcde328c053b.tar.gz
gentoo-baf4cd355603557dca40cb50bbc6dcde328c053b.tar.bz2
gentoo-baf4cd355603557dca40cb50bbc6dcde328c053b.zip
sci-libs/chemkit: Fix exmaple installation
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=617798 Package-Manager: Portage-2.3.5, Repoman-2.3.2 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'sci-libs/chemkit')
-rw-r--r--sci-libs/chemkit/chemkit-0.1-r1.ebuild7
-rw-r--r--sci-libs/chemkit/chemkit-0.1.ebuild65
2 files changed, 5 insertions, 67 deletions
diff --git a/sci-libs/chemkit/chemkit-0.1-r1.ebuild b/sci-libs/chemkit/chemkit-0.1-r1.ebuild
index a92f1547d664..b620a1e9f7fd 100644
--- a/sci-libs/chemkit/chemkit-0.1-r1.ebuild
+++ b/sci-libs/chemkit/chemkit-0.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -75,7 +75,10 @@ src_test() {
}
src_install() {
- use examples && dobin demos/*-viewer/*-viewer examples/uff-energy/uff-energy
+ use examples && \
+ dobin \
+ "${BUILD_DIR}"/demos/*-viewer/*-viewer \
+ "${BUILD_DIR}"/examples/uff-energy/uff-energy
cmake-utils_src_install
}
diff --git a/sci-libs/chemkit/chemkit-0.1.ebuild b/sci-libs/chemkit/chemkit-0.1.ebuild
deleted file mode 100644
index bf48e5d95d46..000000000000
--- a/sci-libs/chemkit/chemkit-0.1.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit cmake-utils multilib python-single-r1 virtualx
-
-DESCRIPTION="Library for chemistry applications"
-HOMEPAGE="http://www.chemkit.org/"
-SRC_URI="mirror://sourceforge/project/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="BSD"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="applications examples python test"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}
- test? ( applications python )"
-
-RDEPEND="
- dev-libs/boost
- dev-cpp/eigen:3
- dev-qt/qtcore:4
- dev-qt/qtgui:4
- dev-qt/qtopengl:4
- media-libs/glu
- examples? (
- x11-libs/libX11
- x11-libs/libXext
- )
- python? ( ${PYTHON_DEPS} )
-"
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}"/${PN}
-
-PATCHES=(
- "${FILESDIR}"/${P}-multilib.patch
- )
-
-src_configure() {
- local mycmakeargs=(
- -DCHEMKIT_BUILD_PLUGIN_BABEL=on
- $(cmake-utils_use applications CHEMKIT_BUILD_APPS)
- $(cmake-utils_use applications CHEMKIT_BUILD_QT_DESIGNER_PLUGINS)
- $(cmake-utils_use examples CHEMKIT_BUILD_EXAMPLES)
- $(cmake-utils_use examples CHEMKIT_BUILD_DEMOS)
- $(cmake-utils_use python CHEMKIT_BUILD_BINDINGS_PYTHON)
- $(cmake-utils_use test CHEMKIT_BUILD_TESTS)
- )
- cmake-utils_src_configure
-}
-
-src_test() {
- VIRTUALX_COMMAND="cmake-utils_src_test"
- virtualmake
-}
-
-src_install() {
- use examples && dobin demos/*-viewer/*-viewer examples/uff-energy/uff-energy
-
- cmake-utils_src_install
-}