summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/coinor-alps
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/coinor-alps')
-rw-r--r--sci-libs/coinor-alps/Manifest1
-rw-r--r--sci-libs/coinor-alps/coinor-alps-1.4.9.ebuild67
-rw-r--r--sci-libs/coinor-alps/metadata.xml13
3 files changed, 81 insertions, 0 deletions
diff --git a/sci-libs/coinor-alps/Manifest b/sci-libs/coinor-alps/Manifest
new file mode 100644
index 000000000000..d887e6751455
--- /dev/null
+++ b/sci-libs/coinor-alps/Manifest
@@ -0,0 +1 @@
+DIST Alps-1.4.9.tgz 5564207 SHA256 b1d1636ed16b3a3982d7bc547da9713657cd22cbc3ed4d4323ec63af04d139d2 SHA512 b8f557d33f3d02d0bf98541309934eeebebd21829fe1e2a438b07e6e17f0a1de1a970ed97b28cdaddc8b14eb1092a86db4d44838cef70bae3d091cd48fe8e2d8 WHIRLPOOL dddf890622d44f0c42278a15e0ac979cc6faa9cfa9b26b47fcc785de709098a044bd68d2fe81671b0ab5bae268c18f2ad8b00741bdf96ec7779ce76bf71fc352
diff --git a/sci-libs/coinor-alps/coinor-alps-1.4.9.ebuild b/sci-libs/coinor-alps/coinor-alps-1.4.9.ebuild
new file mode 100644
index 000000000000..e19f534b7070
--- /dev/null
+++ b/sci-libs/coinor-alps/coinor-alps-1.4.9.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils multilib
+
+MYPN=Alps
+
+DESCRIPTION="COIN-OR Framework for implementing parallel graph search algorithms"
+HOMEPAGE="https://projects.coin-or.org/CHiPPS/"
+SRC_URI="http://www.coin-or.org/download/source/${MYPN}/${MYPN}-${PV}.tgz"
+
+LICENSE="CPL-1.0"
+SLOT="0/3"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples static-libs test"
+
+RDEPEND="
+ sci-libs/coinor-utils:=
+ sci-libs/coinor-clp:="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen[dot] )
+ test? ( sci-libs/coinor-sample sci-libs/coinor-cgl )"
+
+S="${WORKDIR}/${MYPN}-${PV}/${MYPN}"
+
+src_prepare() {
+ # as-needed fix
+ # hack to avoid eautoreconf (coinor has its own weird autotools)
+ sed -i \
+ -e 's:\(libAlps_la_LIBADD.*=\).*:\1 @ALPSLIB_LIBS@:g' \
+ src/Makefile.in || die
+ # bug for later versions of subversions
+ sed -i \
+ -e 's/xexported/xexported -a "x$svn_rev_tmp" != "xUnversioned directory"/' \
+ configure || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-dependency-linking
+ $(use_with doc dot)
+ )
+ PKG_CONFIG_PATH+="${ED}"/usr/$(get_libdir)/pkgconfig \
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile all $(usex doc doxydoc "")
+}
+
+src_test() {
+ autotools-utils_src_test test
+}
+
+src_install() {
+ use doc && HTML_DOC=("${BUILD_DIR}/doxydocs/html/.")
+ autotools-utils_src_install
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}
diff --git a/sci-libs/coinor-alps/metadata.xml b/sci-libs/coinor-alps/metadata.xml
new file mode 100644
index 000000000000..56d981f3f91c
--- /dev/null
+++ b/sci-libs/coinor-alps/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<longdescription lang="en">
+ CHiPPS is the COIN-OR High-Performance Parallel Search Framework, a
+ framework for implementing parallel algorithms based on tree
+ search. The current CHiPPS architecture consists of three
+ layers. The Abstract Library for Parallel Search (ALPS) is the base
+ layer of a hierarchy consisting of implementations of various tree
+ search algorithms for specific problem types.
+</longdescription>
+</pkgmetadata>