summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/coot-data
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/coot-data')
-rw-r--r--sci-libs/coot-data/Manifest1
-rw-r--r--sci-libs/coot-data/coot-data-2-r1.ebuild33
-rw-r--r--sci-libs/coot-data/coot-data-2.ebuild33
-rw-r--r--sci-libs/coot-data/metadata.xml5
4 files changed, 72 insertions, 0 deletions
diff --git a/sci-libs/coot-data/Manifest b/sci-libs/coot-data/Manifest
new file mode 100644
index 000000000000..b07cf5e53def
--- /dev/null
+++ b/sci-libs/coot-data/Manifest
@@ -0,0 +1 @@
+DIST reference-structures-2.tar.gz 6728787 SHA256 44db38506f0f90c097d4855ad81a82a36b49cd1e3ffe7d6ee4728b15109e281a SHA512 7ebe28a619a577b18fc66e714f0bc8347121ebb12f372ac29c1d2d96013e608632921ea26caea3b62744252ae356949de8e04a6513f1a1e0ba30865708c26ffe WHIRLPOOL 59a730017e67687c5d6399252af57f2f97f3197f1b4fd371cf2530f417d1dee7cd6e8792e1a6ce65e619e0b5c2d4c0eaee75ebc822e0c0c9a399e1faeff4d630
diff --git a/sci-libs/coot-data/coot-data-2-r1.ebuild b/sci-libs/coot-data/coot-data-2-r1.ebuild
new file mode 100644
index 000000000000..1640d461d019
--- /dev/null
+++ b/sci-libs/coot-data/coot-data-2-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Data for the Crystallographic Object-Oriented Toolkit"
+HOMEPAGE="http://www.biop.ox.ac.uk/coot/"
+#SRC_URI="http://lmb.bioch.ox.ac.uk/coot/software/dependencies/reference-structures.tar.gz"
+SRC_URI="mirror://gentoo/reference-structures-${PV}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE=""
+
+RESTRICT="binchecks strip"
+
+S="${WORKDIR}"
+
+src_install() {
+ insinto /usr/share/coot
+ doins -r reference-structures
+
+ # Coot looks in the wrong spot for the monomer library
+ # Listens to ccp4's CCP4_LIB rather than CLIBD_MON
+ cat >> "${T}"/coot <<- EOF
+ COOT_REFMAC_LIB_DIR="${EPREFIX}/usr/share/ccp4/"
+ COOT_REF_STRUCTS="${EPREFIX}/usr/share/coot/reference-structures/"
+ EOF
+
+ newenvd "${T}"/coot 20coot
+}
diff --git a/sci-libs/coot-data/coot-data-2.ebuild b/sci-libs/coot-data/coot-data-2.ebuild
new file mode 100644
index 000000000000..2b7d33178adb
--- /dev/null
+++ b/sci-libs/coot-data/coot-data-2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+DESCRIPTION="Data for the Crystallographic Object-Oriented Toolkit"
+HOMEPAGE="http://www.biop.ox.ac.uk/coot/"
+#SRC_URI="http://www.ysbl.york.ac.uk/~emsley/software/extras/reference-structures.tar.gz"
+SRC_URI="mirror://gentoo/reference-structures-${PV}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE=""
+
+RESTRICT="binchecks strip"
+
+S="${WORKDIR}"
+
+src_install() {
+ insinto /usr/share/coot
+ doins -r reference-structures || die
+
+ # Coot looks in the wrong spot for the monomer library
+ # Listens to ccp4's CCP4_LIB rather than CLIBD_MON
+ cat >> "${T}"/coot <<- EOF
+ COOT_REFMAC_LIB_DIR="${EPREFIX}/usr/share/ccp4/"
+ COOT_REF_STRUCTS="${EPREFIX}/usr/share/coot/reference-structures/"
+ EOF
+
+ newenvd "${T}"/coot 20coot || die
+}
diff --git a/sci-libs/coot-data/metadata.xml b/sci-libs/coot-data/metadata.xml
new file mode 100644
index 000000000000..51fdedab1b38
--- /dev/null
+++ b/sci-libs/coot-data/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-chemistry</herd>
+</pkgmetadata>