summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/libtifiles2
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/libtifiles2')
-rw-r--r--sci-libs/libtifiles2/Manifest2
-rw-r--r--sci-libs/libtifiles2/libtifiles2-1.1.5.ebuild45
-rw-r--r--sci-libs/libtifiles2/libtifiles2-1.1.6-r1.ebuild48
-rw-r--r--sci-libs/libtifiles2/metadata.xml15
4 files changed, 110 insertions, 0 deletions
diff --git a/sci-libs/libtifiles2/Manifest b/sci-libs/libtifiles2/Manifest
new file mode 100644
index 000000000000..d8dc21124273
--- /dev/null
+++ b/sci-libs/libtifiles2/Manifest
@@ -0,0 +1,2 @@
+DIST libtifiles2-1.1.5.tar.bz2 460500 SHA256 4e701c98863c778c3f6fa465e426af23df88c9feee6fc9a9ca224a629a91e274
+DIST libtifiles2-1.1.6.tar.bz2 390447 SHA256 ec4d6acd1d135ee04256d04a5e1512c1ccaf82ad01e48f5e24d5c4da31ce898f SHA512 abc40275e7af921a67b658c6b6aa8ec511e965a3e9e00fcdc676c2b85e1d95dbae0f118e127e0806950d26afde9949251e47eb85af04d8f8ecca777dc3afcd23 WHIRLPOOL 40b6973ccdf141f4079790a40731997bd93518284007d16c2fca5e4d54ffab900f72394111471b4174f37fcddefbcff9bde7e0709e19f88c86b9cd8fd5664554
diff --git a/sci-libs/libtifiles2/libtifiles2-1.1.5.ebuild b/sci-libs/libtifiles2/libtifiles2-1.1.5.ebuild
new file mode 100644
index 000000000000..3f09fda75956
--- /dev/null
+++ b/sci-libs/libtifiles2/libtifiles2-1.1.5.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit multilib
+
+DESCRIPTION="Library for TI calculator files"
+HOMEPAGE="http://lpg.ticalc.org/prj_tilp/"
+SRC_URI="mirror://sourceforge/tilp/tilp2-linux/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc nls static-libs"
+
+RDEPEND="dev-libs/glib:2
+ >=sci-libs/libticables2-1.3.3
+ >=sci-libs/libticonv-1.1.3
+ nls? ( virtual/libintl )"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+DOCS=( AUTHORS LOGO NEWS README ChangeLog docs/api.txt )
+
+src_prepare() {
+ sed -e '/define _ZLIBIOAPI_H/ a#define OF(x) x' \
+ -i src/minizip/ioapi.h || die #403387
+}
+
+src_configure() {
+ econf \
+ --disable-rpath \
+ $(use_enable nls) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ use doc && dohtml docs/html/*
+ use static-libs || rm -f "${D}"/usr/$(get_libdir)/${PN}.la
+}
diff --git a/sci-libs/libtifiles2/libtifiles2-1.1.6-r1.ebuild b/sci-libs/libtifiles2/libtifiles2-1.1.6-r1.ebuild
new file mode 100644
index 000000000000..bd6695db915d
--- /dev/null
+++ b/sci-libs/libtifiles2/libtifiles2-1.1.6-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils
+
+DESCRIPTION="Library for TI calculator files"
+HOMEPAGE="http://lpg.ticalc.org/prj_tilp/"
+SRC_URI="mirror://sourceforge/tilp/tilp2-linux/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc nls static-libs"
+
+RDEPEND="
+ app-arch/libarchive
+ dev-libs/glib:2
+ >=sci-libs/libticables2-1.3.3
+ >=sci-libs/libticonv-1.1.3
+ nls? ( virtual/libintl )"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+DOCS=( AUTHORS LOGO NEWS README ChangeLog docs/api.txt )
+
+src_prepare() {
+ cd src
+ sed -i -e "s|types\*.h|$(echo types*.h)|" Makefile.in || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-rpath
+ $(use_enable nls)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+ use doc && dohtml docs/html/*
+}
diff --git a/sci-libs/libtifiles2/metadata.xml b/sci-libs/libtifiles2/metadata.xml
new file mode 100644
index 000000000000..1ba180601ff8
--- /dev/null
+++ b/sci-libs/libtifiles2/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <longdescription lang="en">
+ The libtifiles is a library providing support for operations on Texas
+ Instruments calculators files. All formats for all calculators are
+ supported read/write ; the library is also able to manipulate the
+ group files, which means it is able to group and ungroup variables
+ into such group files.
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">tilp</remote-id>
+ </upstream>
+</pkgmetadata>