summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <junghans@gentoo.org>2018-05-31 18:21:54 -0600
committerChristoph Junghans <junghans@gentoo.org>2018-05-31 18:22:31 -0600
commit46f559e11bea962d98030a2c440fa13c6656daab (patch)
treee53ec4aca0e8b45c8cf1950594c5f01a0dc17fe4 /sci-libs/lmfit
parentsci-visualization/paraview: fix a silly mistake (diff)
downloadgentoo-46f559e11bea962d98030a2c440fa13c6656daab.tar.gz
gentoo-46f559e11bea962d98030a2c440fa13c6656daab.tar.bz2
gentoo-46f559e11bea962d98030a2c440fa13c6656daab.zip
sci-libs/lmfit: initial import from science overlay
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'sci-libs/lmfit')
-rw-r--r--sci-libs/lmfit/Manifest3
-rw-r--r--sci-libs/lmfit/files/lmfit-7.0-cmake.patch66
-rw-r--r--sci-libs/lmfit/lmfit-5.1.ebuild24
-rw-r--r--sci-libs/lmfit/lmfit-6.4.ebuild24
-rw-r--r--sci-libs/lmfit/lmfit-7.0.ebuild25
-rw-r--r--sci-libs/lmfit/metadata.xml11
6 files changed, 153 insertions, 0 deletions
diff --git a/sci-libs/lmfit/Manifest b/sci-libs/lmfit/Manifest
new file mode 100644
index 000000000000..a40aaa40c8eb
--- /dev/null
+++ b/sci-libs/lmfit/Manifest
@@ -0,0 +1,3 @@
+DIST lmfit-5.1.tgz 345077 BLAKE2B df27621745601ffacd2110b28f3e3ea2b06d4c8c3c8fad5dda13bb4d6c2bd9f2a793ff88fab4f6d8c78075278bb26f3f424bd0074095e67ab1780a9d57b72b4b SHA512 1df6ed51d7f2137529793948f6c57ef3658932c9198776925a9f6e1d586352651c93aa053a064db7a201dbb848a7108f284223feff45171d142087539d834b29
+DIST lmfit-6.4.tgz 388809 BLAKE2B 48aa619642ac3fd009ec6a8f8b44ee4c800fc3f33e2603b557218cdf37c789159dc3947a648d560b9e2dd7fef08a6644fd25ac61505859dc3b1d151eeea58c27 SHA512 2bd0f24dd4638345b8b1ce6803ddcf45ca3ef888eb285e99f9f158c2e30b0f96016d9d84a112cdbf28f2ba98470e54fe773416179a65264426043c9a5186757d
+DIST lmfit-7.0.tgz 37950 BLAKE2B a509110f70e7e863d1172b8d91f7439763f0434702f265751e9955494f4982b4c17f0baaa080af86e5cae7f535555e27b98b45ba6a529061d107e53bdb9fd698 SHA512 78f479786c6e5c417781c6d629f5a517335fac70df049fafdefd511485da4e542c988d69c998f96eaab4306160de4bb09a631ca6ffff74bba70c51428d734fc3
diff --git a/sci-libs/lmfit/files/lmfit-7.0-cmake.patch b/sci-libs/lmfit/files/lmfit-7.0-cmake.patch
new file mode 100644
index 000000000000..9ca4efb248e9
--- /dev/null
+++ b/sci-libs/lmfit/files/lmfit-7.0-cmake.patch
@@ -0,0 +1,66 @@
+From 4e66272e1f5ebb220af517ca4d8804936f7f465c Mon Sep 17 00:00:00 2001
+From: Christoph Junghans <junghans@votca.org>
+Date: Thu, 31 May 2018 18:11:26 -0600
+Subject: [PATCH] cmake: minor distribution tweaks
+
+- Use GNUInstallDirs to allow to configure install dirs
+- Allow to disable injecting c flags
+
+Signed-off-by: Christoph Junghans <junghans@votca.org>
+---
+ CMakeLists.txt | 7 +++++--
+ lib/CMakeLists.txt | 4 ++--
+ man/CMakeLists.txt | 2 +-
+ 3 files changed, 8 insertions(+), 5 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index f2d0bdf..75753d3 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -13,9 +13,12 @@ set(lmfit_VERSION ${lmfit_SOVERSION}.0) # lib version
+ # --- Declare project-wide user flags, and set default values ---
+ option(FITTEST "Build with FitTest" OFF)
+
+-set(destination ${CMAKE_INSTALL_PREFIX})
++include(GNUInstallDirs)
+
+-set(CMAKE_C_FLAGS "${CMAKE_CXX_FLAGS} -g -O2 -pedantic -Wall -Wno-sign-compare -Wno-unused-result -Wno-parentheses -Wno-unknown-pragmas -Werror")
++option(INJECT_C_FLAGS "Inject a bunch of useful c flags" ON)
++if (INJECT_C_FLAGS)
++ set(CMAKE_C_FLAGS "${CMAKE_CXX_FLAGS} -g -O2 -pedantic -Wall -Wno-sign-compare -Wno-unused-result -Wno-parentheses -Wno-unknown-pragmas -Werror")
++endif()
+
+ add_subdirectory(lib)
+ add_subdirectory(demo)
+diff --git a/lib/CMakeLists.txt b/lib/CMakeLists.txt
+index 51b79bb..754f60f 100644
+--- a/lib/CMakeLists.txt
++++ b/lib/CMakeLists.txt
+@@ -17,9 +17,9 @@ target_link_libraries(${library_name} m)
+
+ install(
+ TARGETS ${library_name} LIBRARY
+- DESTINATION ${destination}/lib
++ DESTINATION ${CMAKE_INSTALL_LIBDIR}
+ COMPONENT Libraries)
+ install(
+ FILES ${inc_files}
+- DESTINATION ${destination}/include
++ DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}
+ COMPONENT Headers)
+diff --git a/man/CMakeLists.txt b/man/CMakeLists.txt
+index a718d3d..4a15597 100644
+--- a/man/CMakeLists.txt
++++ b/man/CMakeLists.txt
+@@ -15,7 +15,7 @@ function(one_page pname section)
+ )
+ install(
+ FILES ${CMAKE_CURRENT_BINARY_DIR}/${pname}.${section}
+- DESTINATION "${CMAKE_INSTALL_PREFIX}/man/man${section}"
++ DESTINATION "${CMAKE_INSTALL_MANDIR}/man${section}"
+ )
+ endfunction()
+
+--
+2.16.4
+
diff --git a/sci-libs/lmfit/lmfit-5.1.ebuild b/sci-libs/lmfit/lmfit-5.1.ebuild
new file mode 100644
index 000000000000..5cc8fa8bda4d
--- /dev/null
+++ b/sci-libs/lmfit/lmfit-5.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils
+
+DESCRIPTION="library for Levenberg-Marquardt least-squares minimization and curve fitting"
+HOMEPAGE="http://apps.jcns.fz-juelich.de/doku/sc/lmfit"
+SRC_URI="http://apps.jcns.fz-juelich.de/src/lmfit/old/${P}.tgz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="static-libs"
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}
diff --git a/sci-libs/lmfit/lmfit-6.4.ebuild b/sci-libs/lmfit/lmfit-6.4.ebuild
new file mode 100644
index 000000000000..5cc8fa8bda4d
--- /dev/null
+++ b/sci-libs/lmfit/lmfit-6.4.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils
+
+DESCRIPTION="library for Levenberg-Marquardt least-squares minimization and curve fitting"
+HOMEPAGE="http://apps.jcns.fz-juelich.de/doku/sc/lmfit"
+SRC_URI="http://apps.jcns.fz-juelich.de/src/lmfit/old/${P}.tgz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="static-libs"
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}
diff --git a/sci-libs/lmfit/lmfit-7.0.ebuild b/sci-libs/lmfit/lmfit-7.0.ebuild
new file mode 100644
index 000000000000..e895f1f06889
--- /dev/null
+++ b/sci-libs/lmfit/lmfit-7.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="library for Levenberg-Marquardt least-squares minimization and curve fitting"
+HOMEPAGE="http://apps.jcns.fz-juelich.de/doku/sc/lmfit"
+SRC_URI="http://apps.jcns.fz-juelich.de/src/lmfit/${P}.tgz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+PATCHES=( "${FILESDIR}/${P}-cmake.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ -DINJECT_C_FLAGS=OFF
+ )
+
+ cmake-utils_src_configure
+}
diff --git a/sci-libs/lmfit/metadata.xml b/sci-libs/lmfit/metadata.xml
new file mode 100644
index 000000000000..2550df8221b6
--- /dev/null
+++ b/sci-libs/lmfit/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">lmfit</remote-id>
+ </upstream>
+</pkgmetadata>