summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-01-23 21:04:50 +0100
committerDavid Seifert <soap@gentoo.org>2016-01-23 21:05:15 +0100
commit0513f4a6ef96b4b7c73d8504740d091ddb84cc75 (patch)
treebf646973487d14273394d4be366ef9c0a0469095 /sci-libs/netcdf-fortran/netcdf-fortran-4.4.3.ebuild
parentsci-libs/netcdf-cxx: Add USE=hdf5 dependency on sci-libs/netcdf (diff)
downloadgentoo-0513f4a6ef96b4b7c73d8504740d091ddb84cc75.tar.gz
gentoo-0513f4a6ef96b4b7c73d8504740d091ddb84cc75.tar.bz2
gentoo-0513f4a6ef96b4b7c73d8504740d091ddb84cc75.zip
sci-libs/netcdf-fortran: Version bump to 4.4.3
* EAPI=6 * Remove usage of 'autotools-utils' Package-Manager: portage-2.2.27
Diffstat (limited to 'sci-libs/netcdf-fortran/netcdf-fortran-4.4.3.ebuild')
-rw-r--r--sci-libs/netcdf-fortran/netcdf-fortran-4.4.3.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/sci-libs/netcdf-fortran/netcdf-fortran-4.4.3.ebuild b/sci-libs/netcdf-fortran/netcdf-fortran-4.4.3.ebuild
new file mode 100644
index 000000000000..5b6e55d51f04
--- /dev/null
+++ b/sci-libs/netcdf-fortran/netcdf-fortran-4.4.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+FORTRAN_STANDARD="77 90"
+
+inherit autotools eutils fortran-2
+
+DESCRIPTION="Scientific library and interface for array oriented data access"
+HOMEPAGE="http://www.unidata.ucar.edu/software/netcdf/"
+SRC_URI="https://github.com/Unidata/netcdf-fortran/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="UCAR-Unidata"
+SLOT="0/6"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples static-libs"
+
+RDEPEND="sci-libs/netcdf"
+DEPEND="${RDEPEND}
+ dev-lang/cfortran
+"
+
+src_prepare() {
+ # use system cfortran
+ rm libsrc/cfortran.h || die
+
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+ prune_libtool_files
+}