summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/nfft
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/nfft')
-rw-r--r--sci-libs/nfft/Manifest1
-rw-r--r--sci-libs/nfft/metadata.xml9
-rw-r--r--sci-libs/nfft/nfft-3.2.3.ebuild32
3 files changed, 42 insertions, 0 deletions
diff --git a/sci-libs/nfft/Manifest b/sci-libs/nfft/Manifest
new file mode 100644
index 000000000000..51833b3917aa
--- /dev/null
+++ b/sci-libs/nfft/Manifest
@@ -0,0 +1 @@
+DIST nfft-3.2.3.tar.gz 3977407 SHA256 5c920f4be63230083756f36ad78bbdd083c4c2298ec361741dc74243c4d67818 SHA512 d7b3345e0917e8dad9931adc5974f3412a82feda2d43925fe83fa4027f36cf037d4e185da85c53c87dc2e56a72f28c52b6b6a7ac56275d96888238a95610949e WHIRLPOOL 83e3445ed58a3b711762664f1776672239b51e085a4b52b90c47b2643445963697243ca6e36250f3a15576b36fb4dccb2772e867190393f0e7e9dc09873cc0dd
diff --git a/sci-libs/nfft/metadata.xml b/sci-libs/nfft/metadata.xml
new file mode 100644
index 000000000000..119d0fde1940
--- /dev/null
+++ b/sci-libs/nfft/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <maintainer>
+ <email>ottxor@gentoo.org</email>
+ <name>Christoph Junghans</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/sci-libs/nfft/nfft-3.2.3.ebuild b/sci-libs/nfft/nfft-3.2.3.ebuild
new file mode 100644
index 000000000000..e6f5802bab27
--- /dev/null
+++ b/sci-libs/nfft/nfft-3.2.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit autotools-utils toolchain-funcs
+
+DESCRIPTION="library for nonequispaced discrete Fourier transformations"
+HOMEPAGE="http://www-user.tu-chemnitz.de/~potts/nfft"
+SRC_URI="http://www-user.tu-chemnitz.de/~potts/nfft/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="openmp static-libs"
+
+RDEPEND="sci-libs/fftw:3.0[threads,openmp?]"
+DEPEND="${RDEPEND}"
+
+pkg_pretend() {
+ use openmp && ! tc-has-openmp && \
+ die "Please switch to an openmp compatible compiler"
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-all
+ $(use_enable openmp)
+ )
+ autotools-utils_src_configure
+}