summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-10-08 13:52:21 +0200
committerDavid Seifert <soap@gentoo.org>2016-10-08 14:12:50 +0200
commit5d36e49753e6a6b13250384226f3f6c93f9a0d0d (patch)
tree40237f8c44649584713d0b1b9948ba1fb9c37310 /sci-libs/scipy
parentdev-python/numpy: Version bump to 1.11.2 (diff)
downloadgentoo-5d36e49753e6a6b13250384226f3f6c93f9a0d0d.tar.gz
gentoo-5d36e49753e6a6b13250384226f3f6c93f9a0d0d.tar.bz2
gentoo-5d36e49753e6a6b13250384226f3f6c93f9a0d0d.zip
sci-libs/scipy: Version bump to 0.18.1
Package-Manager: portage-2.3.1
Diffstat (limited to 'sci-libs/scipy')
-rw-r--r--sci-libs/scipy/Manifest3
-rw-r--r--sci-libs/scipy/scipy-0.18.1.ebuild147
2 files changed, 150 insertions, 0 deletions
diff --git a/sci-libs/scipy/Manifest b/sci-libs/scipy/Manifest
index 615f27d073e7..74ff66727c3a 100644
--- a/sci-libs/scipy/Manifest
+++ b/sci-libs/scipy/Manifest
@@ -8,3 +8,6 @@ DIST scipy-0.16.1.tar.gz 12221561 SHA256 ecd1efbb1c038accb0516151d1e6679809c6010
DIST scipy-0.17.0-html.zip 27600230 SHA256 f7e4459d9797d7e83231926a15f667c9337fffa4a3cd6ec90c00c2290e4e0656 SHA512 30cb76490bb9b539f27bb874d86619e639322fd35c367a5f74057c510e4751a994052fef14916c166bde52c0599388587a50e8967a3d7aa52ada8f1500d8437e WHIRLPOOL 1edf0a97f87fc0f8d1467583a0e834bba86d2535b2f52ef5a3d97fc44016cf9ddb620953a51efe0b865ea029e3cdba147da4708c81e7daba5ce0811f5c5fe721
DIST scipy-0.17.0-ref.pdf 12206837 SHA256 67e4e1ff7b2ba5d92dee9fca71c332f686008356c24562e0608edad9c5ad9096 SHA512 49c7cdb153fb37985becbe13d9f491812bdcc8b98a4ebd71da9ca9519819161010615ec359d10494fc44164e5b961415e5d9d8b361f97b404ec4c6f1d9af2a50 WHIRLPOOL 86052b2e2f0a0e88e60e283f2f3cd551a95bda24a7839d71633e5b17da0ae4c025cdcc89a173da45e29728a754488243ac109d63d5ae68039f2f1d3d447a84bc
DIST scipy-0.17.0.tar.gz 12397929 SHA256 f600b755fb69437d0f70361f9e560ab4d304b1b66987ed5a28bdd9dd7793e089 SHA512 de6409d75a3ff3cf1e5391d3b09126f0bc7e1a40a15f9bee244195638fe2f8481fca032896d8534623e6122ff59aaf669664e27ff89cf1b094a5ce7312f220b7 WHIRLPOOL 9ebbb6bcdbf107882690998b83ac304889e077e7b866a31c1cd8c615785d5377964d9e4d75ac4589ad7aed7f392e5a59f892b55be5d12da12eb08811f6aaef10
+DIST scipy-0.18.1-html.zip 32907714 SHA256 b6118abf9af19318b566521c1944d93f0dec57a7e533641348e5338f790e1279 SHA512 fc61ce9a9dcc7091da29d35a42cc38074b0c4f5ff81d5ca5dea9c2d32e5e3ee1e8463fcb4e18c931c0c0e4f00410f8cd16d0f81c219fb326edc20d2286866e03 WHIRLPOOL 52fb21455beae1b75bb1aa24eed7d2227b52fe44bf81345fd56c12316d7c6887eccc10b551f64464da7fc034e453b06095c80c95f7baeae2374e6f256035cc18
+DIST scipy-0.18.1-ref.pdf 14824115 SHA256 c5bb8baac66c43450cab24d3fec3a4f626d51568ab311f712446b5946fe7a295 SHA512 e668420ae3668f459d15cb88765045c89df02f9c73854c8ddce8fe1611973e8c9d40ac49a1db0342282074b1d46b8156bb75430b7df079efd1c3a6ccb4bf2c37 WHIRLPOOL bf36c77059dff97402430df0721bbfe59c6e889d9c202e4a86e7f5b2cd2eb9f32115abcfaf47ceb847579bfe870707a6926d69c2c714d0655e60a9a3f7ee4103
+DIST scipy-0.18.1.tar.gz 13141689 SHA256 8ab6e9c808bf2fb3e8576cd8cf07226d9cdc18b012c06d9708429a821ac6634e SHA512 f2ee21c808141d8002f69e48e7cf006e36982b1a7041323a8f4d803a1de3d191ffcc40227aac351dd876c28843de366ef89e9cf84dc106fadac86a3f40491659 WHIRLPOOL 977729517cfaed931123484160b9f4e7949dd46c4124757c5cbfe8607f2da9ddc3ad260ac4fcd8b382b8a801a86340405eceb3ad5a48d1a3f23dd0faa0941b7e
diff --git a/sci-libs/scipy/scipy-0.18.1.ebuild b/sci-libs/scipy/scipy-0.18.1.ebuild
new file mode 100644
index 000000000000..6a86dca1c78f
--- /dev/null
+++ b/sci-libs/scipy/scipy-0.18.1.ebuild
@@ -0,0 +1,147 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
+PYTHON_REQ_USE="threads(+)"
+
+DOC_PV=${PV}
+
+inherit fortran-2 distutils-r1 flag-o-matic multiprocessing toolchain-funcs
+
+DESCRIPTION="Scientific algorithms library for Python"
+HOMEPAGE="https://www.scipy.org/"
+SRC_URI="
+ mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
+ doc? (
+ https://docs.scipy.org/doc/${PN}-${DOC_PV}/${PN}-html-${PV}.zip -> ${PN}-${DOC_PV}-html.zip
+ https://docs.scipy.org/doc/${PN}-${DOC_PV}/${PN}-ref-${PV}.pdf -> ${PN}-${DOC_PV}-ref.pdf
+ )"
+
+LICENSE="BSD LGPL-2"
+SLOT="0"
+IUSE="doc sparse test"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+
+CDEPEND="
+ >=dev-python/numpy-1.10[lapack,${PYTHON_USEDEP}]
+ sci-libs/arpack:0=
+ virtual/cblas
+ virtual/lapack
+ sparse? ( sci-libs/umfpack:0= )"
+DEPEND="${CDEPEND}
+ dev-lang/swig
+ >=dev-python/cython-0.22[${PYTHON_USEDEP}]
+ virtual/pkgconfig
+ doc? ( app-arch/unzip )
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+RDEPEND="${CDEPEND}
+ dev-python/pillow[${PYTHON_USEDEP}]"
+
+DOCS=( HACKING.rst.txt THANKS.txt )
+
+DISTUTILS_IN_SOURCE_BUILD=1
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.12.0-blitz.patch
+ "${FILESDIR}"/${PN}-0.12.0-restore-sys-argv.patch
+)
+
+src_unpack() {
+ default
+ if use doc; then
+ unzip -qo "${DISTDIR}"/${PN}-${DOC_PV}-html.zip -d html || die
+ fi
+}
+
+pc_incdir() {
+ $(tc-getPKG_CONFIG) --cflags-only-I $@ | \
+ sed -e 's/^-I//' -e 's/[ ]*-I/:/g' -e 's/[ ]*$//' -e 's|^:||'
+}
+
+pc_libdir() {
+ $(tc-getPKG_CONFIG) --libs-only-L $@ | \
+ sed -e 's/^-L//' -e 's/[ ]*-L/:/g' -e 's/[ ]*$//' -e 's|^:||'
+}
+
+pc_libs() {
+ $(tc-getPKG_CONFIG) --libs-only-l $@ | \
+ sed -e 's/[ ]-l*\(pthread\|m\)\([ ]\|$\)//g' \
+ -e 's/^-l//' -e 's/[ ]*-l/,/g' -e 's/[ ]*$//' \
+ | tr ',' '\n' | sort -u | tr '\n' ',' | sed -e 's|,$||'
+}
+
+python_prepare_all() {
+ # scipy automatically detects libraries by default
+ export {FFTW,FFTW3,UMFPACK}=None
+ use sparse && unset UMFPACK
+ # the missing symbols are in -lpythonX.Y, but since the version can
+ # differ, we just introduce the same scaryness as on Linux/ELF
+ [[ ${CHOST} == *-darwin* ]] \
+ && append-ldflags -bundle "-undefined dynamic_lookup" \
+ || append-ldflags -shared
+ [[ -z ${FC} ]] && export FC="$(tc-getFC)"
+ # hack to force F77 to be FC until bug #278772 is fixed
+ [[ -z ${F77} ]] && export F77="$(tc-getFC)"
+ export F90="${FC}"
+ export SCIPY_FCONFIG="config_fc --noopt --noarch"
+ append-fflags -fPIC
+
+ local libdir="${EPREFIX}"/usr/$(get_libdir)
+ cat >> site.cfg <<-EOF || die
+ [blas]
+ include_dirs = $(pc_incdir cblas)
+ library_dirs = $(pc_libdir cblas blas):${libdir}
+ blas_libs = $(pc_libs cblas blas)
+ [lapack]
+ library_dirs = $(pc_libdir lapack):${libdir}
+ lapack_libs = $(pc_libs lapack)
+ EOF
+
+ # Drop hashes to force rebuild of cython based .c code
+ rm cythonize.dat || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ ${EPYTHON} tools/cythonize.py || die
+ distutils-r1_python_compile \
+ $(usex python_targets_python3_5 "" "-j $(makeopts_jobs)") \
+ ${SCIPY_FCONFIG}
+}
+
+python_test() {
+ # fails with bdist_egg. should it be fixed in distutils-r1 eclass?
+ distutils_install_for_testing ${SCIPY_FCONFIG}
+ cd "${TEST_DIR}" || die "no ${TEST_DIR} available"
+ "${PYTHON}" -c \
+ 'import numpy as np; print("relaxed strides checking:", np.ones((10,1),order="C").flags.f_contiguous)' \
+ || die
+ # https://github.com/scipy/scipy/issues/5426
+ "${EPYTHON}" -c \
+ "import scipy, sys; r = scipy.test('fast', verbose=2, raise_warnings='release'); sys.exit(0 if r.wasSuccessful() else 1)" \
+ || die "Tests fail with ${EPYTHON}"
+# "${EPYTHON}" -c \
+# "import scipy, sys; r = scipy.test('fast',verbose=2); sys.exit(0 if r.wasSuccessful() else 1)" \
+# || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && \
+ local DOCS=( "${DISTDIR}"/${PN}*pdf ) \
+ local HTML_DOCS=( "${WORKDIR}"/html/. )
+ distutils-r1_python_install_all
+}
+
+python_install() {
+ distutils-r1_python_install ${SCIPY_FCONFIG}
+}
+
+pkg_postinst() {
+ elog "You might want to set the variable SCIPY_PIL_IMAGE_VIEWER"
+ elog "to your prefered image viewer. Example:"
+ elog "\t echo \"export SCIPY_PIL_IMAGE_VIEWER=display\" >> ~/.bashrc"
+}