summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-03-05 04:11:01 +0000
committerSam James <sam@gentoo.org>2023-03-05 04:11:46 +0000
commit6a387b91f1d468c450a1fa0382ed8e06805479e3 (patch)
tree9f6b907121143122e8553445698ec7f34073d78b /sci-libs
parentdev-libs/pegtl: add 3.2.7 (diff)
downloadgentoo-6a387b91f1d468c450a1fa0382ed8e06805479e3.tar.gz
gentoo-6a387b91f1d468c450a1fa0382ed8e06805479e3.tar.bz2
gentoo-6a387b91f1d468c450a1fa0382ed8e06805479e3.zip
sci-libs/arpack: add 3.9.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/arpack/Manifest1
-rw-r--r--sci-libs/arpack/arpack-3.9.0.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/sci-libs/arpack/Manifest b/sci-libs/arpack/Manifest
index 94121d526f10..ce9b7f1fd764 100644
--- a/sci-libs/arpack/Manifest
+++ b/sci-libs/arpack/Manifest
@@ -1,3 +1,4 @@
DIST arpack-3.8.0.tar.gz 1014494 BLAKE2B 6daf8a237fdfce527935d777292df150b2f78892d9975f8696a37024fcb78174b29afd300e7abca2684c1907eeda658eb4478f09f580835896c0e10d106cdbbd SHA512 8969c74c4c0459ea2d29ea49d5260f668fd33f73886df0da78a42a94aea93c9f5fb70f5df035266db68807ab09a92c13487a7a4e6ca64922145aade8a148a2de
+DIST arpack-3.9.0.tar.gz 1015328 BLAKE2B fc9960025140a9d6a570ee0359c16055c826482fe1ee58c2dc7727cd0ead04fbb940da0e08a6f11e05205d239b1059c93af0e08bf2b6e0cfee61d73f1d0d9816 SHA512 fbcaa2179dd1aa5a39fc3e7d80f377ec90ddf16ef93184a88e6ecfc464ed97e5659f2cf578294ac3e0b0c0da6408c86acf5bbdce533e1e9d2a3121848340d282
DIST tutorial.ps.gz 105599 BLAKE2B 99570e6a0cc1c020b9c271e8ce1cc224f69ff5333cc818c10b063dc8ffbaf66a9f5c6ede99541b4212286d422146b1c4e332eba7e1635c99efa0e4c2620f0630 SHA512 a7b8fefd1a572ed477ae208d49094c1c65c9368990d12de9b3528e33fed546c947659f74e54a810d04154b4a1b0f9a94bcba4db0cf59d379e20786a261066aa4
DIST ug.ps.gz 248543 BLAKE2B ac010aef470060636fa00360636ba093f0d24d219fa927c79fb1726b798160eda74fa8b4be6c7dff94f5759efcf30afa99ad310e7959115e028738beb8aa125d SHA512 3349117fb10b07207ffbab2ffa31b406d026855ea4c16e8649b14c7d70bc94e11b5730672e34acd654817799136d4bd76569ac50ec78d787df5582d18ed61328
diff --git a/sci-libs/arpack/arpack-3.9.0.ebuild b/sci-libs/arpack/arpack-3.9.0.ebuild
new file mode 100644
index 000000000000..cfd783760a46
--- /dev/null
+++ b/sci-libs/arpack/arpack-3.9.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools fortran-2 toolchain-funcs
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/opencollab/arpack-ng"
+else
+ SRC_URI="https://github.com/opencollab/${PN}-ng/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+ S="${WORKDIR}/${PN}-ng-${PV}"
+fi
+
+DESCRIPTION="Arnoldi package library to solve large scale eigenvalue problems"
+HOMEPAGE="http://www.caam.rice.edu/software/ARPACK/ https://github.com/opencollab/arpack-ng"
+LICENSE="BSD"
+SLOT="0"
+IUSE="examples mpi"
+
+RDEPEND="
+ virtual/blas
+ virtual/lapack
+ mpi? ( virtual/mpi[fortran] )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-static \
+ --with-blas="$($(tc-getPKG_CONFIG) --libs blas)" \
+ --with-lapack="$($(tc-getPKG_CONFIG) --libs lapack)" \
+ $(use_enable mpi)
+}
+
+src_install() {
+ default
+
+ dodoc DOCUMENTS/*.doc
+ newdoc DOCUMENTS/README README.doc
+ if use examples; then
+ dodoc -r EXAMPLES
+ if use mpi; then
+ docinto EXAMPLES/PARPACK
+ dodoc -r PARPACK/EXAMPLES/MPI
+ fi
+ fi
+
+ # no static archives
+ find "${ED}" -name '*.la' -delete || die
+}