summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2017-01-22 10:08:20 +0000
committerJustin Lecher <jlec@gentoo.org>2017-01-22 10:21:13 +0000
commit899170263f29d4bcc0f6e8e8a79ae3808c064c48 (patch)
treed153f4acdf30ace36ed03642e8fe4b027318bb81 /sci-libs
parentmedia-libs/audiofile: Stable for HPPA (bug #562886). (diff)
downloadgentoo-899170263f29d4bcc0f6e8e8a79ae3808c064c48.tar.gz
gentoo-899170263f29d4bcc0f6e8e8a79ae3808c064c48.tar.bz2
gentoo-899170263f29d4bcc0f6e8e8a79ae3808c064c48.zip
sci-libs/suitesparseconfig: Add 32bit support
Package-Manager: Portage-2.3.3, Repoman-2.3.1 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/suitesparseconfig/suitesparseconfig-4.2.1-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sci-libs/suitesparseconfig/suitesparseconfig-4.2.1-r1.ebuild b/sci-libs/suitesparseconfig/suitesparseconfig-4.2.1-r1.ebuild
new file mode 100644
index 000000000000..4a79daac9752
--- /dev/null
+++ b/sci-libs/suitesparseconfig/suitesparseconfig-4.2.1-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit multilib-minimal
+
+DESCRIPTION="Common configurations for all packages in suitesparse"
+HOMEPAGE="http://www.cise.ufl.edu/research/sparse/SuiteSparse_config"
+SRC_URI="https://dev.gentoo.org/~bicatali/distfiles/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="static-libs"
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" \
+ econf \
+ $(use_enable static-libs static)
+}
+
+multilib_src_install_all() {
+ if ! use static-libs; then
+ find "${ED}" -name "*.la" -delete || die
+ fi
+}