summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-12-13 21:15:09 +0100
committerMichał Górny <mgorny@gentoo.org>2018-12-13 21:52:17 +0100
commit4fae46a493d81fffc0495a55e449a54a6c71f7be (patch)
tree7127935b4c55c56464c674e4b10ac5b4b458748c /sci-mathematics
parentsci-mathematics/z3: Co-maintain (used by clang) (diff)
downloadgentoo-4fae46a493d81fffc0495a55e449a54a6c71f7be.tar.gz
gentoo-4fae46a493d81fffc0495a55e449a54a6c71f7be.tar.bz2
gentoo-4fae46a493d81fffc0495a55e449a54a6c71f7be.zip
sci-mathematics/z3: Bump to 4.8.3, major ebuild overhaul
Closes: https://bugs.gentoo.org/644508 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/z3/Manifest1
-rw-r--r--sci-mathematics/z3/z3-4.8.3.ebuild101
2 files changed, 102 insertions, 0 deletions
diff --git a/sci-mathematics/z3/Manifest b/sci-mathematics/z3/Manifest
index 8edc2db77832..135a75b7e230 100644
--- a/sci-mathematics/z3/Manifest
+++ b/sci-mathematics/z3/Manifest
@@ -1,2 +1,3 @@
DIST z3-4.4.1.tar.gz 3347371 BLAKE2B 57f090b891618613c4647a89620d12f2ac05ea110268e63b343594f53fa2cc7aa347781001e2778ea7dc1ce475c964ddeced7a82c304b4be706ad164fd17a285 SHA512 76991a24f47f2b53ceb8d7a9a6be19913c57994ffb6cf6acfe30f61b2e73959cf02a99f656053594fccb5aaf4d1f44b3ae7e51f1c8953b213d738ceeeaea74f8
DIST z3-4.5.0.tar.gz 3573695 BLAKE2B 285cc4d1f998d61ddb0b854044b7c79c1bb4cccf51bbdcba7c4a45698d74d9591f84d0aa74c5ef7c8aea2c6539ac987f29e326b44037e954108df67644dff594 SHA512 1ebc2c908d90b6b879f1e819c864ff894613276af47a440f27cf94968c195656952434754c3eb20f4bdbdd8497d227d22e1b4821c0d320b11052b5648d9e2dc7
+DIST z3-4.8.3.tar.gz 4119116 BLAKE2B 02535832a28ba09bb5b5c9354c77941bdce29fe977fa88d59e2e757fd6242b7d9ffcb0bbc0f9462ac7fd58bc29020be848b27311cf3f51cd60e84f66713a05e1 SHA512 34a2dca0083ed469fdaf5ac062dda26248633245607ddd9ef90629c5f76ae30f87bfa4191c04ba9be7a617bf182a1bd00b59fd2274699e12ece69b86088c8044
diff --git a/sci-mathematics/z3/z3-4.8.3.ebuild b/sci-mathematics/z3/z3-4.8.3.ebuild
new file mode 100644
index 000000000000..3a8136475a75
--- /dev/null
+++ b/sci-mathematics/z3/z3-4.8.3.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit cmake-utils python-single-r1 toolchain-funcs
+
+DESCRIPTION="An efficient theorem prover"
+HOMEPAGE="http://z3.codeplex.com/"
+SRC_URI="https://github.com/Z3Prover/z3/archive/${P}.tar.gz"
+
+SLOT="0/4.8"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples gmp isabelle java openmp python"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ gmp? ( dev-libs/gmp:0= )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ java? ( >=virtual/jdk-1.8 )"
+
+S=${WORKDIR}/${PN}-${P}
+
+CMAKE_BUILD_TYPE=RelWithDebInfo
+
+pkg_setup() {
+ python_setup
+
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ if use openmp && ! tc-has-openmp; then
+ ewarn "Please use an openmp compatible compiler"
+ ewarn "like >gcc-4.2 with USE=openmp"
+ die "Openmp support missing in compiler"
+ fi
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_DOCDIR="${EPREFIX}/usr/share/doc/${P}"
+ -DUSE_LIB_GMP=$(usex gmp)
+ -DUSE_OPENMP=$(usex openmp)
+ -DENABLE_EXAMPLE_TARGETS=OFF
+ -DBUILD_DOCUMENTATION=$(usex doc)
+ -DBUILD_PYTHON_BINDINGS=$(usex python)
+ -DBUILD_JAVA_BINDINGS=$(usex java)
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ local DOCS=( "README.md" "RELEASE_NOTES" )
+ cmake-utils_src_install
+
+ use examples && dodoc -r examples
+ use python && python_optimize
+
+ if use isabelle; then
+ insinto /usr/share/Isabelle/contrib/${P}/etc
+ newins - settings <<-EOF
+ Z3_COMPONENT="\$COMPONENT"
+ Z3_HOME="${EPREFIX}/usr/bin"
+ Z3_SOLVER="${EPREFIX}/usr/bin/z3"
+ Z3_REMOTE_SOLVER="z3"
+ Z3_VERSION="${PV}"
+ Z3_INSTALLED="yes"
+ Z3_NON_COMMERCIAL="yes"
+ EOF
+ fi
+}
+
+pkg_postinst() {
+ if use isabelle; then
+ if [[ -f ${ROOT%/}/etc/isabelle/components ]]; then
+ sed -e "/contrib\/${PN}-[0-9.]*/d" \
+ -i "${ROOT%/}/etc/isabelle/components" || die
+ cat <<-EOF >> "${ROOT%/}/etc/isabelle/components" || die
+ contrib/${P}
+ EOF
+ fi
+ fi
+}
+
+pkg_postrm() {
+ if use isabelle; then
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ if [[ -f "${ROOT%/}/etc/isabelle/components" ]]; then
+ # Note: this sed should only match the version of this ebuild
+ # Which is what we want as we do not want to remove the line
+ # of a new Isabelle component being installed during an upgrade.
+ sed -e "/contrib\/${P}/d" \
+ -i "${ROOT%/}/etc/isabelle/components" || die
+ fi
+ fi
+ fi
+}